Missing styles & can't log into index.pl

Moderator: crythias

Post Reply
ptay
OTRS expert
Posts: 85
Joined: 13 Jul 2010, 18:55
OTRS Version?: 5.0.10

Missing styles & can't log into index.pl

Post by ptay » 25 Jan 2011, 01:02

Anyone know why Agent index.pl page would display this error & I'm missing styles? I don't recall making any changes on CentOS/test box and it gives same errors.

Browser Warning
The browser you are using is too old. OTRS runs with a huge lists of browsers, please upgrade to one of these. Please see the documentation or ask your admin for further information.


The page has a login box and recover password page. It looks like no CSS / styles are applied to page.

This is happening on both production and test boxes.

I am using latest version of Firefox, Chrome, and IE7. Firefox displays the index.pl on production box but cannot interact with page at all.

The customer.pl pages show customer login pages and I can login & view links to tickets but there is no theme (straight looking html).
Last edited by ptay on 01 Feb 2011, 21:53, edited 2 times in total.
Test:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7
Prod:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7

User avatar
crythias
Moderator
Posts: 9980
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: Missing styles & can't log into index.pl

Post by crythias » 25 Jan 2011, 02:33

did you check your apache access and error logs?
If you see the too old, it's probably for the same reason: css isn't loading.

The "your browser is too old" shows when css isn't being used to hide the code.

Code: Select all

                <div class="WidgetSimple Hidden" id="OldBrowser">
                    <div class="Header">
                        <h2 class="Center">$Text{"Browser Warning"}</h2>
                    </div>
                    <div class="Content">
                        <p class="SpacingTop Center">
                            $Text{"The browser you are using is too old."}
                            $Text{"OTRS runs with a huge lists of browsers, please upgrade to one of these."}
                            $Text{"Please see the documentation or ask your admin for further information."}
                        </p>
                    </div>
                </div>
You can try

perl $OTRS_PATH/bin/otrs.DeleteCache.pl
perl $OTRS_PATH/bin/otrs.LoaderCache.pl

(this has been suggested regarding other topics, and hasn't had any disclaimers about being detrimental. http://forums.otrs.org/viewtopic.php?f=62&t=6746 )
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

ptay
OTRS expert
Posts: 85
Joined: 13 Jul 2010, 18:55
OTRS Version?: 5.0.10

Re: Missing styles & can't log into index.pl

Post by ptay » 25 Jan 2011, 17:10

I ran the cache scripts yesterday & ran them again this morning for sanity. No apparent impact on CSS.

Reading the logs I see no errors. I upgraded to 3.05 on test box this morning and still no CSS.

recent access log entries:

Code: Select all

10.10.10.5 - - [25/Jan/2011:08:57:24 -0600] "GET /otrs/customer.pl HTTP/1.1" 200 5752 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:27 -0600] "GET /otrs-web/skins/Customer/default/css-cache/CommonCSS_730f30987335baf638c9e410deb4445c.css HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/customer.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:27 -0600] "GET /otrs-web/skins/Customer/default/css/thirdparty/ui-theme/jquery-ui.css HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/customer.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:27 -0600] "GET /otrs-web/js/js-cache/CommonJS_91eb974bc587c3038346128f708ad023.js HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/customer.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:27 -0600] "GET /otrs-web/js/js-cache/ModuleJS_ba9426fbc9cd810a99143c96db224fc3.js HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/customer.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:27 -0600] "GET /otrs-web/skins/Agent/default/img/icons/product.ico HTTP/1.1" 200 98750 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:32 -0600] "GET /otrs/index.pl HTTP/1.1" 200 10699 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:34 -0600] "GET /otrs-web/skins/Agent/default/css/thirdparty/ui-theme/jquery-ui.css HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/index.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:34 -0600] "GET /otrs-web/js/js-cache/CommonJS_23b3e9570e67f14a324c90a75a20914b.js HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/index.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:34 -0600] "GET /otrs-web/skins/Agent/default/css-cache/CommonCSS_297af93777df25485f3baad3f3e00d96.css HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/index.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:34 -0600] "GET /otrs-web/js/js-cache/ModuleJS_0f306ffe9463644038f9af74655c43d3.js HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/index.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:34 -0600] "GET /otrs-web/skins/Agent/default/img/logo_bg.png HTTP/1.1" 200 98750 "http://10.10.10.100/otrs/index.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
10.10.10.5 - - [25/Jan/2011:08:57:34 -0600] "GET /otrs-web/skins/Agent/default/img/icons/product.ico HTTP/1.1" 200 98750 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10"
recent error_log entries:

Code: Select all

[Tue Jan 25 08:56:56 2011] [notice] SELinux policy enabled; httpd running as context user_u:system_r:httpd_t
[Tue Jan 25 08:56:56 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jan 25 08:56:56 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 25 08:56:56 2011] [notice] Digest: done
[Tue Jan 25 08:56:56 2011] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
Test:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7
Prod:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7

ptay
OTRS expert
Posts: 85
Joined: 13 Jul 2010, 18:55
OTRS Version?: 5.0.10

Re: Missing styles & can't log into index.pl

Post by ptay » 25 Jan 2011, 20:53

I removed OTRS from CentOS/test box then installed otrs-3.0.5-01.noarch.rpm.

When I run the http://10.10.10.100/otrs/installer.pl there is no CSS / styles & when I click Next... nothing happens.
Test:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7
Prod:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7

jojo
Moderator
Posts: 14291
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Missing styles & can't log into index.pl

Post by jojo » 25 Jan 2011, 21:01

try to switch off SELINUX
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

ptay
OTRS expert
Posts: 85
Joined: 13 Jul 2010, 18:55
OTRS Version?: 5.0.10

Re: [SOLVED]Missing styles & can't log into index.pl

Post by ptay » 25 Jan 2011, 22:30

I got CentOS / test box working now I'll try RHEL / production box.

I tried several things so I'm not sure which one exactly fixed the issue but I think these two were the standouts:

I found a mistake in my httpd.conf. Although Apache did not spit out any errors. I could enable / disable CSS/login problem in OTRS by enabling / disabling mod_info in httpd.conf incorrectly.

Proper syntax without restrictions:

Code: Select all

<Location /server-info>
SetHandler server-info
</Location>
Incorrect syntax without restrictions (notice missing the Location tags):

Code: Select all

SetHandler server-info

When I upgraded to 3.05 the CSS/login problem reappeared regardless of mod_info setting.

Even with SetHandler server-info disabled I was still experiencing CSS/login problem. After reading this post I ran the otrs.SetPermission.pl script and appears to have fixed the issue.

It's important to note I can reproduce the CSS/login problem on my CentOS box by enabling SetHandler server-info with incorrect syntax.
Test:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7
Prod:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7

Mitchal
OTRS newbie
Posts: 6
Joined: 27 Jan 2011, 04:35
OTRS Version?: 3.0.5

Re: [SOLVED]Missing styles & can't log into index.pl

Post by Mitchal » 27 Jan 2011, 04:43

I am having this issue in every browser except IE8.
My build is OTRS 3.0.5-01 on fedora 14 using mysql.
Firefox is 3.6.13
I have done a chown -R otrs:apache on /opt/otrs so that otrs and apache can write to the folder.
I have disabled SELinux.
I have tried the scripts listed above and in the linked post but still no luck in firefox.
It would suggest that the css stylesheets cannot be loaded but then why would it work in IE8 and nothing else. The other strange thing is that i can log in (the username and password fields aren't greyed out) which is what everybody else is posting.
Any help would be career saving.
Cheers,
Mitch

ptay
OTRS expert
Posts: 85
Joined: 13 Jul 2010, 18:55
OTRS Version?: 5.0.10

Re: [SOLVED]Missing styles & can't log into index.pl

Post by ptay » 31 Jan 2011, 18:03

Mitchal, any errors in httpd access or error logs? Are you able to post your httpd.conf file? My error was in httpd.conf. Not sure why one browser would work and the other one would not.

I fixed my RHEL when I fixed the mod_info syntax in httpd.conf.

Some folks upgrading to 3.05 have run into a CSS/stylesheet issue and fixed the issue by running the permissions script.

You have a previous full backup you can restore from to test if break happened after upgrade?
Test:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7
Prod:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7

Mitchal
OTRS newbie
Posts: 6
Joined: 27 Jan 2011, 04:35
OTRS Version?: 3.0.5

Re: [SOLVED]Missing styles & can't log into index.pl

Post by Mitchal » 01 Feb 2011, 05:00

Hi Ptay,
Thanks for your reply. I did a yum erase otrs to remove the package so i could do a fresh install. I have attached my httpd.conf file and copied the error logs data from my session this morning generated after the reinstallation.
/opt/httpd/logs/erro_log is as follows:

[Tue Feb 01 08:55:34 2011] [error] [client 10.27.18.180] Directory index forbidden by Options directive: /var/www/html/
[Tue Feb 01 09:37:19 2011] [error] [client 10.27.18.180] Directory index forbidden by Options directive: /var/www/html/
[Tue Feb 1 09:45:50 2011] -e: Use of uninitialized value in hash element at /opt/otrs//Kernel/Output/HTML/Layout.pm line 1364.
[Tue Feb 1 09:45:50 2011] -e: Use of uninitialized value in hash element at /opt/otrs//Kernel/Output/HTML/Layout.pm line 1369.
ERROR: OTRS-CGI-10 Perl: 5.12.2 OS: linux Time: Tue Feb 1 09:45:50 2011

Message: SecureMode active!

Traceback (15842):
Module: Kernel::Output::HTML::Layout::Error (v1.350) Line: 1121
Module: Kernel::System::Web::InterfaceInstaller::Run (v1.6) Line: 124
Module: ModPerl::ROOT::ModPerl::Registry::opt_otrs_bin_cgi_2dbin_installer_2epl::handler (unknown version) Line: 45
Module: (eval) (v1.33) Line: 204
Module: ModPerl::RegistryCooker::run (v1.33) Line: 204
Module: ModPerl::RegistryCooker::default_handler (v1.33) Line: 170
Module: ModPerl::Registry::handler (v1.99) Line: 31

[Tue Feb 01 09:53:43 2011] [notice] caught SIGTERM, shutting down
[Tue Feb 01 09:53:45 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Feb 01 09:53:46 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 01 09:53:46 2011] [notice] Digest: done
[Tue Feb 01 09:53:46 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_perl/2.0.4 Perl/v5.12.2 configured -- resuming normal operations
[Tue Feb 1 09:56:01 2011] -e: DBD::mysql::db do failed: Can't create database 'otrs'; database exists at /opt/otrs//Kernel/Modules/Installer.pm line 264.
Notice: Install /opt/otrs/Kernel/Output/HTML/Standard/AdminSupport.dtl (644)!
Notice: Install /opt/otrs/Kernel/Output/HTML/Standard/AdminSupportLicenseText.dtl (644)!
Notice: Install /opt/otrs/Kernel/System/Support.pm (644)!
Notice: Create Directory /opt/otrs/Kernel/System/Support!
Notice: Install /opt/otrs/Kernel/System/Support/Database.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/OS.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/OTRS.pm (644)!
Notice: Create Directory /opt/otrs/Kernel/System/Support/Webserver!
Notice: Install /opt/otrs/Kernel/System/Support/Webserver/IIS.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/Webserver/Apache.pm (644)!
Notice: Create Directory /opt/otrs/Kernel/System/Support/Database!
Notice: Install /opt/otrs/Kernel/System/Support/Database/oracle.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/Database/mssql.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/Database/postgresql.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/Database/mysql.pm (644)!
Notice: Install /opt/otrs/Kernel/System/Support/Webserver.pm (644)!
Notice: Create Directory /opt/otrs/Kernel/cpan-lib/Archive!
Notice: Create Directory /opt/otrs/Kernel/cpan-lib/Archive/Tar!
Notice: Install /opt/otrs/Kernel/cpan-lib/Archive/Tar/Constant.pm (644)!
Notice: Install /opt/otrs/Kernel/cpan-lib/Archive/Tar/File.pm (644)!
Notice: Install /opt/otrs/Kernel/cpan-lib/Archive/Tar.pm (644)!
Notice: Create Directory /opt/otrs/Kernel/cpan-lib/Linux!
Notice: Install /opt/otrs/Kernel/cpan-lib/Linux/Distribution.pm (644)!
Notice: Install /opt/otrs/Kernel/Modules/AdminSupport.pm (644)!
Notice: Install /opt/otrs/Kernel/Config/Files/Support.xml (644)!
Notice: Install /opt/otrs/var/httpd/htdocs/skins/Agent/default/css/Support.Default.css (644)!
Notice: CREATE TABLE support_bench_test (
name_a VARCHAR (60) NOT NULL,
name_b VARCHAR (60) NOT NULL,
INDEX support_index_bench_test_name_a (name_a)
)
[Tue Feb 1 09:58:21 2011] -e: DBD::mysql::db do failed: Got a packet bigger than 'max_allowed_packet' bytes at /opt/otrs//Kernel/System/DB.pm line 422.
ERROR: OTRS-CGI-10 Perl: 5.12.2 OS: linux Time: Tue Feb 1 09:58:21 2011

Message: Got a packet bigger than 'max_allowed_packet' bytes, SQL: 'INSERT INTO package_repository (name, version, vendor, filename, content_size, content_type, content, install_status, create_time, create_by, change_time, change_by) VALUES (?, ?, ?, ?, '213', 'text/xml', ?, 'not installed', current_timestamp, 1, current_timestamp, 1)'

Traceback (19016):
Module: Kernel::System::Package::RepositoryAdd (v1.119) Line: 284
Module: Kernel::System::Package::PackageInstall (v1.119) Line: 411
Module: (eval) (v1.119) Line: 1758
Module: Kernel::System::Package::PackageInstallDefaultFiles (v1.119) Line: 1757
Module: Kernel::Modules::Installer::Run (v1.86) Line: 593
Module: Kernel::System::Web::InterfaceInstaller::Run (v1.6) Line: 142
Module: ModPerl::ROOT::ModPerl::Registry::opt_otrs_bin_cgi_2dbin_installer_2epl::handler (unknown version) Line: 45
Module: (eval) (v1.33) Line: 204
Module: ModPerl::RegistryCooker::run (v1.33) Line: 204
Module: ModPerl::RegistryCooker::default_handler (v1.33) Line: 170
Module: ModPerl::Registry::handler (v1.99) Line: 31

Thank you so much for your time and any help you are able to offer.
Kind regards,
Mitch
You do not have the required permissions to view the files attached to this post.

ptay
OTRS expert
Posts: 85
Joined: 13 Jul 2010, 18:55
OTRS Version?: 5.0.10

Re: [SOLVED]Missing styles & can't log into index.pl

Post by ptay » 01 Feb 2011, 21:53

Most of the issues I notice are with OTRS and not Apache. Not sure how to fix them though, maybe someone else will chime in. I removed the [SOLVED] from main post so others may look at your issue also.


Areas of interest to me would be:
[Tue Feb 1 09:45:50 2011] -e: Use of uninitialized value in hash element at /opt/otrs//Kernel/Output/HTML/Layout.pm line 1364.
[Tue Feb 1 09:45:50 2011] -e: Use of uninitialized value in hash element at /opt/otrs//Kernel/Output/HTML/Layout.pm line 1369.
[Tue Feb 1 09:56:01 2011] -e: DBD::mysql::db do failed: Can't create database 'otrs'; database exists at /opt/otrs//Kernel/Modules/Installer.pm line 264.
Test:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7
Prod:: OTRS 5.0.10 w/MariaDB 5.5.47 backend on RHEL7

User avatar
crythias
Moderator
Posts: 9980
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: Missing styles & can't log into index.pl

Post by crythias » 01 Feb 2011, 22:39

the error says that the database "otrs" exists on install. If you're installing fresh, install as a different database name.
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

Mitchal
OTRS newbie
Posts: 6
Joined: 27 Jan 2011, 04:35
OTRS Version?: 3.0.5

Re: Missing styles & can't log into index.pl

Post by Mitchal » 02 Feb 2011, 01:41

Hi Ptay,
Thanks for the help. I have rectified the DB issue. (these errors were created when i tried to setup a new database without removing the "otrs" database from the previous install.)
The 2 other errors seem to be the issue i think. I have no idea where to go from here.
I would use IE if all my users also used IE but they all use firefox. All functionalty works perfect in IE.
Thanks again for your assistance on this one.
Anyone else who could offer some insight on this would be great.
Cheers,
Mitch

Mitchal
OTRS newbie
Posts: 6
Joined: 27 Jan 2011, 04:35
OTRS Version?: 3.0.5

Re: Missing styles & can't log into index.pl

Post by Mitchal » 07 Feb 2011, 02:02

Hi Guys,
I haven't been able to solve the problem but i did end up swapping distro's and trying again with that as i noticed on the otrs download page that it doesn't mention a package for anything above Fedora 11. Someone with a bit more experience in linux may be able to solve this issue but i know my in-house guru couldn't crack it.
Its now running on centos 5 and i installed from source rather than an rpm.
The only thing i can put it down to is an incompatability with fedora 14.
Thanks for your help guys.

nilskm
OTRS newbie
Posts: 6
Joined: 29 Sep 2010, 09:50
OTRS Version?: 3.0.0 beta4

Re: Missing styles & can't log into index.pl

Post by nilskm » 15 Aug 2011, 09:30

I received this error when otrs crashed casue to an overfilled harddrive. The solution for me was to upgrade to last version of otrs (3.0.9 in this case). I guess a file somewhere got corrupted by the crash and the upgrade fixed this.

sfault
OTRS newbie
Posts: 8
Joined: 21 Jun 2012, 11:57
OTRS Version?: 3.0.9
Real Name: Ara

Re: Missing styles & can't log into index.pl

Post by sfault » 23 Jul 2012, 04:07

I know this thread is somewhat dead as the last reply was August 2011.

I had the same problem just a while ago. Or maybe it has been a problem since I don't know when but I didn't know because I've always used Chrome. My colleague pointed out that OTRS was working fine in Chrome but not in Firefox. Wasn't able to try it on IE as I'm using Linux right now.

Anyway, what worked for me was to simply restart Apache. No errors encountered during the restart. Not sure what exactly happened but I installed PHP a few days ago (via yum install) and this was the only thing I changed in the system since last week of June. We're using v3.0.9, BTW.

Hope this helps someone. :)

User avatar
ndhvu275
OTRS wizard
Posts: 139
Joined: 06 Nov 2012, 09:02
OTRS Version?: 3.x, 4.x and 5.x
Real Name: Vu Nguyen
Company: INFOdation
Location: Netherlands
Contact:

Re: Missing styles & can't log into index.pl

Post by ndhvu275 » 23 Jan 2013, 11:16

Hi,

Above issue is reason you don't set permission for otrs folder (create and delete, default is access)
1-23-2013 4-14-25 PM.png
Hope it is helpful for you

Thanks,

Vu Nguyen
You do not have the required permissions to view the files attached to this post.
OTRS 3.x, 4.x on CentOS/Windows
MySQL database
External customer backend with MySQL, MSSQL
Customization

lamarchk
OTRS newbie
Posts: 14
Joined: 08 Jul 2013, 08:38
OTRS Version?: 3.1.12
Real Name: Jun Tiburcio
Company: Achieve Without Borders

Re: Missing styles & can't log into index.pl

Post by lamarchk » 27 Aug 2014, 06:26

Has anyone successfully fixed their OTRS installation using the steps above?

Kindly inform me as I am already in a bind with my OTRS installation, which has been down from yesterday.

Thanks.

wurzel
OTRS guru
Posts: 2440
Joined: 08 Jul 2010, 22:25
OTRS Version?: 6.0.x

Re: Missing styles & can't log into index.pl

Post by wurzel » 27 Aug 2014, 09:35

Hi,

if you are in trouble, restore to old version or try professional support from otrs.com

and you should not open two threads.

Florian
    ((OTRS)) Community Edition 6.0.x, LAMP LIVE auf Debian 9
    OTRS 6 Managed Silver

    -- Ich beantworte keine Forums-Fragen PN - No PN please

    I won't answer to unfriendly users any more. A greeting and regards are just polite.

    lamarchk
    OTRS newbie
    Posts: 14
    Joined: 08 Jul 2013, 08:38
    OTRS Version?: 3.1.12
    Real Name: Jun Tiburcio
    Company: Achieve Without Borders

    Re: Missing styles & can't log into index.pl

    Post by lamarchk » 27 Aug 2014, 10:11

    I'm sorry about opening this thread.

    I am still getting the hang of posting on User Forums such as this community.

    Thank you.

    myotrs
    OTRS newbie
    Posts: 11
    Joined: 15 Nov 2013, 18:52
    OTRS Version?: 4.0.5
    Real Name: Kuljeet Singh

    Re: Missing styles & can't log into index.pl

    Post by myotrs » 27 Aug 2015, 16:55

    Hi All,

    Well, I was also getting the same error (mentioned below) like others but somehow I think the browser "useragent" is not compare properly or not setup properly.

    "The browser you are using is too old. OTRS runs with a huge lists of browsers, please upgrade to one of these. Please see the documentation or ask your admin for further information."

    I have latest Mozilla Firefox installed i.e. 40.0 but still getting the error. I then looked at the "general.useragent.override" string in "about:config" and see the following:

    "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20150807 Firefox/4.0.0; xs-SkhvHDfPXbc;" -> "This string gives me the error".

    I changed the string to

    "Mozilla/5.0 (compatible; Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20150807 Firefox/4.0.0; xs-SkhvHDfPXbc;" -> "No error and OTRS works fine".

    I did not dig down further to see what may be the security risks for this setting. But currently it is working fine and will be looking at the risks for this setting.

    I hope this may help.

    Thank you,
    Kuljeet
    "Production": OTRS: 5.0.6
    "Dev | Test": OTRS: 5.0.6
    OS: DEV-> RHEL, PROD->RHEL
    Apache2.2.15/MySQL 5+

    ajbird
    OTRS newbie
    Posts: 1
    Joined: 15 Jan 2018, 16:23
    OTRS Version?: 3.2.8

    Re: Missing styles & can't log into index.pl

    Post by ajbird » 15 Jan 2018, 16:49

    just to add.. the only thing that fixed it for me was

    perl otrs.LoaderCache.pl -o delete

    again.. after a hard drive ran out of space

    itefectivos
    OTRS newbie
    Posts: 1
    Joined: 17 May 2018, 15:59
    OTRS Version?: 6.0.0.0
    Real Name: Rodrigo De la Peña
    Company: IT Efectivos S.A.S.

    Re: Missing styles & can't log into index.pl

    Post by itefectivos » 17 May 2018, 18:44

    i had the same problem in otrs6 runing out of space.

    tryied:
    su -c "/opt/otrs/bin/otrs.Console.pl Maint::Cache::Delete" -s /bin/bash otrs

    cache delete didint work becouse cache files where generated empty,

    i got it working by deleting empty files in
    /opt/otrs/var/httpd/htdocs/skins/Customer/default/css-cache
    /opt/otrs/var/httpd/htdocs/js/js-cache/

    Post Reply