OTRS UPgrade 6.0.19 to 6.0.28 Not Working

Moderator: crythias

Post Reply
pradeepspa
OTRS newbie
Posts: 60
Joined: 06 May 2016, 14:03
OTRS Version?: 3.0.5
Real Name: Pradeep

OTRS UPgrade 6.0.19 to 6.0.28 Not Working

Post by pradeepspa »

Hello Folks,

I am runninf OTRS COmmunity edition 6.0.19 on a centos-7 machine. I am trying to update it to the latest version 6.0.28. I am following below link for the update.
https://doc.otrs.com/doc/manual/admin/6 ... ating.html

After running "scripts/DBUpdate-to-6.pl" it says "Migration completed!"
perl -cw /opt/otrs/bin/cgi-bin/index.pl
/opt/otrs/bin/cgi-bin/index.pl syntax OK
However, I coudlnt access the gui and when i try i see this error under http logs.
[Tue May 19 12:58:14.408850 2020] [:error] [pid 28887] Attempt to reload Kernel/System/ObjectManager.pm aborted.\nCompilation failed in require at /opt/otrs/bin/cgi-bin/index.pl line 33.\nBEGIN failed--compilation aborted at /opt/otrs/bin/cgi-bin/index.pl line 33.\n
As per one of the suggestions from the forum, I tried this but no luck.
/opt/otrs/bin/otrs.SetPermissions.pl
Setting permissions on /opt/otrs
Any idea what could be causing this?

jojo
Moderator
Posts: 14738
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: OTRS UPgrade 6.0.19 to 6.0.28 Not Working

Post by jojo »

check if all needed Perl Modules are installed
"Production": OTRS™ 7, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) and git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

zzz
OTRS wizard
Posts: 505
Joined: 15 Dec 2016, 15:13
OTRS Version?: 3.x–6.0.x
Real Name: Emin
Company: Efflux GmbH
Contact:

Re: OTRS UPgrade 6.0.19 to 6.0.28 Not Working

Post by zzz »

Hey,

You're most likely missing Moo.
Use "yum install perl-Moo"

See bug: https://github.com/OTRS/otrs/commit/542 ... ac2bf8cf59

— Emin
Professional OTRS services for development, consulting, hosting and support:
efflux.de – German | efflux.de/en/ – English

Free and premium OTRS add-ons (TextModule, AdBlocker, ModernSkin, ModernSkinCustomer etc.): portal.efflux.de

pradeepspa
OTRS newbie
Posts: 60
Joined: 06 May 2016, 14:03
OTRS Version?: 3.0.5
Real Name: Pradeep

Re: OTRS UPgrade 6.0.19 to 6.0.28 Not Working

Post by pradeepspa »

Thanks for the response. I see I have installed all necessary modules which includes "MOO".
/opt/otrs/bin/otrs.CheckModules.pl
o Apache::DBI......................ok (v1.12)
o Apache2::Reload..................ok (v0.13)
o Archive::Tar.....................ok (v1.92)
o Archive::Zip.....................ok (v1.30)
o Crypt::Eksblowfish::Bcrypt.......ok (v0.009)
o Date::Format.....................ok (v2.24)
o DateTime.........................ok (v1.04)
o DateTime::TimeZone.............ok (v1.70)
Please consider updating to version 2.20 or higher: This version includes recent time zone changes for Chile.
o DBI..............................ok (v1.627)
o DBD::mysql.......................ok (v4.023)
o DBD::ODBC........................Not installed! (optional - Required to connect to a MS-SQL database.)
o DBD::Oracle......................Not installed! (optional - Required to connect to a Oracle database.)
o DBD::Pg..........................ok (v2.19.3)
o Digest::SHA......................ok (v5.85)
o Encode::HanExtra.................ok (v0.23)
o IO::Socket::SSL..................ok (v1.94)
Please consider updating to version 2.066 or higher: This version fixes email sending (bug#14357).
o JSON::XS.........................ok (v3.03)
o List::Util::XS...................ok (v1.27)
o LWP::UserAgent...................ok (v6.26)
o Mail::IMAPClient.................ok (v3.37)
o IO::Socket::SSL................ok (v1.94)
Please consider updating to version 2.066 or higher: This version fixes email sending (bug#14357).
o Authen::SASL...................ok (v2.15)
o Authen::NTLM...................ok (v1.09)
o ModPerl::Util....................ok (v2.000010)
o Net::DNS.........................ok (v0.72)
o Net::LDAP........................ok (v0.56)
o Moo..............................ok (v2.004000)
o Net::SMTP........................ok (v2.31)
Please consider updating to version 3.11 or higher: This version fixes email sending (bug#14357).
o Template.........................ok (v2.24)
o Template::Stash::XS..............ok (undef)
o Text::CSV_XS.....................ok (v1.00)
o Time::HiRes......................ok (v1.9725)
o XML::LibXML......................ok (v2.0018)
o XML::LibXSLT.....................ok (v1.80)
o XML::Parser......................ok (v2.41)
o YAML::XS.........................ok (v0.54)

skullz
OTRS expert
Posts: 251
Joined: 24 Feb 2012, 03:58
OTRS Version?: OTRS 6
Real Name: Skullz
Contact:

Re: OTRS UPgrade 6.0.19 to 6.0.28 Not Working

Post by skullz »

Can we see more log ?
perhaps another few lines before the one you just post above ?

Post Reply