Firmentickets mit LDAP-Customer Portal werden nicht angezeigt

Allgemein Fragen, deutsche News, Ankündigungen & Events zum OTRS
Post Reply
masterd01
OTRS newbie
Posts: 3
Joined: 14 Mar 2020, 12:28
OTRS Version?: OTRS 6 Com
Real Name: Daniel

Firmentickets mit LDAP-Customer Portal werden nicht angezeigt

Post by masterd01 »

Hallo zusammen,

ich habe vermutlich ein simples Problem, aber bisher hier keine Lösungen gefunden, die für mich greifen. Vielleicht ist es auch ein Verständnisproblem, bei dem ihr mir helfen könnt :-)
Wir nutzen OTRS als Ticketsystem für unsere Firma intern.
LDAP Sync-Module ist aktiv, Auth-Module mittels LDAP ist aktiv und auch das Customer:Auth-Module ist aktiv. Funktioniert auch alles wunderbar. Die Mitarbeiter können direkt über das Customer-Portal ihre Tickets melden.

Jetzt möchte ich für einige (nicht für alle) Abteilungen die Company-Tickets aktivieren. Heißt also User1, User2 und User3 sollen die Tickets untereinander im Customer-Portal sehen. Das soll allerdings NICHT über die AD gesteuert werden, sondern über die Firmen/Gruppenverwaltung.

Was ich getan habe:

1.) Ticket::Frontend::CustomerDisableCompanyTicketAccess --> ist nicht aktiv

2.) Kunde habe ich angelegt
[attachment=1]bild1.PNG[/attachment]

3.) Kundenbenutzer --> Kunde habe ich zugeordnet (Bild2)
[attachment=0]bild2.PNG[/attachment]

4.) Mit CustomerUserExcludePrimaryCustomerID => 1, habe ich rumgespielt, aber bis dato ohne erfolg. Ist aktuell inaktiv.

Ich weiß, dass mir an einer Stelle was fehlt. Aber wo genau? Ich stehe auf dem Schlauch :-(

Meine Config:

[quote] ### AD <==> DB OTRS (MySQL)
$Self->{'AuthSyncModule'} = 'Kernel::System::Auth::Sync::LDAP';
$Self->{'AuthSyncModule::LDAP::Host'} = 'XXXX.XXXX.local'; # AD SRV
$Self->{'AuthSyncModule::LDAP::BaseDN'} = 'dc=XXXX,DC=local'; # Domain
$Self->{'AuthSyncModule::LDAP::UID'} = 'sAMAccountName';
$Self->{'AuthModule::LDAP::GroupDN'} = 'CN=OTRS-Ticketsystembenutzer,OU=Gruppen,OU=Administration,DC=XXXX,DC=local'; #OTRS User group
$Self->{'AuthSyncModule::LDAP::SearchUserDN'} = 'LDAP';
$Self->{'AuthSyncModule::LDAP::SearchUserPw'} = 'XXXXXX';
$Self->{'AuthSyncModule::LDAP::UserSyncMap'} = {
# DB -> LDAP
UserFirstname => 'givenName',
UserLastname => 'sn',
UserEmail => 'mail',
};

$Self->{'AuthSyncModule::LDAP::UserSyncInitialGroups'} = [
'users', 'basic_admin',
];
$Self->{'Customer::AuthModule'} = 'Kernel::System::CustomerAuth::HTTPBasicAuth';
$Self->{'Customer::AuthModule::HTTPBasicAuth::ReplaceRegExp'} = '@XXXX.LOCAL';
$Self->{'Customer::AuthModule::LDAP::Host'} = 'XXXX.XXXX.local';
$Self->{'Customer::AuthModule::LDAP::BaseDN'} = 'dc=XXXX,DC=local';
$Self->{'Customer::AuthModule::LDAP::UID'} = 'sAMAccountName';
$Self->{'Customer::AuthModule::LDAP::SearchUserDN'} = 'LDAP';
$Self->{'Customer::AuthModule::LDAP::SearchUserPw'} = 'XXXX';
$Self->{CustomerUser} = {
Module => 'Kernel::System::CustomerUser::LDAP',
Params => {
Host => 'XXXX.XXXX.local', # AD Server
BaseDN => 'dc=XXXX,DC=local', #Domain
SSCOPE => 'sub',
UserDN =>'LDAP', #OTRS Service User
UserPw => 'XXXX', #its password
# AlwaysFilter => '(&(samAccountType=805306368)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))',
SourceCharset => 'utf-8',
DestCharset => 'utf-8',
},
# CustomerUserExcludePrimaryCustomerID => 1,
CustomerKey => 'sAMAccountName',
CustomerID => 'mail',
CustomerUserListFields => ['sAMAccountName', 'cn', 'mail'],
CustomerUserSearchFields => ['sAMAccountName', 'cn', 'mail'],
CustomerUserSearchPrefix => '',
CustomerUserSearchSuffix => '*',
CustomerUserSearchListLimit => 10000,
CustomerUserPostMasterSearchFields => ['mail'],
CustomerUserNameFields => ['givenname', 'sn'],
Map => [
# note: Login, Email and CustomerID needed!
#[ 'UserSalutation', 'Title', 'title', 1, 0, 'var' ],
[ 'UserCompany', 'Firma', 'company', 1, 1, 'var' ],
[ 'UserFirstname', 'Firstname', 'givenname', 1, 1, 'var' ],
[ 'UserLastname', 'Lastname', 'sn', 1, 1, 'var' ],
[ 'UserLogin', 'Login', 'sAMAccountName', 1, 1, 'var' ],
[ 'UserDepartment', 'Abteilung', 'description', 1, 1, 'var' ],
[ 'UserEmail', 'Email', 'mail', 1, 1, 'var' ],
[ 'UserMobile', 'Mobile', 'mobile', 1, 0, 'var', '', 0 ],
[ 'UserCustomerID', 'CustomerID', 'mail', 0, 1, 'var' ],
[ 'UserPhone', 'Phone', 'telephonenumber', 1, 0, 'var' ],
[ 'UserRoom', 'Room', 'physicalDeliveryOfficeName', 0, 1, 'var', '', 0 ],
[ 'UserManager', 'Vorgesetzer', 'manager', 1, 1, 'var' ],
#[ 'UserAddress', 'Address', 'postaladdress', 1, 0, 'var' ],
#[ 'UserComment', 'Comment', 'description', 1, 0, 'var' ],
],
};
[/quote]

Ich danke Euch jetzt schon für die Hilfe und wünsche nen schönen Abend

Viele Grüße

MasterD
You do not have the required permissions to view the files attached to this post.

masterd01
OTRS newbie
Posts: 3
Joined: 14 Mar 2020, 12:28
OTRS Version?: OTRS 6 Com
Real Name: Daniel

Re: Firmentickets mit LDAP-Customer Portal werden nicht angezeigt

Post by masterd01 »

Hallo und guten Morgen,

würde mich über ne kurze Info freuen, wie woran es bei mir mit den Firmentickets im OTRS scheitert. Gerne auch einfach nur Links, die ich mir durchlesen kann. Oder ggf. nochmal im englischen Forum posten?

Beste Grüße

MasterD

root
Moderator
Posts: 2084
Joined: 18 Dec 2007, 12:23
OTRS Version?: 4/5/6
Real Name: Roy Kaldung
Company: Znuny Inc.
Contact:

Re: Firmentickets mit LDAP-Customer Portal werden nicht angezeigt

Post by root »

Hi,

Vielleicht traut sich keiner zu antworten weil Du im Profil OTRS 7 stehen hast. Da gibt's (noch?) keine Community Edition.

Hast Du Dich schon an den Support gewandt?

Ich würde erst einmal versuchen hier

Code: Select all

CustomerID => 'mail',
und hier

Code: Select all

[ 'UserCustomerID', 'CustomerID', 'mail', 0, 1, 'var' ],
anstelle von mail ein Feld zu verwenden was bei den Kundenbenutzer gleich ist. Z.B. department oder company

- Roy
OTRS 5/6 CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

Do you need professional services for the ((OTRS)) Community Edition? Check out https://www.znuny.com/

masterd01
OTRS newbie
Posts: 3
Joined: 14 Mar 2020, 12:28
OTRS Version?: OTRS 6 Com
Real Name: Daniel

[gelöst] Firmentickets mit LDAP-Customer Portal werden nicht angezeigt

Post by masterd01 »

Hallo Roy,

Danke für die Antwort.
Mein Fehler - grober Schnitzer: Die Installation hier ist ein OTRS6 Community und dewegen war die Angabe in meinem Profil falsch. Sorry :(

Dein Tipp war goldrichtig. Hab's hinbekommen und alles ist gut :-)

Vielen Dank nocheinmal und beste Grüße

MasterD

Post Reply