[Solved] OTRS 3.3 to 4.0 upgrade problem with the server

Moderator: crythias

Post Reply
kkgigiioo
OTRS newbie
Posts: 22
Joined: 06 Mar 2019, 09:26
OTRS Version?: 6.0.15

[Solved] OTRS 3.3 to 4.0 upgrade problem with the server

Post by kkgigiioo » 07 Nov 2019, 17:19

Dear Forum members!

I have a little problem. We have a Debian Jessie with OTRS 3.3. I would update it to OTRS 4.0, but when I run CheckModule.pl, tells you to install libtemplate-perl modul. Now the problem is the OS rejects the update due to dependency on OTRS.

Here is the code that I see, when I run the update:

Code: Select all

# apt-get install -y libtemplate-perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 otrs2 : Depends: libgd-text-perl but it is not going to be installed
         Depends: libgd-graph-perl but it is not going to be installed
         Recommends: mysql-server but it is not going to be installed or
                     postgresql but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
#
I know it is not especially OTRS problem, but maybe someone have met like that problem.

Thank you for your answer. I really appresiate that.
Regards!
Last edited by kkgigiioo on 07 Nov 2019, 19:18, edited 1 time in total.

jojo
Moderator
Posts: 14597
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: OTRS 3.3 to 4.0 upgrade problem with the server

Post by jojo » 07 Nov 2019, 18:45

please don't use the OTRS debian package. I suggest to install from tar ball and migrate to the latest version (on a new server). All versions prior to OTRS 5 are not supported any more and do not get security fixes. There are known vulnerabilities.
"Production": OTRS™ 7, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) and git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

kkgigiioo
OTRS newbie
Posts: 22
Joined: 06 Mar 2019, 09:26
OTRS Version?: 6.0.15

Re: OTRS 3.3 to 4.0 upgrade problem with the server

Post by kkgigiioo » 07 Nov 2019, 19:11

Thank you Jojo your answer!
I downloaded a tar file and that I upgraded it from 3.3 to 4.0. This part is all right. The database has also been updated nicely. However, when I ran the bin / otrs.CheckModules.pl command, it was missing the file mentioned above.
My other plans are to upgrade to 6.0, but according to the description, I need to upgrade to 4.0 first.

I attach the result of running the bin/otrs.CheckModules.pl:

Code: Select all

$ bin/otrs.CheckModules.pl
  o Apache::DBI......................ok (v1.12)
  o Apache2::Reload..................ok (v0.13)
  o Archive::Tar.....................ok (v1.96)
  o Archive::Zip.....................ok (v1.34)
  o Crypt::Eksblowfish::Bcrypt.......ok (v0.008)
  o Crypt::SSLeay....................ok (v0.58)
  o Date::Format.....................ok (v2.24)
  o DBI..............................ok (v1.622)
  o DBD::mysql.......................ok (v4.021)
  o DBD::Pg..........................ok (v2.19.2)
  o Digest::SHA......................ok (v5.85)
  o IO::Socket::SSL..................ok (v1.76)
  o JSON::XS.........................ok (v2.32)
  o List::Util::XS...................ok (v1.23)
  o LWP::UserAgent...................ok (v6.13)
  o Mail::IMAPClient.................ok (v3.31)
    o IO::Socket::SSL................ok (v1.76)
    o Authen::SASL...................ok (v2.15)
  o ModPerl::Util....................ok (v2.000007)
  o Net::DNS.........................ok (v0.66)
  o Net::LDAP........................ok (v0.44)
  o Template.........................Not installed! Use: 'apt-get install -y libtemplate-perl' (required - Template::Toolkit, the rendering engine of OTRS.)
  o Template::Stash::XS..............Not installed! Use: 'apt-get install -y libtemplate-perl' (required - The fast data stash for Template::Toolkit.)
  o Text::CSV_XS.....................ok (v0.90)
  o Time::HiRes......................ok (v1.9721_01)
  o Time::Piece......................ok (v1.20_01)
  o XML::Parser......................ok (v2.41)
  o YAML::XS.........................ok (v0.41)
$
Then I try to ran "sudo apt-get install -y libtemplate-perl", and I got the error described earlier.
I'm here right now. The whole upgrade process is necessary because we want to migrate the system to CentOS, but we need the database.

jojo
Moderator
Posts: 14597
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: OTRS 3.3 to 4.0 upgrade problem with the server

Post by jojo » 07 Nov 2019, 19:16

if you don't want to login during the upgrade steps don't mind the libtemplate perl module (which you might need to install via CPAN otherwise)
"Production": OTRS™ 7, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) and git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

kkgigiioo
OTRS newbie
Posts: 22
Joined: 06 Mar 2019, 09:26
OTRS Version?: 6.0.15

Re: OTRS 3.3 to 4.0 upgrade problem with the server

Post by kkgigiioo » 07 Nov 2019, 19:17

Dear jojo!
That was exactly my question. Thank you very much for your reply!

Post Reply