6.0.1 QueueView very slow and error message

Moderator: crythias

Post Reply
akipt
OTRS newbie
Posts: 8
Joined: 14 Mar 2016, 14:05
OTRS Version?: 5.0.14

6.0.1 QueueView very slow and error message

Post by akipt » 23 Nov 2017, 15:12

Hey,

just updated my OTRS Free from 5.0.24 to 6.0.1

Updatescripts runs without errors and I also set the right permissions, but if I login, goto QueueView and click on a queue (with 7 active tickets) it takes about 7-8 seconds to to load the page. It doesnt deppend on the used browser/CPU/DB-connection

Also the log shows the following error:

Code: Select all

Recent Log Entries	Time 	Priority 	Facility 	Message
Thu Nov 23 14:00:28 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 14:00:28 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:54:37 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:54:37 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:53:40 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:53:40 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:47:07 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:47:07 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:44:39 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:44:39 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:42:38 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:42:38 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:40:33 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:40:33 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:40:19 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:40:19 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:38:02 2017 	error 	OTRS-CGI-10 	Need GroupName!
Thu Nov 23 13:38:02 2017 	error 	OTRS-CGI-10 	Need GroupName!
Maybe there is correlation between this two events.

Thanky you very much!
Julius

akipt
OTRS newbie
Posts: 8
Joined: 14 Mar 2016, 14:05
OTRS Version?: 5.0.14

Re: 6.0.1 QueueView very slow and error message

Post by akipt » 15 Dec 2017, 14:04

Problem still exists with 6.0.2

Nobody an idea?

Thank you

root
Moderator
Posts: 1341
Joined: 18 Dec 2007, 12:23
OTRS Version?: 4/5/6
Real Name: Roy Kaldung
Company: Znuny Inc.
Contact:

Re: 6.0.1 QueueView very slow and error message

Post by root » 15 Dec 2017, 14:47

Hi,

I would check, after clearing the log, if this error came up when updating AgentTicketQueue. If yes, look into the System Configuration if there's any settings change which belongs to the module.

- Roy
OTRS 4/5/6 CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

You need professional services? Check out https://www.znuny.com/

felix123
OTRS newbie
Posts: 4
Joined: 29 Feb 2016, 12:16
OTRS Version?: 6.0.4

Re: 6.0.1 QueueView very slow and error message

Post by felix123 » 20 Dec 2017, 10:22

Hi,

I have the same error. (6.0.3)

It occur when you click on the "Admin"-Button.

I don't know how to fix it.

The group "admin" already exists.

Best regards.

felix123
OTRS newbie
Posts: 4
Joined: 29 Feb 2016, 12:16
OTRS Version?: 6.0.4

Re: 6.0.1 QueueView very slow and error message

Post by felix123 » 20 Dec 2017, 10:40

Error-Log:

ERROR: OTRS-CGI-16 Perl: 5.18.2 OS: linux Time: Tue Nov 28 14:13:51 2017

Message: Need GroupName!

RemoteAddress: x.x.x.x
RequestURI: /otrs/index.pl?Action=Admin

Traceback (2689):
Module: Kernel::System::Group::PermissionCheck Line: 945
Module: Kernel::Output::HTML::NavBar::ModuleAdmin::Run Line: 76
Module: Kernel::Output::HTML::Layout::NavigationBar Line: 3218
Module: Kernel::Modules::Admin::Run Line: 35
Module: Kernel::System::Web::InterfaceAgent::Run Line: 1098
Module: ModPerl::ROOT::ModPerl::Registry::opt_otrs_bin_cgi_2dbin_index_2epl::handler Line: 40
Module: (eval) (v1.99) Line: 206
Module: ModPerl::RegistryCooker::run (v1.99) Line: 206
Module: ModPerl::RegistryCooker::default_handler (v1.99) Line: 172
Module: ModPerl::Registry::handler (v1.99) Line: 31

User avatar
crythias
Moderator
Posts: 9984
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: 6.0.1 QueueView very slow and error message

Post by crythias » 22 Dec 2017, 21:11

This is likely because the [+] was clicked but not implemented in the System Configuration.

A way to address is to seek out

Code: Select all

''
(two apostrophes) from within Kernel/Config/Files/ZZZAuto.pm

Code: Select all

      'Group' => [
        ''
      ],
Either in Group or Groupro
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

petrj
OTRS newbie
Posts: 5
Joined: 30 Dec 2017, 18:29
OTRS Version?: 6.0.*
Company: UOL

Re: 6.0.1 QueueView very slow and error message

Post by petrj » 30 Dec 2017, 20:11

We have very similar issue after upgrading OTRS from 5.0.20 to 6.0.3. Load of page index.pl?Action=AgentTicketQueue is realy slow, about 4s with 6 tickets in queue (10s with 17 tickets in queue). It's really difficult to use OTRS in this state.

During loading AgentTicketQueue there is load in PostgreSQL.

We found nothing related in otrs log (OTRS in debug loglevel), appache error.log neither in postgresql.log.

To eliminate external influence we deploy backup on similar server (OpenStack node, exact performance). With 5.0.10 the load of AgentTicketQueue take about 1s. Then we perform OTRS upgrade to 6.0.3, migratation script ended without errors. Unfortunately OTRS became slow again (same as on our productiong instance).

We test it without other connected agents. We also try to turn off OTRS Cron and Daemon.
Using default Config.pm (withoud LDAP settings) has also no perfomance effect.

We tried PostgreSQL 9.6 and 10 with different setting, but no major performance improvement.

Can someone help where we should look or what test...???
OTRS 6.0.12, Ubuntu, PostgreSQL 11, LDAP

petrj
OTRS newbie
Posts: 5
Joined: 30 Dec 2017, 18:29
OTRS Version?: 6.0.*
Company: UOL

Re: 6.0.1 QueueView very slow and error message

Post by petrj » 08 Jan 2018, 18:54

Please, has anyone resolved this issue? Any ideas?

Could this be PostgreSQL related - do you ( akipt/ felix123) use postgres?

I'm considering downgrade OTRS (probably not posible) or new OTRS instance on 5.x without data migration...
Sadly, our agents are not able to use OTRS.
OTRS 6.0.12, Ubuntu, PostgreSQL 11, LDAP

root
Moderator
Posts: 1341
Joined: 18 Dec 2007, 12:23
OTRS Version?: 4/5/6
Real Name: Roy Kaldung
Company: Znuny Inc.
Contact:

Re: 6.0.1 QueueView very slow and error message

Post by root » 08 Jan 2018, 19:00

Hi,

Did enabled the query /statement logging of PostgreSQL and checked it? Is your DNS working properly? What does the performance log of OTRS say?
Sorry, but I think you should consider professional support in this situation.

- Roy
OTRS 4/5/6 CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

You need professional services? Check out https://www.znuny.com/

petrj
OTRS newbie
Posts: 5
Joined: 30 Dec 2017, 18:29
OTRS Version?: 6.0.*
Company: UOL

Re: 6.0.1 QueueView very slow and error message

Post by petrj » 09 Jan 2018, 18:37

Hi Roy,

thanks for your reply. This helps, I found solution in postgres log.

Load of index.pl?Action=AgentTicketQueue with 8 open tickets took about 5,5s (measurement in chromium dev console). Sum of postgres statements (while loading AgentTicketQueue) durations was ~5s. In pg log I found repeated stamenent which took about 300ms...

Code: Select all

SELECT sadm.a_from, sadm.a_reply_to, sadm.a_to, sadm.a_cc, sadm.a_bcc, sadm.a_subject,
sadm.a_message_id, sadm.a_in_reply_to, sadm.a_references, sadm.a_content_type, sadm.a_body, sadm.incoming_time FROM article_data_mime sadm WHERE sadm.article_id = '438025' LIMIT 1;
Execution time: 300+ ms

I found missing index...so I run hotfix:

Code: Select all

CREATE INDEX "otrs_speed_index" ON article_data_mime USING btree (article_id);

Code: Select all

EXPLAIN ANALYZE SELECT ...
Planning time: 0.473 ms
Execution time: 0.158 ms
OTRS is fast again, I'm super happy :)

Should I report a bug report?

EDIT:
Reported at bugs.otrs as #13661
Last edited by petrj on 14 Feb 2018, 16:48, edited 1 time in total.
OTRS 6.0.12, Ubuntu, PostgreSQL 11, LDAP

tpsupport
OTRS expert
Posts: 60
Joined: 02 Feb 2011, 14:45
OTRS Version?: 6.0.10

Re: 6.0.1 QueueView very slow and error message

Post by tpsupport » 18 Jan 2018, 16:54

crythias wrote:This is likely because the [+] was clicked but not implemented in the System Configuration.

A way to address is to seek out

Code: Select all

''
(two apostrophes) from within Kernel/Config/Files/ZZZAuto.pm

Code: Select all

      'Group' => [
        ''
      ],
Either in Group or Groupro
Thank you, for the hint. Since there was no ZZZAuto.pm but just the ZZZAAuto.pm I had to Remove the empty 'Group' entries via "System Configuration". However I used the ZZZAAuto.pm to find the empty entries. I searched for the two double quotes as per you suggestion to find them.
OTRS 6 - Ubuntu 16.04 x64, Azure Database for MySQL server 5.7, Perl 5.22.1, Apache/2.4.18

felix123
OTRS newbie
Posts: 4
Joined: 29 Feb 2016, 12:16
OTRS Version?: 6.0.4

Re: 6.0.1 QueueView very slow and error message

Post by felix123 » 23 Jan 2018, 10:38

crythias wrote:This is likely because the [+] was clicked but not implemented in the System Configuration.

A way to address is to seek out

Code: Select all

''
(two apostrophes) from within Kernel/Config/Files/ZZZAuto.pm

Code: Select all

      'Group' => [
        ''
      ],
Either in Group or Groupro
thanks for the help. it works after deleting the ' ' in ZZZAAuto.pm

Post Reply