"Internal Server Error" After upgrading from 2.4.1 to 3.0.4

Moderator: crythias

Post Reply
ruiaraujo
OTRS newbie
Posts: 2
Joined: 17 Jan 2011, 01:40
OTRS Version?: 3.0.4

"Internal Server Error" After upgrading from 2.4.1 to 3.0.4

Post by ruiaraujo »

Hello all
I'm stuck with this problem on my production OTRS Server after upgrading from perfectly working 2.4.1 to 3.0.4 version.
I followed the online manual, got NO errors in the process, and finally, after starting up httpd, also with NO errors, I'm getting this on every browser:

Code: Select all

500 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, administrator@mydomian.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
What can be the problem?

Every Perl Module is installed:

Code: Select all

[root@otrsserver~]# /opt/otrs/bin/otrs.CheckModules.pl
   o CGI............................ok (v3.50)
   o Crypt::PasswdMD5...............ok (v1.3)
   o CSS::Minifier..................ok (v0.01)
   o Date::Format...................ok (v2.24)
   o Date::Pcalc....................ok (v1.2)
   o DBI............................ok (v1.616)
   o DBD::mysql.....................ok (v4.018)
   o Digest::MD5....................ok (v2.51)
   o Digest::SHA::PurePerl..........ok (v5.48)
   o Encode::HanExtra...............Not installed! (Optional - Required to handle mails with several Chinese character sets.)
   o GD.............................Not installed! (Optional - Required for stats)
      o GD::Text....................Not installed! (Optional - Required for stats.)
      o GD::Graph...................Not installed! (Optional - Required for stats.)
      o GD::Graph::lines............Not installed! (Optional - Required for stats.)
      o GD::Text::Align.............Not installed! (Optional - Required for stats.)
   o IO::Scalar.....................ok (v2.110)
   o IO::Wrap.......................ok (v2.110)
   o JavaScript::Minifier...........ok (v1.05)
   o JSON...........................ok (v2.27)
      o JSON::PP....................ok (v2.27008)
      o JSON::XS....................Not installed! (Optional - Install it for faster AJAX/JavaScript handling.)
   o LWP::UserAgent.................ok (v5.835)
   o Mail::Internet.................ok (v2.07)
   o Mail::POP3Client...............ok (v2.18 )
      o IO::Socket::SSL.............Not installed! (Optional - Required for POP3 SSL connections.)
   o MIME::Base64...................ok (v3.13)
   o MIME::Tools....................ok (v5.428)
   o ModPerl::Util..................Not installed! (Optional - Improves Performance on Apache webservers dramatically.)
      o Apache::DBI.................Not installed! (Optional - Improves performance on Apache webservers with mod_perl by establishing persistent database connections.)
      o Apache2::Reload.............Not installed! (Optional - Should be installed on mod_perl based installations to automatically reload changed Perl files and configuration data.)
   o Net::DNS.......................ok (v0.66)
   o Net::POP3......................ok (v2.29)
   o Net::IMAP::Simple..............ok (v1.2017)
      o Net::IMAP::Simple::SSL......Not installed! (Optional - Required for SSL connections.)
   o Net::SMTP......................ok (v2.31)
      o Authen::SASL................ok (v2.15)
      o Net::SMTP::SSL..............Not installed! (Optional - Required for SSL/SMTPS connections.)
      o Net::SMTP::TLS..............Not installed! (Optional - Required for TLS/SMTP connections.)
   o Net::LDAP......................ok (v0.4001)
   o PDF::API2......................Not installed! (Optional - Required for PDF output.)
      o Compress::Zlib..............ok (v2.033)
   o SOAP::Lite.....................Not installed! (Optional - Required for the SOAP interface.)
   o Text::CSV......................ok (v1.20)
      o Text::CSV_PP................ok (v1.28)
      o Text::CSV_XS................Not installed! (Optional - Optional, install it for faster CSV handling.)
   o XML::Parser....................Not installed! (Optional - Required for faster xml handling.)
Perl is NOT complaining:

Code: Select all

perl -cw bin/cgi-bin/index.pl 
bin/cgi-bin/index.pl syntax OK
Apache is NOT logging any error whatsoever...

Any help will be well appreciated..

TIA,
Rui

Wolfgangf
OTRS guru
Posts: 1029
Joined: 13 Apr 2009, 12:26
OTRS Version?: 6.0.13
Real Name: Wolfgang Fürtbauer
Company: PBS Logitek GmbH
Location: Pinsdorf

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by Wolfgangf »

did you check the startup script? (I assume: /opt/otrs/scirpts/apache2-perl-starup.pl)
Produktiv:
OTRS 6.0.13/ ITSM 6.0.13
OS: SUSE Linux (SLES 12, Leap), MySql 5.5.x, 5.6.x
Windows 2012 AD Integration (agents and customers), Nagios integration (incidents, CMDB), Survey, TimeAccounting

ruiaraujo
OTRS newbie
Posts: 2
Joined: 17 Jan 2011, 01:40
OTRS Version?: 3.0.4

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by ruiaraujo »

Wolfgangf wrote:did you check the startup script? (I assume: /opt/otrs/scirpts/apache2-perl-starup.pl)
Hello Wolfgangf,
Thanks for the reply.

I didn't check it because it wasn't mentioned in any of the upgrade manuals.

My upgrade path came from 2.2.3->2.3.1->2.4.1 with no problems because that file wasn't needed

Thank you very much for pointing me in the right direction..
It's a perl thing after all...

sj89
OTRS newbie
Posts: 8
Joined: 03 Feb 2012, 12:12
OTRS Version?: 3.0.11
Real Name: SJ
Company: Sybrid

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by sj89 »

Wolfgangf wrote:did you check the startup script? (I assume: /opt/otrs/scirpts/apache2-perl-starup.pl)
How do you check am nOOb sorry for asking easy-for-you-guys
OTRS 3.1 on Centos with MySQL database PHP Apache Server

ferrosti
OTRS ninja
Posts: 723
Joined: 10 Oct 2007, 14:30
OTRS Version?: 3.0
Location: Hamburg, Germany

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by ferrosti »

After an upgrade make sure you executed all clean up scripts, session cleaning, cache cleaning and rebuilding default config.
After all restart apache and everything should work like a charm.
openSuSE on ESX
IT-Helpdesk: OTRS 3.0
Customer Service: OTRS 3.0 (upgraded from 2.3)
Customer Service (subsidiary): OTRS 3.0
+additional test and development systems

sj89
OTRS newbie
Posts: 8
Joined: 03 Feb 2012, 12:12
OTRS Version?: 3.0.11
Real Name: SJ
Company: Sybrid

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by sj89 »

ferrosti wrote:After an upgrade make sure you executed all clean up scripts, session cleaning, cache cleaning and rebuilding default config.
After all restart apache and everything should work like a charm.
Can you give me exact syntax/commands so i can check and please check my thread as well Thanks!
OTRS 3.1 on Centos with MySQL database PHP Apache Server

jojo
Moderator
Posts: 14676
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by jojo »

Pleasre read the UPGRADING file!
"Production": OTRS™ 7, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) and git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

ferrosti
OTRS ninja
Posts: 723
Joined: 10 Oct 2007, 14:30
OTRS Version?: 3.0
Location: Hamburg, Germany

Re: "Internal Server Error" After upgrading from 2.4.1 to 3.

Post by ferrosti »

You can find all those programs in your $OTSR_HOME/bin directory.
And as jojo already states: have a close look at the UPGRADING file!
openSuSE on ESX
IT-Helpdesk: OTRS 3.0
Customer Service: OTRS 3.0 (upgraded from 2.3)
Customer Service (subsidiary): OTRS 3.0
+additional test and development systems

Post Reply