Certain time-based Jobs not working

Moderator: crythias

Post Reply
himbeertoni
OTRS newbie
Posts: 2
Joined: 06 Aug 2020, 14:59
OTRS Version?: 6.0.25
Real Name: Clemens Zauner
Company: A.K.I.S. GmbH

Certain time-based Jobs not working

Post by himbeertoni »

First of Hello, excuse me, if this is already answered - I skimmed over the Forum but I didn't find anything as I'm observing here.
I also have near zero experience with OTRS, I'm trying to find an alternative to cerberus helpdesk.

Situation:
- new OTRS 6 installation (community-ed), on a FreeBSD Jail (on a FreeNAS installation), nginx + fpm. It seems to work.
- The otrs deamon is also running.

Yes, really:
# su - otrs -c '/usr/local/otrs/bin/otrs.Daemon.pl status'
Manage the OTRS daemon process.
Daemon running
#

Problem: Mail sending and receiving (via postmaster mailboxes) does not happen at all. No hints in the logfiles.
The receiving is no longer a problem, as I'm using the direct approach with sendmail+procmail, but Mail is only
queued (test-accounts, so not masked):

# su - otrs -c 'bin/otrs.Console.pl Maint::Email::MailQueue --list '

+----+-----------+----------+---------------+--------------------+----------+----------------+-------------------+
| ID | ArticleID | Attempts | Sender | Recipient | Due Time | Last SMTP Code | Last SMTP Message |
+----+-----------+----------+---------------+--------------------+----------+----------------+-------------------+
| 3 | 26 | 0 | lines@akis.at | noc+test@atnoc.net | - | - | - |
+----+-----------+----------+---------------+--------------------+----------+----------------+-------------------+

Mail queue contains 1 message(s)

Done.
#

Until I 'send' the Mails via the console.pl (which works just fine).

# su - otrs -c 'bin/otrs.Console.pl Maint::Email::MailQueue --send '

1 message(s) successfully sent!
Done.

#

The log-files in var/log/Daemon/ are always 0 Bytes (empty); But have a current timestamp.

I'm at a kind of loss here, especially as the sending of the queue looks enabled to me:
(from Kernel/Config/Files/XML/Daemon.xml)
<Setting Name="Daemon::SchedulerCronTaskManager::Task###MailQueueSend" Required="0" Valid="1" ConfigLevel="100">
<Description Translatable="1">Checks for queued outgoing emails to be sent.</Description>
<Navigation>Daemon::SchedulerCronTaskManager::Task</Navigation>
<Value>
<Hash>
<Item Key="TaskName">MailQueueSend</Item>
<Item Key="Schedule">* * * * *</Item> <!-- default every minute -->
<Item Key="Module">Kernel::System::Console::Command::Maint::Email::MailQueue</Item>
<Item Key="Function">Execute</Item>
<Item Key="MaximumParallelInstances">1</Item>
<Item Key="Params">
<Array>
<Item>--send</Item>
</Array>
</Item>
</Hash>
</Value>
</Setting>

What exactly I'm doing wrong? Technical specifications of the system (I'm omitting all the installed clutter, just the main parts):
# uname -a
FreeBSD otrs6 11.3-RELEASE-p11 FreeBSD 11.3-RELEASE-p11 #0 r325575+fb17f3e15b8(HEAD): Tue Jul 28 11:09:10 EDT 2020 root@tnbuilds05.tn.ixsystems.net:/freenas-releng/freenas/_BE/objs/freenas-releng/freenas/_BE/os/sys/FreeNAS.amd64 amd64

# perl -v

This is perl 5, version 30, subversion 3 (v5.30.3) built for amd64-freebsd-thread-multi

# sendmail -v -d0.1
Version 8.15.2
Compiled with: DNSMAP IPV6_FULL LOG MAP_REGEX MATCHGECOS MILTER
MIME7TO8 MIME8TO7 NAMED_BIND NETINET NETINET6 NETUNIX NEWDB NIS
PIPELINING SCANF STARTTLS TCPWRAPPERS USERDB XDEBUG


# nginx -v
nginx version: nginx/1.18.0

# pkg info | grep fcgi
fcgi-devkit-2.4.0_5 FastCGI Development Kit
fcgiwrap-1.1.0_11 Simple FastCGI wrapper for CGI scripts


Thanks in advance for all pointers on stuff I missed out. As written before - my OTRS-experience is more-or-less non-existent, am still trying to find the ropes.

Post Reply