[SOLVED] Customer Info Center not Recognizing Accents

Moderator: crythias

Post Reply
jason123
OTRS newbie
Posts: 33
Joined: 25 Apr 2016, 15:27
OTRS Version?: OTRS 5

[SOLVED] Customer Info Center not Recognizing Accents

Post by jason123 » 13 Apr 2017, 16:23

Selected 'Customer >> Customer Information Center'. When I typed in 'Tefé', nothing appears, but when I remove the 'é' and just type 'Tef', I get various customers with 'Tefé' in the name.

Why does OTRS not search the accents? Is this not possible to configure?

Thanks
Last edited by jason123 on 18 Apr 2017, 17:19, edited 3 times in total.

Giulio Soleni
OTRS superhero
Posts: 392
Joined: 30 Dec 2010, 14:35
OTRS Version?: 6.0.x and 5.0.x
Real Name: Giulio Soleni
Company: IKS srl

Re: Customer Info Center not Recognizing Accents

Post by Giulio Soleni » 18 Apr 2017, 11:41

Hi,
there should be a parameter like:
CustomerUserSearchFields => [ 'login', 'first_name', 'last_name', 'customer_id', 'phone', 'mobile' ],
set within your /opt/otrs/Kernel/Config.pm file ... may you check?

Also ... what is the charset used by your db? you may check it from the web console
Admin > System Administration - Support Data Collector ... and check for the Database configuration

HTH
OTRS 6.0.x on CentOS 7.x with MariaDB 10.2.x database connected to an Active Directory for Agents and Customers.
ITSM and FAQ modules installed.

jason123
OTRS newbie
Posts: 33
Joined: 25 Apr 2016, 15:27
OTRS Version?: OTRS 5

Re: Customer Info Center not Recognizing Accents

Post by jason123 » 18 Apr 2017, 17:19

Hi Giulio,

The database formatting was the issue, it is formatted to SQL_ASCII and should be UTF8.

Thanks for you help,
Jason

Post Reply