Upgrade OTRS 4 to 5 errors

Moderator: crythias

Post Reply
galaxis
OTRS newbie
Posts: 8
Joined: 04 Mar 2016, 12:20
OTRS Version?: 4.0.16-01
Real Name: Alexis
Company: EDT

Upgrade OTRS 4 to 5 errors

Post by galaxis » 04 Mar 2016, 12:46

Hello,

I must upgrade my Otrs v4.0.16-01 to 5.0.7-01 on a CentOS server 6.7.
My database server got the mysql-server-5.1.73 version. All tables are InnoDB, I also modify my "my.cnf" file to make this storage engine as default.

I've launched the scripts to test my DB and modules required ( ALL ok ) but during the database upgrade step with the script "DBUpdate-to-5.pl", I've got this error :

Code: Select all

Step 10 of 17: Migrate Output configurations to the new module locations...
--- Toolbar modules......done.
--- Ticket menu modules......done.
--- Ticket overview menu modules......done.
--- Ticket overview modules......done.
--- Preferences group modules......done.
--- SLA/Service/Queue preference modules......done.
--- Article view modules......done.
--- NavBar menu modules......done.
--- NavBar ModuleAdmin modules...[Fri Mar  4 11:03:04 2016] DBUpdate-to-5.pl: Use of uninitialized value in string eq at scripts/DBUpdate-to-5.pl line 1481.
[Fri Mar  4 11:03:04 2016] DBUpdate-to-5.pl: Use of uninitialized value in string eq at scripts/DBUpdate-to-5.pl line 1481.
[Fri Mar  4 11:03:04 2016] DBUpdate-to-5.pl: Use of uninitialized value in string eq at scripts/DBUpdate-to-5.pl line 1481.
[Fri Mar  4 11:03:04 2016] DBUpdate-to-5.pl: Use of uninitialized value in string eq at scripts/DBUpdate-to-5.pl line 1481.
[Fri Mar  4 11:03:04 2016] DBUpdate-to-5.pl: Use of uninitialized value in string eq at scripts/DBUpdate-to-5.pl line 1481.
[Fri Mar  4 11:03:04 2016] DBUpdate-to-5.pl: Use of uninitialized value in string eq at scripts/DBUpdate-to-5.pl line 1481.
...done.
--- Dashboard modules......done.
--- Customer user generic modules......done.
--- FilterText modules......done.
--- Notify modules......done.
done.
When the upgrade is done, the Admin tab doesn't work. When I click, nothing happen but if I modify the URL with : /index.pl?Action=Admin I will be on the Admin page.
SO I assume that the thing which doesn't work is the redirection on the page when I click on the admin tab.
But I'm lost after that..
Do you have any ideas please ?

Just in case, this is my version of perl : perl-5.10.1-141.el6_7.1.x86_64

For they most insightful of us, yes i created an other ticket with an other issue few minutes ago :lol:

Thanks in advance
Best regards,
Alexis.

galaxis
OTRS newbie
Posts: 8
Joined: 04 Mar 2016, 12:20
OTRS Version?: 4.0.16-01
Real Name: Alexis
Company: EDT

Re: Upgrade OTRS 4 to 5 errors

Post by galaxis » 14 Apr 2016, 15:16

Anyone please ?

It should be a javascript error because when I do a right clik on the Admin tab and I open it in a new firefox tab, I can access to the admin..
It strange ^^

MrDron
OTRS newbie
Posts: 1
Joined: 23 Jun 2016, 15:33
OTRS Version?: 5.0.10

Re: Upgrade OTRS 4 to 5 errors

Post by MrDron » 24 Jun 2016, 07:02

The same situation, the same problem. Still no solution.
If remove this lines form original code:
  • <li id="nav-Admin" class="CanDrag ui-sortable-handle" aria-controls="nav-Admin-container" aria-expanded="false" aria-haspopup="true">
    <a href="/otrs/index.pl?Action=Admin" title="Admin (a)" accesskey="a">Admin</a>
    <ul id="nav-Admin-container">
    </ul>
    </li>
admin link works perfect

Giulio Soleni
OTRS superhero
Posts: 392
Joined: 30 Dec 2010, 14:35
OTRS Version?: 6.0.x and 5.0.x
Real Name: Giulio Soleni
Company: IKS srl

Re: Upgrade OTRS 4 to 5 errors

Post by Giulio Soleni » 24 Jun 2016, 16:56

I reported such issue as a bug:
http://bugs.otrs.org/show_bug.cgi?id=11885
and as far as I know (I didn't tested it so far...) it has been fixed.

In any case, in the bug report you may find also the fix that should be applied to scripts/DBUpdate-to-5.pl script

HTH
Giulio
OTRS 6.0.x on CentOS 7.x with MariaDB 10.2.x database connected to an Active Directory for Agents and Customers.
ITSM and FAQ modules installed.

Post Reply