[SOLVED] Bulk ticket update error post 5.0.6-01 update

Moderator: crythias

Post Reply
amdkryn
OTRS expert
Posts: 187
Joined: 02 Oct 2012, 02:52
OTRS Version?: 5.0.27

[SOLVED] Bulk ticket update error post 5.0.6-01 update

Post by amdkryn »

Hello,

I have completed an update to the latest version (otrs-5.0.6-01.noarch.rpm) and upgraded all installed packages to the latest release. Now when we attempt to do a bulk update of tickets we receive a Internal Server error.

I've removed the packages Time Accounting, Survey and SystemMonitoring, based on a post by a user with the same problem. The solution that worked with him did not work with me.


Here is some more information:

Error:
Can't call method "FatalError" on an undefined value at /opt/otrs//Kernel/Modules/AgentTicketBulk.pm line 32. ,


Here is some more information:

Code: Select all

server:~ # /opt/otrs/bin/otrs.Console.pl Admin::Package::List --allow-root
Listing all installed packages...
+----------------------------------------------------------------------------+
| Name:        FAQ
| Version:     5.0.2
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The FAQ/knowledge base.
+----------------------------------------------------------------------------+
| Name:        GeneralCatalog
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The General Catalog package.
+----------------------------------------------------------------------------+
| Name:        ImportExport
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The ImportExport package.
+----------------------------------------------------------------------------+
| Name:        iPhoneHandle
| Version:     4.0.1
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The iPhoneHandle Package.
+----------------------------------------------------------------------------+
| Name:        ITSM
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The OTRS::ITSM bundle package.
+----------------------------------------------------------------------------+
| Name:        ITSMChangeManagement
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The OTRS::ITSM Change Management package.
+----------------------------------------------------------------------------+
| Name:        ITSMConfigurationManagement
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The OTRS::ITSM Configuration Management package.
+----------------------------------------------------------------------------+
| Name:        ITSMCore
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The OTRS::ITSM Core package.
+----------------------------------------------------------------------------+
| Name:        ITSMIncidentProblemManagement
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The OTRS::ITSM Incident and Problem Management package.
+----------------------------------------------------------------------------+
| Name:        ITSMServiceLevelManagement
| Version:     5.0.6
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: The OTRS::ITSM Service Level Management package.
+----------------------------------------------------------------------------+
| Name:        MultiSMTP
| Version:     5.0.1
| Vendor:      Perl-Services.de
| URL:         http://www.perl-services.de
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: A module that allows OTRS to use several SMTP servers.
+----------------------------------------------------------------------------+
| Name:        OTRSMasterSlave
| Version:     5.0.2
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: Includes "Ticket Master/Slave" feature.
+----------------------------------------------------------------------------+
| Name:        Survey
| Version:     5.0.1
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: A customer survey tool.
+----------------------------------------------------------------------------+
| Name:        SurveyExport
| Version:     0.3.1
| Vendor:      Hunting Bears B.V.
| URL:         https://github.com/mbeijen/OTRS-SurveyExport
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: Survey CSV Export.
+----------------------------------------------------------------------------+
| Name:        SystemMonitoring
| Version:     5.0.1
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: Basic mail interface to System Monitoring Suites. Also provides deeper integration to Nagios (Acknowledge on lock and che                                ck script).
+----------------------------------------------------------------------------+
| Name:        TimeAccounting
| Version:     5.0.1
| Vendor:      OTRS AG
| URL:         http://otrs.org/
| License:     GNU AFFERO GENERAL PUBLIC LICENSE Version 3, November 2007
| Description: A Time Registration Module.
+----------------------------------------------------------------------------+
Done.


Code: Select all

server:~ # /opt/otrs/bin/otrs.CheckModules.pl
  o Apache::DBI......................ok (v1.12)
  o Apache2::Reload..................ok (v0.13)
  o Archive::Tar.....................ok (v1.82)
  o Archive::Zip.....................ok (v1.30)
  o Crypt::Eksblowfish::Bcrypt.......ok (v0.009)
  o Crypt::SSLeay....................ok (v0.58)
  o Date::Format.....................ok (v2.24)
  o DBI..............................ok (v1.617)
  o DBD::mysql.......................ok (v4.021)
  o DBD::ODBC........................Not installed! (optional - Required to connect to a MS-SQL database.)
  o DBD::Oracle......................Not installed! (optional - Required to connect to a Oracle database.)
  o DBD::Pg..........................Not installed! Use: 'zypper install perl-DBD-Pg' (optional - Required to connect to a PostgreSQL database.)
  o Encode::HanExtra.................ok (v0.23)
  o IO::Socket::SSL..................ok (v1.55)
  o JSON::XS.........................ok (v2.32)
  o List::Util::XS...................ok (v1.23)
  o LWP::UserAgent...................ok (v6.13)
  o Mail::IMAPClient.................ok (v3.32)
    o IO::Socket::SSL................ok (v1.55)
  o ModPerl::Util....................ok (v2.000006)
  o Net::DNS.........................ok (v0.68)
  o Net::LDAP........................ok (v0.44)
  o Template.........................ok (v2.24)
  o Template::Stash::XS..............ok (undef)
  o Text::CSV_XS.....................ok (v0.87)
  o Time::HiRes......................ok (v1.9725)
  o Time::Piece......................ok (v1.20_01)
  o XML::LibXML......................ok (v1.95)
  o XML::LibXSLT.....................ok (v1.76)
  o XML::Parser......................ok (v2.41)
  o YAML::XS.........................ok (v0.38)

server:/opt/otrs # rpm -Uvh --replacepkgs /tmp/5/otrs-5.0.6-01.noarch.rpm
Preparing... ########################################### [100%]
Check OTRS user ... otrs exists.
usermod: Account `otrs' is currently in use.
error: %pre(otrs-5.0.6-01.noarch) scriptlet failed, exit status 15
error: otrs-5.0.6-01.noarch: install failed

Does anyone have a tip on how I can solve this problem? We use this feature much.
Last edited by amdkryn on 13 Feb 2016, 21:14, edited 1 time in total.
OTRS version 5.0.27 (With ITSM), Operating System OpenSuse 12 with Mysql.

amdkryn
OTRS expert
Posts: 187
Joined: 02 Oct 2012, 02:52
OTRS Version?: 5.0.27

Re: Bulk ticket update error post 5.0.6-01 update

Post by amdkryn »

I do not know how to delete a post.

I swear I researched a lot before creating the post and suddenly, on the basis of a user who reinstalled the rpm package with --replacepkgs, had the idea to check the date of my file "/opt/otrs/Kernel/Modules/AgentTicketBulk.pm" and the date was old (no idea why). In short, I changed the file in use by the rpm package file and now is working.
OTRS version 5.0.27 (With ITSM), Operating System OpenSuse 12 with Mysql.

Post Reply