[SOLVED] Error internet explorer 9

Moderator: crythias

Post Reply
dcorbera
OTRS wizard
Posts: 164
Joined: 15 Mar 2013, 17:09
OTRS Version?: OTRS 3.2

[SOLVED] Error internet explorer 9

Post by dcorbera » 18 Mar 2014, 13:47

We have an error when enters on OTRS using internet explorer 9.
Namespace Core.UI.AdvancedChart could not be initialized, because nvd3 could not be found
How can we solve it?
Many thanks
Last edited by dcorbera on 07 Apr 2014, 15:24, edited 1 time in total.
Using:
OTRS HELP DESK 3.3.5
OTRS ITSM 3.3.5
POSTGRES 8.3

dcorbera
OTRS wizard
Posts: 164
Joined: 15 Mar 2013, 17:09
OTRS Version?: OTRS 3.2

Re: Error internet explorer 9

Post by dcorbera » 26 Mar 2014, 12:59

Any response?
Using:
OTRS HELP DESK 3.3.5
OTRS ITSM 3.3.5
POSTGRES 8.3

jojo
Moderator
Posts: 14390
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Error internet explorer 9

Post by jojo » 26 Mar 2014, 13:02

switch off combatibility mode
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

mom20xx
OTRS newbie
Posts: 5
Joined: 29 Apr 2014, 00:24
OTRS Version?: 3.3.6

Re: Error internet explorer 9

Post by mom20xx » 29 Apr 2014, 00:57

jojo wrote:switch off combatibility mode
sorry but in big companies with a lot of intranet servers with old web applications this is not feasible. you can not switch off a flag and then configure a huge exception list for other things to work. the better solution would be to fix this in the sources.

e.g. if you set

set header X-UA-Compatible: IE=Edge in the apache config should force IE to switch in Edge mode. this works on a lot of other Web Apps but not with OTRS. so this has to be fixed. it's not a solution to tell enterprises to use a different web browser

jojo
Moderator
Posts: 14390
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: [SOLVED] Error internet explorer 9

Post by jojo » 29 Apr 2014, 06:44

OTRS does set this header. But IE defaults in most environements to use compability mode for intranet sites. So you have to switch it off!
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

dasDing
OTRS expert
Posts: 54
Joined: 12 Nov 2013, 19:27
OTRS Version?: 4.0.x Linux

Re: [SOLVED] Error internet explorer 9

Post by dasDing » 01 Sep 2014, 09:38

So, is the solution to switch off compatiblity mode?
I know only a GPO to use pages in compatilbity mode but how can I don't use it in compatiblity mode?

User avatar
crythias
Moderator
Posts: 9984
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: [SOLVED] Error internet explorer 9

Post by crythias » 01 Sep 2014, 16:27

Note from Microsoft's website:
Beginning January 12, 2016, only the most current version of Internet Explorer available for a supported operating system will receive technical support and security updates. Please visit the Internet Explorer Support Lifecycle Policy FAQ here http://support.microsoft.com/gp/Microso ... t-Explorer for list of supported operating systems and browser combinations.
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

Post Reply