SegFault error when sending emails

Moderator: crythias

Post Reply
Netras
OTRS newbie
Posts: 1
Joined: 21 Feb 2013, 14:34
OTRS Version?: 3.1.7

SegFault error when sending emails

Post by Netras »

Hello all,

After searching through the forums and the general internet, I was not able to find a possible solution for an OTRS problem, maybe you have an idea.

The problem:
When OTRS sends an e-mail in rare cases a segfault error occurs. This can happen on any e-mail job (reply to customer, forward, escalation notification, etc.).
We are sending a couple of hundred e-mails daily from the system and we get this error around 10 times a day.

If the error occurs on a reply, the agents will get a "no-response-from-server" browser error and can refresh the page, which will usually successfully send out the e-mail.

We are sending mails through SMTP TLS and have checked with our e-mail provider for possible problems, but it seems that the problem is related to our OTRS system.
Currently we assume, that we are looking at a perl problem, but we cannot find proof either way.

The specific error message looks like this (this is from the apache error.log, the otrs_error.log shows no related errors):
[Thu Feb 21 11:54:59 2013] [notice] child pid 5366 exit signal Segmentation fault (11)
[Thu Feb 21 12:17:51 2013] [notice] child pid 5394 exit signal Segmentation fault (11)

A couple of facts:
OTRS 3.1.7
No ITSM module
No PERL customizing (just a few template/dtls)

Neither change logs of the new OTRS versions nor current bug reports promise any fixes for related issues.
Maybe you can point us in the right direction.

Thank you for reading through this and taking time to help!

Yours sincerely,

Netras Fent

CSL
OTRS expert
Posts: 159
Joined: 11 Nov 2011, 19:27
OTRS Version?: 3.0.11

Re: SegFault error when sending emails

Post by CSL »

It would probably be worth turning on debug level logging in apache to see if you can get any more concrete info on this error, and possibly pinpoint which module / script could be causing it.

If you can't gain anything more from the logs, then I think your best bet is to upgrade your system to the latest release on the 3.1.x line and hope that this goes away. If you've only customized some dtl files then updating shouldn't be as bad as it could be, and you might even get away with just a straightforward copy over the top of your directory (back up everything first). A segfault in an apache child does seem to point to a mod_perl issue. If updating OTRS doesn't fix it, then updating apache could be a next step, and finally upgrading OTRS to 3.2.x.
Backend: OTRS 3.0.11 RedHat Enterprise Linux 6.2, Apache, MySQL with replication
Frontend: OTRS 3.0.11 RedHat Enterprise Linux 6.2 with SELinux, Apache SSL

luis5m
OTRS newbie
Posts: 2
Joined: 04 Apr 2013, 17:23
OTRS Version?: OTRS 3.2
Real Name: Luis Mercado

Re: SegFault error when sending emails

Post by luis5m »

Hello

I just installed but I have serious problems when I'm in the email setup screen, I have the same error, any idea where or how I can solve the problem?


[Thu Apr 04 15:44:16 2013] [notice] child pid 13342 exit signal Segmentation fault (11)
[Thu Apr 04 15:44:18 2013] [notice] child pid 13339 exit signal Segmentation fault (11)
[Thu Apr 04 15:46:41 2013] [notice] child pid 13338 exit signal Segmentation fault (11)
[Thu Apr 04 15:46:42 2013] [notice] child pid 13363 exit signal Segmentation fault (11)
[Thu Apr 04 15:47:01 2013] [notice] child pid 13340 exit signal Segmentation fault (11)
[Thu Apr 04 15:47:03 2013] [notice] child pid 13369 exit signal Segmentation fault (11)


the version is 3.2.3

Post Reply