Errors after upgrading 3.1.1

Moderator: crythias

Post Reply
GEACAM
OTRS newbie
Posts: 4
Joined: 23 Feb 2012, 15:13
OTRS Version?: v3d1d1

Errors after upgrading 3.1.1

Post by GEACAM »

Hi everyone,

afer 3.1.1 upgrade, i've two issues with OTRS,

1) I can't create a new phone ticket, when i tried to submit a new one, the "FROM CUSTOMER" field turns blank and stop the process.
2) At "reply" a ticket, i get the "Core.Agent.CustomerSearch.AddTicketCustomer is not a function" error.

My OTRS has an ActiveDirectory connection, so all the customers (not the agents) are in my AD. When i access to "CUSTOMER" section, i can see every employes in AD.

Any ideas?

Thx for all

GEACAM
OTRS newbie
Posts: 4
Joined: 23 Feb 2012, 15:13
OTRS Version?: v3d1d1

Re: Errors after upgrading 3.1.1

Post by GEACAM »

I resolved it reinstalling all js from tarball.

Thanks.

ferrosti
OTRS ninja
Posts: 723
Joined: 10 Oct 2007, 14:30
OTRS Version?: 3.0
Location: Hamburg, Germany

Re: Errors after upgrading 3.1.1

Post by ferrosti »

Code: Select all

$OTRS_HOME/bin/otrs.LoaderCache.pl -o delete
should have resolved this, also
openSuSE on ESX
IT-Helpdesk: OTRS 3.0
Customer Service: OTRS 3.0 (upgraded from 2.3)
Customer Service (subsidiary): OTRS 3.0
+additional test and development systems

steveparker
OTRS newbie
Posts: 6
Joined: 23 Apr 2012, 15:30
OTRS Version?: 3.1.3
Real Name: Steve Parker

Re: Errors after upgrading 3.1.1

Post by steveparker »

ferrosti wrote:

Code: Select all

$OTRS_HOME/bin/otrs.LoaderCache.pl -o delete
should have resolved this, also
I just upgraded from 3.0.11 to 3.1.4 and I'm seeing the same error when I try to do a "reply" or a "reply all". I've run the DB upgrades as part of the process, and based on the previous reply, run the following (also part of the upgrade) as root from /opt/otrs again. I still see the error whenever I try to "reply" to a ticket.

Code: Select all

bin/otrs.RebuildConfig.pl
bin/otrs.DeleteCache.pl
bin/otrs.LoaderCache.pl -o delete
If I click OK or Cancel, the reply window comes up just fine, but the [Submit] button won't work.

When trying to create new email tickets, no matter what customer I put in the customer field, it always comes back with an error where it's cleared the "to" field, moved my value to the "cc" and "bcc" field, saying "Please include at least one customer for the ticket".

Did I miss something major along the way from 3.0.11 to 3.1.4? This notification for 3.1.4 is the first notification I've received about an upgrade since 3.0.11.

If it helps, this is the exact message I get from my browser when trying to reply to a ticket:

Code: Select all

'undefined' is not a function (evaluating 'Core.Agent.CustomerSearch.AddTicketCustomer( 'ToCustomer', '<my-email-address' )')

{anonymous}(TypeError: 'undefined' is not a function (evaluating 'Core.Agent.CustomerSearch.AddTicketCustomer( 'ToCustomer', '<my-email-address>' )'))
printStackTrace(#object)
{anonymous}(#function)
{anonymous}([object HTMLDocument],[#function])
{anonymous}()
{anonymous}([object Event])
Any thoughts on what's going on?

TIA, Steve

steveparker
OTRS newbie
Posts: 6
Joined: 23 Apr 2012, 15:30
OTRS Version?: 3.1.3
Real Name: Steve Parker

Re: Errors after upgrading 3.1.1

Post by steveparker »

As was the case with GEACAM, my issue was resolved by reinstalling the tar ball. I think I finally understand why, but don't have time to try to break it again to test my theory.

In the install instructions at http://doc.otrs.org/3.1/en/html/upgrading.html, step 2 says to backup a number of things, one of which is the /var directory. Then, in step 6, there's a section that has me restore the config files, I restored the /var directory too, even though that's not in the instructions (I figured it was an oversight).

So the manual, while technically correct, is a little misleading. I'll see if I can submit a documentation type bug report to get it cleaned up a bit.

But all is good again, and I'm fully operational.

Steve

boundsw
OTRS newbie
Posts: 6
Joined: 08 Oct 2012, 14:54
OTRS Version?: 3.0.12
Real Name: Warren Bounds
Company: Medco

Re: Errors after upgrading 3.1.1

Post by boundsw »

Im having this exact issue after an upgrade from 3.0.12 to 3.1.12

What does "reinstalling all js from tarball." mean ?

Im running OTRS on a Windows 2008 R2 Server.

none of these perl scripts solved the problem

bin/otrs.RebuildConfig.pl
bin/otrs.DeleteCache.pl
bin/otrs.LoaderCache.pl -o delete

And i copied over /var/* from the old install over the new. (I have a backup of the "new" var if required to go back)

still the same issue when trying to reply to tickets.

any ideas ?

ferrosti
OTRS ninja
Posts: 723
Joined: 10 Oct 2007, 14:30
OTRS Version?: 3.0
Location: Hamburg, Germany

Re: Errors after upgrading 3.1.1

Post by ferrosti »

What does "reinstalling all js from tarball." mean ?
I assume you should download the .tar.gz OTRS installation version and replace these files in installation path from this source.
Afterwards on should execute the aforementioned scripts and possibly restart the webserver (service).
openSuSE on ESX
IT-Helpdesk: OTRS 3.0
Customer Service: OTRS 3.0 (upgraded from 2.3)
Customer Service (subsidiary): OTRS 3.0
+additional test and development systems

boundsw
OTRS newbie
Posts: 6
Joined: 08 Oct 2012, 14:54
OTRS Version?: 3.0.12
Real Name: Warren Bounds
Company: Medco

Re: Errors after upgrading 3.1.1

Post by boundsw »

Ok - so I am not actually installing anything. Just placing the scripts in the relevant directory.

Ill try this now.

thank-you

Post Reply