Module FAQ Error

Moderator: crythias

Post Reply
manoj99
OTRS newbie
Posts: 19
Joined: 22 Jan 2020, 00:00
OTRS Version?: 5.0.41
Real Name: mk99

Module FAQ Error

Post by manoj99 »

Hello,

I wanted to completely get rid of FAQ Module so I have uninstalled FAQ Package from the admin page which also said that it deletes the tables.
But, even after deleting the cache from otrs shell (bin/otrs.Console.pl Maint::Cache::Delete) and restarting the apache ,I still see the error in my otrs logs
[Error][Kernel::System::Stats::GetObjectBehaviours][1136] Module Kernel/System/Stats/Static/FAQAccess.pm not in @INC (/home/otrs/perlib/lib/perl5//x86_64-linux-thread-multi /home/otrs/perlib/lib/perl5/ /home/otrs/perlib/lib/perl5/site_perl /home/otrs/perlib/lib64/perl5 /etc/httpd)

The Package Manager on my admin page is not complaining about anything but I see that error every time when I visit OTRS dashboard.

Any leads on this appreciated.

Thanks,
Mano.

zzz
OTRS wizard
Posts: 569
Joined: 15 Dec 2016, 15:13
OTRS Version?: 3.x–6.0.x
Real Name: Emin
Company: Efflux GmbH
Contact:

Re: Module FAQ Error

Post by zzz »

Hello Mano,

Try to execute this command as the OTRS user:

Code: Select all

/opt/otrs/bin/otrs.Console.pl Maint::Config::Rebuild --cleanup
and restart the web server.

Best regards
Emin

Edit: Just saw that you're using OTRS 5. Try to remove the parameter.
Professional OTRS services for development, consulting, hosting and support:
efflux.de – German | efflux.de/en/ – English

Free and premium OTRS add-ons (TextModule, AdBlocker, ModernSkin, ModernSkinCustomer etc.): portal.efflux.de

manoj99
OTRS newbie
Posts: 19
Joined: 22 Jan 2020, 00:00
OTRS Version?: 5.0.41
Real Name: mk99

Re: Module FAQ Error

Post by manoj99 »

Thanks for the response. Its still the same.

I have ran the command and deleted the binary files that are being created by apache. But stilll I find that in logs.

Is there anything else that I can try.

FYI, command - bin/otrs.Console.pl Maint::Config::Rebuild --cleanup-user-config for V5 OTRS.

Best,
Mano.

manoj99
OTRS newbie
Posts: 19
Joined: 22 Jan 2020, 00:00
OTRS Version?: 5.0.41
Real Name: mk99

Re: Module FAQ Error

Post by manoj99 »

zzz wrote:
31 Mar 2020, 16:08
Hello Mano,

Try to execute this command as the OTRS user:

Code: Select all

/opt/otrs/bin/otrs.Console.pl Maint::Config::Rebuild --cleanup
and restart the web server.

Best regards
Emin

Edit: Just saw that you're using OTRS 5. Try to remove the parameter.

Hello Emin,

I have tried using without parameter, but I still see the error

Thanks,
Mano.

zzz
OTRS wizard
Posts: 569
Joined: 15 Dec 2016, 15:13
OTRS Version?: 3.x–6.0.x
Real Name: Emin
Company: Efflux GmbH
Contact:

Re: Module FAQ Error

Post by zzz »

I had the error a while ago on the system of a customer who installed OTRS with wrong permissions.

Check the permission (and run SetPermission script), install the FAQ package and uninstall it back again.

Otherwise, I'd look up for FAQAccess in the system configuration and disable these settings by hand.
I know it's not the best solution, but at least it will not produce more error messages.

Best regards
Emin
Professional OTRS services for development, consulting, hosting and support:
efflux.de – German | efflux.de/en/ – English

Free and premium OTRS add-ons (TextModule, AdBlocker, ModernSkin, ModernSkinCustomer etc.): portal.efflux.de

manoj99
OTRS newbie
Posts: 19
Joined: 22 Jan 2020, 00:00
OTRS Version?: 5.0.41
Real Name: mk99

Re: Module FAQ Error

Post by manoj99 »

Hello Emin,

I tried installing and installing the FAQ Module but still throws an error even after running Cache Delete and Rebuild after uninstalling.

2. I dont have any SysConfig for FAQAcces/FAQ.

Please advice

Thanks,
M.

zzz
OTRS wizard
Posts: 569
Joined: 15 Dec 2016, 15:13
OTRS Version?: 3.x–6.0.x
Real Name: Emin
Company: Efflux GmbH
Contact:

Re: Module FAQ Error

Post by zzz »

If that's the only error you get, you might also want to check if you have a leftover FAQ statistic and delete it manually.

— Emin
Professional OTRS services for development, consulting, hosting and support:
efflux.de – German | efflux.de/en/ – English

Free and premium OTRS add-ons (TextModule, AdBlocker, ModernSkin, ModernSkinCustomer etc.): portal.efflux.de

mferraz
OTRS newbie
Posts: 15
Joined: 03 Oct 2016, 11:58
OTRS Version?: 6.0.27
Real Name: Miguel Ferraz
Company: Universidade do Porto

Re: Module FAQ Error

Post by mferraz »

I also want to get rid of the same module, check if you have any entrance to FAQ module on System Configuration (it's the next thing that I will try after solving the BUG with "Need From" on 6.0.27.

Post Reply