Errors in log after fresh installation

Moderator: crythias

Post Reply
sakul123
OTRS newbie
Posts: 13
Joined: 14 Mar 2017, 07:19
OTRS Version?: OTRS 3/4/5
Real Name: Sakul

Errors in log after fresh installation

Post by sakul123 » 31 Mar 2019, 06:50

Hi
I see below this error in system logs post fresh installation of OTRS 6 in centos 7 during navigating to any page.

Code: Select all

[Sun Mar 31 10:17:02 2019][Error][Kernel::System::Main::RequireBaseClass][119] Can't locate HASH(0x55ef37247ff0).pm in @INC (@INC contains: /opt/otrs/Custom /opt/otrs/Kernel/cpan-lib /opt/otrs/ /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /opt/otrs//Kernel/System/Main.pm line 82.

[Sun Mar 31 10:17:09 2019][Error][Kernel::System::Main::RequireBaseClass][119] Can't locate HASH(0x55ef374e6d40).pm in @INC (@INC contains: /opt/otrs/Custom /opt/otrs/Kernel/cpan-lib /opt/otrs/ /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /opt/otrs//Kernel/System/Main.pm line 82.

[Sun Mar 31 10:17:17 2019][Error][Kernel::System::Main::RequireBaseClass][119] Can't locate HASH(0x55ef371e39c0).pm in @INC (@INC contains: /opt/otrs/Custom /opt/otrs/Kernel/cpan-lib /opt/otrs/ /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /opt/otrs//Kernel/System/Main.pm line 82.

[Sun Mar 31 10:17:29 2019][Error][Kernel::System::Main::RequireBaseClass][119] Can't locate HASH(0x55ef374fa608).pm in @INC (@INC contains: /opt/otrs/Custom /opt/otrs/Kernel/cpan-lib /opt/otrs/ /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /opt/otrs//Kernel/System/Main.pm line 82.
Thanks
Sakul.
Thanks
Best Regards
Sakul
OTRS 3/4/5 Centos/RHEL/Ubuntu/Fedora Mysql

crythias
Moderator
Posts: 10104
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: Errors in log after fresh installation

Post by crythias » 31 Mar 2019, 22:48

Make sure you have the basic perl packages installed as well. Check the docs.
(No, not just OTRS required ones, but the basic perl package).
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

sakul123
OTRS newbie
Posts: 13
Joined: 14 Mar 2017, 07:19
OTRS Version?: OTRS 3/4/5
Real Name: Sakul

Re: Errors in log after fresh installation

Post by sakul123 » 01 Apr 2019, 09:19

Hi,

I have follwed the isntallation steps from below link.

https://www.vultr.com/docs/how-to-insta ... n-centos-7

and below is the status of checkModules.pl

Code: Select all

[root@otrsapp ~]# /opt/otrs/bin/otrs.CheckModules.pl
  o Apache::DBI......................ok (v1.12)
  o Apache2::Reload..................ok (v0.13)
  o Archive::Tar.....................ok (v1.92)
  o Archive::Zip.....................ok (v1.30)
  o Crypt::Eksblowfish::Bcrypt.......ok (v0.009)
  o Crypt::SSLeay....................ok (v0.64)
  o Date::Format.....................ok (v2.24)
  o DateTime.........................ok (v1.04)
  o DBI..............................ok (v1.627)
  o DBD::mysql.......................ok (v4.023)
  o DBD::ODBC........................Not installed! (optional - Required to conn                                                                             ect to a MS-SQL database.)
  o DBD::Oracle......................Not installed! (optional - Required to conn                                                                             ect to a Oracle database.)
  o DBD::Pg..........................ok (v2.19.3)
  o Digest::SHA......................ok (v5.85)
  o Encode::HanExtra.................ok (v0.23)
  o IO::Socket::SSL..................ok (v1.94)
  o JSON::XS.........................ok (v3.01)
  o List::Util::XS...................ok (v1.27)
  o LWP::UserAgent...................ok (v6.26)
  o Mail::IMAPClient.................ok (v3.37)
    o IO::Socket::SSL................ok (v1.94)
    o Authen::SASL...................ok (v2.15)
    o Authen::NTLM...................ok (v1.09)
  o ModPerl::Util....................ok (v2.000010)
  o Net::DNS.........................ok (v0.72)
  o Net::LDAP........................ok (v0.56)
  o Template.........................ok (v2.24)
  o Template::Stash::XS..............ok (undef)
  o Text::CSV_XS.....................ok (v1.00)
  o Time::HiRes......................ok (v1.9725)
  o XML::LibXML......................ok (v2.0018)
  o XML::LibXSLT.....................ok (v1.80)
  o XML::Parser......................ok (v2.41)
  o YAML::XS.........................ok (v0.54)
Thanks
Thanks
Best Regards
Sakul
OTRS 3/4/5 Centos/RHEL/Ubuntu/Fedora Mysql

Post Reply