Customer login failed with LDAP Backend

Moderator: crythias

Post Reply
lilpat
OTRS newbie
Posts: 3
Joined: 09 Feb 2018, 04:11
OTRS Version?: 6.0.4
Real Name: Patrick Sanscartier

Customer login failed with LDAP Backend

Post by lilpat » 10 Feb 2018, 22:16

New to OTRS. I installed my instance 2 weeks ago (OTRS6) and integrated Active Directory as a backend for agents. I am trying to integrate my customers with the same Active Directory backend (some of my agents will also be customers at times).

My LDAP binding and authentication is working (proven with a Wireshark trace, many times). Also proven by going in as an administrator into the Admin menu and I can see the customers populated, but when I'm trying to login from the customer.pl page, I get login failed.

Any help would be appreciated. Please let me know what you need for information. I'm not getting much for logs.

One more note, I was following a guide ealier on, that indicated to configure these settings within Default.pm.
Thanks in advance.
lilpat

**Installed on Ubuntu 16.04, Apache2, Mysql (all most recent versions for Ubuntu)

jojo
Moderator
Posts: 14195
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Customer login failed with LDAP Backend

Post by jojo » 10 Feb 2018, 23:31

never change the Defaults.pm!

Please show your changes and the errors from the logfile
"Production": OTRS Business Solution™ 6, STORM powered by OTRS
"Testing": OTRS git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

lilpat
OTRS newbie
Posts: 3
Joined: 09 Feb 2018, 04:11
OTRS Version?: 6.0.4
Real Name: Patrick Sanscartier

Re: Customer login failed with LDAP Backend

Post by lilpat » 11 Feb 2018, 03:15

thanks jojo. Where is the log file located and what is the name of that file? As I mentioned, I am totally new to OTRS. I have years of experience in managing Linux OS, but nothing with OTRS. I will have to restore the Default.pm from the install, and modify Config.pm.

lilpat
OTRS newbie
Posts: 3
Joined: 09 Feb 2018, 04:11
OTRS Version?: 6.0.4
Real Name: Patrick Sanscartier

Re: Customer login failed with LDAP Backend

Post by lilpat » 11 Feb 2018, 22:19

By restoring the Defaults.pm to the original, then copying my settings over to Config.pm, I noticed that there was a block of lines missing:

$Self->{'Customer::AuthModule'} =..... (and 5 more defining my connection settings)

This is now resolved. Thanks jojo for your help.

Post Reply