OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Moderator: crythias

Post Reply
andrep
OTRS newbie
Posts: 29
Joined: 13 Aug 2015, 13:12
OTRS Version?: 4.0.10

OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by andrep » 08 Mar 2019, 15:44

Dear all,

I installed few month ago an OTRS 6.0.8 and being able to setup IMAPTLS and SMTPTLS in order to get and send emails through Office 365. Everything works fine.

Today I installed I new server with OTRS 6.0.16, IMAPTLS works fine but I can't send email through SMTPTLS.

I got the message in the GUI :
Sending of this message has failed. [08.03.2019 12:09 (Europe/Zurich)] SMTP authentication failed: 500, Command unknown: 'AUTH'!
and in the log :
Message: CommunicationLog(ID:1612,AccountType:-,AccountID:-,Direction:Outgoing,Transport:Email,ObjectLogType:Message,ObjectLogID:3058)::Kernel::System::MailQueue => Message could not be sent! Error message: SMTP authentication failed: 500, Command unknown: 'AUTH'!

Did someone get the same problem ? I don't want to install a relay or another workaround.

Thank you for your help.

André

User avatar
crythias
Moderator
Posts: 10074
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by crythias » 09 Mar 2019, 05:40

SMTP Auth means you're trying to use authentication and it's not expecting it.
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

skilled
OTRS expert
Posts: 58
Joined: 11 Apr 2018, 13:53
OTRS Version?: 6.0.16

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by skilled » 11 Mar 2019, 00:02

if you could, try to send E-mails internally without auth and show if it is working or not?

Nooobstyle
OTRS newbie
Posts: 2
Joined: 13 Mar 2019, 16:08
OTRS Version?: 6.0.17

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by Nooobstyle » 14 Mar 2019, 12:55

Hi all,
Have same problem, who already solved with problem?
With google SMTPLS it works, but in google settings need to allow unsafe applications.

andrep
OTRS newbie
Posts: 29
Joined: 13 Aug 2015, 13:12
OTRS Version?: 4.0.10

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by andrep » 18 Mar 2019, 15:00

Hello,
It seems that the problem is known since few months
https://bugs.otrs.org/show_bug.cgi?id=14376

A bug was opened accordingly but I'm scare that it's not the priority of the OTRS dev. team.

Unfortunately I can't get the version 292 of PERL. Anybody has an idea ?

Thank you for your help

André

Nooobstyle
OTRS newbie
Posts: 2
Joined: 13 Mar 2019, 16:08
OTRS Version?: 6.0.17

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by Nooobstyle » 20 Mar 2019, 10:00

andrep wrote:
18 Mar 2019, 15:00
Hello,
It seems that the problem is known since few months
https://bugs.otrs.org/show_bug.cgi?id=14376

A bug was opened accordingly but I'm scare that it's not the priority of the OTRS dev. team.

Unfortunately I can't get the version 292 of PERL. Anybody has an idea ?

Thank you for your help

André
For me helped this solution from this ticket https://bugs.otrs.org/show_bug.cgi?id=14357

cpan IO::Socket::SSL
cpan Net::SMTP

service httpd restart

andrep
OTRS newbie
Posts: 29
Joined: 13 Aug 2015, 13:12
OTRS Version?: 4.0.10

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by andrep » 25 Mar 2019, 11:53

tip doesn't work,... :(

I got the message 'can't connect to outlook'.

In the log file :
[root@vps654461 tmp]# vi otrs.log
[Mon Mar 25 07:05:11 2019][Error][Kernel::System::Email::SMTP::Check][113] SMTP, connection try 1, unexpected error captured: To use SSL please install IO::Socket::SSL with version>=2.007 at /usr/local/share/perl5/Net/SMTP.pm line 268.

[root@vps654461 tmp]# yum install "perl(IO::Socket::SSL)"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* epel: www.mirrorservice.org
Package perl-IO-Socket-SSL-1.94-7.el7.noarch already installed and latest version
Nothing to do
[root@vps654461 tmp]#

This 1.94 version doesn't work. So a pity,...

User avatar
crythias
Moderator
Posts: 10074
Joined: 04 May 2010, 18:38
OTRS Version?: 5.0.x
Location: SouthWest Florida, USA
Contact:

Re: OTRS 6.0.8 versus 6.0.16 SMTP O365 Problem

Post by crythias » 27 Mar 2019, 21:40

CentOS 7 seems to be maxed at 1.94, but Open Fusion has at least 2.027
https://centos.pkgs.org/7/openfusion-x8 ... h.rpm.html
OTRS 5.0.x (private/testing/public) on Linux with MySQL database. Also on github.
Please edit your signature to include your OTRS version, Operating System, and database type.
Click Subscribe Topic below to get notifications. Consider amending your topic title to include [SOLVED] if it is so.
Need help? Before you ask

Post Reply