WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Hilfe zu OTRS Problemen aller Art
Post Reply
osiris1337
OTRS newbie
Posts: 6
Joined: 29 Dec 2010, 16:09
OTRS Version?: 3.0.4

WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by osiris1337 »

Hallo alle zusammen,

ich habe heute auf einen Windows Server 2008 Standard R2 OTRS 3.0.4 installiert.
Die OTRS installation habe ich mit dem Windows Installer von OTRS durchgeführt, nach der Installation
habe ich von MySQL auf MSSQL umgestellt, das hat auch alles soweit funktioniert.

Jetzt tritt leider immer folgendesproblem auf (manchmal) passiert es wenn ich auf OTRS auf irgendeinen Link Klicke
kommt die Fehlermeldung "Webseite kann nicht angezeigt werden" (Internet Explorer Fehlermeldung, das gleiche passiert auch mit Firefox)
Aufgefallen ist es mit als ich das FAQ Modul installieren wollte. Hier ist es mir nicht möglich den Explorer aufzurufen. Aber auch unter den Admin
Einstellungen kommt es mitlerweile sehr heufig vor das ich es nicht mehr öffen kann.

Woran könnte das liegen? Für eure Hilfe wäre ich sehr dankbar.

Gruß
Osiris1337
Testing: OTRS 3.0.4 / Win2008 x64 Std auf VMware ESXi4 / Apache2, MySQL5

Daniel Obee
Moderator
Posts: 644
Joined: 19 Jun 2007, 17:11
OTRS Version?: various
Real Name: Daniel Obée
Location: Berlin

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by Daniel Obee »

Wirf mal einen Blick in das Apache Log. Meist steht da schon drin, wo's hängt.

Evtl. sogar im SysLog des OTRS.

Gruß
Daniel

osiris1337
OTRS newbie
Posts: 6
Joined: 29 Dec 2010, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by osiris1337 »

Danke für den Tipp! Ich habe mal nachgeschaut und im SysLog von OTRS steht leider nichts.
Und im Apache Log steht folgendes:

Damit kann ich leider nicht soviel anfangen, könnte irgendwas auf den Fehler drauf hinweisen?

Und Nochmals Vielen Dank für die Hilfe!

Code: Select all

Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 1
[Wed Dec 29 15:23:33 2010] [notice] Apache/2.2.17 (Win32) mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.12.2 configured -- resuming normal operations
[Wed Dec 29 15:23:33 2010] [notice] Server built: Oct 18 2010 01:58:12
[Wed Dec 29 15:23:33 2010] [notice] Parent: Created child process 3540
Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 1
[Wed Dec 29 15:23:35 2010] [notice] Child 3540: Child process is running
[Wed Dec 29 15:23:35 2010] [notice] Child 3540: Acquired the start mutex.
[Wed Dec 29 15:23:35 2010] [notice] Child 3540: Starting 64 worker threads.
[Wed Dec 29 15:23:35 2010] [notice] Child 3540: Starting thread to listen on port 80.
[Wed Dec 29 15:23:51 2010] [warn] [client 127.0.0.1] incomplete redirection target of '/otrs/index.pl' for URI '/' modified to 'http://localhost/otrs/index.pl'
Out of memory!
[Wed Dec 29 15:24:01 2010] [notice] Parent: child process exited with status 1 -- Restarting.
Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 1
[Wed Dec 29 15:24:02 2010] [notice] Apache/2.2.17 (Win32) mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.12.2 configured -- resuming normal operations
[Wed Dec 29 15:24:02 2010] [notice] Server built: Oct 18 2010 01:58:12
[Wed Dec 29 15:24:02 2010] [notice] Parent: Created child process 3368
Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 1
[Wed Dec 29 15:24:06 2010] [notice] Child 3368: Child process is running
[Wed Dec 29 15:24:06 2010] [notice] Child 3368: Acquired the start mutex.
[Wed Dec 29 15:24:06 2010] [notice] Child 3368: Starting 64 worker threads.
[Wed Dec 29 15:24:06 2010] [notice] Child 3368: Starting thread to listen on port 80.
Out of memory!
[Wed Dec 29 15:24:06 2010] [notice] Parent: child process exited with status 1 -- Restarting.
Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 1
[Wed Dec 29 15:24:08 2010] [notice] Apache/2.2.17 (Win32) mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.12.2 configured -- resuming normal operations
[Wed Dec 29 15:24:08 2010] [notice] Server built: Oct 18 2010 01:58:12
[Wed Dec 29 15:24:08 2010] [notice] Parent: Created child process 3720
Scalars leaked: 1
Scalars leaked: 1
Scalars leaked: 1
[Wed Dec 29 15:24:11 2010] [notice] Child 3720: Child process is running
[Wed Dec 29 15:24:11 2010] [notice] Child 3720: Acquired the start mutex.
[Wed Dec 29 15:24:11 2010] [notice] Child 3720: Starting 64 worker threads.
[Wed Dec 29 15:24:11 2010] [notice] Child 3720: Starting thread to listen on port 80.
Testing: OTRS 3.0.4 / Win2008 x64 Std auf VMware ESXi4 / Apache2, MySQL5

Daniel Obee
Moderator
Posts: 644
Joined: 19 Jun 2007, 17:11
OTRS Version?: various
Real Name: Daniel Obée
Location: Berlin

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by Daniel Obee »

Da war irgendwas mit mod_perl... aber bei solchen Themen bin ich raus. Vielleicht kannst Du den Fehler ja googlen und findest was.

Sorry,
Daniel

osiris1337
OTRS newbie
Posts: 6
Joined: 29 Dec 2010, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by osiris1337 »

Ok, danke erstmal.

Also meine google Suche hat nicht wirklich viel ergeben wenn also jemand noch eine Idee hat,
wäre es sehr freundlich wenn mir jemand helfen könnte.

Schon mal vielen Dank für die Hilfe.

Gruß,
Kai
Testing: OTRS 3.0.4 / Win2008 x64 Std auf VMware ESXi4 / Apache2, MySQL5

garwen
OTRS superhero
Posts: 260
Joined: 03 Feb 2009, 16:51
OTRS Version?: 2.4.7

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by garwen »

mit dem "Scalars leaked: 1" kann ich auch nix anfangen. Aber folgende Zeile ist mir aufgefallen:

Code: Select all

[Wed Dec 29 15:23:51 2010] [warn] [client 127.0.0.1] incomplete redirection target of '/otrs/index.pl' for URI '/' modified to 'http://localhost/otrs/index.pl'
Out of memory!
[Wed Dec 29 15:24:01 2010] [notice] Parent: child process exited with status 1 -- Restarting.
Da läuft etwas mit rewrite schief und dann geht er auf of Memory. Den rewrite solltest Du auf jeden fall korrigieren.
Dann würde ich bei Google nach diesem "Scalars leaked: 1" suchen. Vielleicht hat das mit dem "Out of Memory" zu tun.
Mir scheint so, als ob der Apache den Speicher füllt und dadurch die Childs killt. Beobachte mal unter den Prozessen, wie sich die httpd.exe verhält.
MfG
~Fredy

Produktiv: OTRS 3.0.11/ openSUSE 11.4 / Apache2, MySQL5 / Exchange 2010

osiris1337
OTRS newbie
Posts: 6
Joined: 29 Dec 2010, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by osiris1337 »

Frohes neues Jahr,

also leider konnte ich nichts zu diesem Problem bei google finden... -.-

Es scheint aber definitiv am MSSQL Server zu liegen nachdem ich jetzt wieder auf mySQL umgestellt habe funktioniert alles
wunderbar...

Hat jemand vielleicht noch eine Idee? Für jede Anregung wäre ich sehr dankbar.

Gruß,
Kai
Testing: OTRS 3.0.4 / Win2008 x64 Std auf VMware ESXi4 / Apache2, MySQL5

jangli78
OTRS newbie
Posts: 5
Joined: 04 Jan 2011, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by jangli78 »

Hallo,

Bei mir tritt genau das gleiche Problem auf. Es lässt sich bei Aufruf des Stats-Moduls sogar reproduzieren. Firefox liefert dann lediglich eine weisse Seite. Leider ist somit das Stats-Modul nicht nutzbar. Auch beim automatische refresh des Dashboards tritt der Fehler manchmal auf.

Das Problem trat bei Version 3.0.3 bereits auf, und nun bei 3.0.4.
An Win2008R2 Std (x64) liegt es nicht, da ich auch auf Win2003R2 Std (32bit) getestet hatte.
"Hardware": vmWare ESXi4.1
DB: MS SQL 2005 Std

Ob es mit MySQL funktionierte kann ich nicht sagen.

Für Hilfe bei der Lösung des Problems wäre auch ich sehr dankbar.

mfg
jangli78

jangli78
OTRS newbie
Posts: 5
Joined: 04 Jan 2011, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by jangli78 »

reHallo,

Auch in Verbindung mit MS Sql 2008 64bit tritt das Problem auf.

mfg
jangli78

garwen
OTRS superhero
Posts: 260
Joined: 03 Feb 2009, 16:51
OTRS Version?: 2.4.7

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by garwen »

jangli78 wrote:Es lässt sich bei Aufruf des Stats-Moduls sogar reproduzieren.
Wie genau ? Auf meinem Testsystem kann ich es nicht reproduzieren.
Der Einzige Unterschied zwischen Deinem und meinem Test-System liegt im OS und der DB.
MfG
~Fredy

Produktiv: OTRS 3.0.11/ openSUSE 11.4 / Apache2, MySQL5 / Exchange 2010

jangli78
OTRS newbie
Posts: 5
Joined: 04 Jan 2011, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by jangli78 »

re,

die oben geposteten Fehler in der error.log sowie eine weisse Seite in Firefox treten auf nach dem Klick auf Statistics --> Overview auf, was folgenden Link laden sollte: http://mein_server/otrs/index.pl?Action=AgentStats;Subaction=Overview.

Ich werd morgen nochmal auf einem einfachen WinXP SP3 probieren. Leider darf ich vor Feierabend den Namen des Pinguin OS'es nicht mal denken... obwohl ich persönlich das bevorzugen würde.

mfg
jangli78

Kreuzi2000
OTRS newbie
Posts: 14
Joined: 04 Aug 2010, 09:13
OTRS Version?: 3.0.9

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by Kreuzi2000 »

Hallo, ich habe genau das selbe Problem mit 2008R2, OTRS 3.0.4 und MSSQL-DB. Gibts in dieser Hinsicht schon was Neues?
Bekomme statt der Statistik auch immer "Seite kann nicht angezeigt werden", und diese Logs im Apache.
OTRS 2.4.8, Windows Server 2008R2, MS SQL 2008
OTRS 3.0.11 (Testserver), Windows Server 2008R2, MS SQL 2008

jangli78
OTRS newbie
Posts: 5
Joined: 04 Jan 2011, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by jangli78 »

Hallo,

Leider noch nix neues, une ich hab auch keine Ahnung was ich noch irgendwie testen soll. Umstieg auf eine andere DB ist leider keine Alternative, genau so wenig wie ein nicht M$ OS. :-(

mfg
jangli78

Kreuzi2000
OTRS newbie
Posts: 14
Joined: 04 Aug 2010, 09:13
OTRS Version?: 3.0.9

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by Kreuzi2000 »

Seit gestern gibt es eine neue Version, 3.0.5, und diese funktioniert nun bei mir!!!
OTRS 2.4.8, Windows Server 2008R2, MS SQL 2008
OTRS 3.0.11 (Testserver), Windows Server 2008R2, MS SQL 2008

jangli78
OTRS newbie
Posts: 5
Joined: 04 Jan 2011, 16:09
OTRS Version?: 3.0.4

Re: WinSrv 2008 Std R2 + OTRS 3.0.4 Problem

Post by jangli78 »

juchee... kann ich bestätigen. bisher ist der fehler nicht mehr aufgetaucht seit dem update.

mfg
jangli78

Post Reply