Cron funktioniert nach neustart der Appliance nicht mehr

Hilfe zu OTRS Problemen aller Art
Post Reply
shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 12 Oct 2015, 15:30

Hallo,

wir haben die 4.0.8 Appliance installiert. Nachdem wir den Server heruntgefahren haben, funktioniert plötzlich unser Cron nicht mehr. Die Emails werden per postmaster_mailbox nicht mehr alle 10 minuten abgerufen. Ich habe auch schon Cron.sh restart probiert. Allerdings ohne Erfolg.In den Log Dateien kann ich auch nichts finden. Manuell über PostMaster-E-Mail Konten kann ich die Emails abrufen. Es funktioniert also nur der Cron nicht.
Den otrs.Scheduler.pl -a start habe ich ebenfalls gestartet ohne Fehler.

Woran kann das liegen? Danke!
Linux Debian Jessie
DB: postgres

Hazet
OTRS superhero
Posts: 386
Joined: 19 Feb 2009, 12:05
OTRS Version?: 5.0.9
Real Name: Harald Zahn
Company: Klinikum Augsburg
Location: Augsburg

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by Hazet » 13 Oct 2015, 07:15

Läuft denn der cron-Daemon?
Produktiv: OTRS 5.0.9 , (ITSM 5.0.10) unter Ubuntu 14.04, mysql 5.5
Test: OTRS 5.0.8 , (ITSM 5.0.8), KIX unter Ubuntu 14.04, mysql 5.5

shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 13 Oct 2015, 08:29

tut mir leid ich bin jetzt nicht der Linux spezialist. Kannst Du mir sagen wie ich das überpürfen kann?
Danke!
Linux Debian Jessie
DB: postgres

Hazet
OTRS superhero
Posts: 386
Joined: 19 Feb 2009, 12:05
OTRS Version?: 5.0.9
Real Name: Harald Zahn
Company: Klinikum Augsburg
Location: Augsburg

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by Hazet » 13 Oct 2015, 09:14

ps -ef|grep crond
Produktiv: OTRS 5.0.9 , (ITSM 5.0.10) unter Ubuntu 14.04, mysql 5.5
Test: OTRS 5.0.8 , (ITSM 5.0.8), KIX unter Ubuntu 14.04, mysql 5.5

shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 13 Oct 2015, 09:35

Danke. Anbei die Ausgabe.
You do not have the required permissions to view the files attached to this post.
Linux Debian Jessie
DB: postgres

jojo
Moderator
Posts: 14390
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by jojo » 13 Oct 2015, 09:38

dann läuft der Cron Daemon wohl nicht und muss gestartet werden.

Allerdings scheint mir Dein Linuxgrundwissen ebenfalls nicht vorhanden zu sein (Experten Wissen braucht man hier sicher nicht). Du solltest Dir dementsprechend überlegen das System durch entsprechende Fachfirmen betreiben zu lassen.
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

Hazet
OTRS superhero
Posts: 386
Joined: 19 Feb 2009, 12:05
OTRS Version?: 5.0.9
Real Name: Harald Zahn
Company: Klinikum Augsburg
Location: Augsburg

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by Hazet » 13 Oct 2015, 09:43

Dann als root:

service cron start

Ansonsten hat jojo recht: Ohne Linux-Grundwissen ist das ganze als managed Service sicher besser aufgehoben...
Produktiv: OTRS 5.0.9 , (ITSM 5.0.10) unter Ubuntu 14.04, mysql 5.5
Test: OTRS 5.0.8 , (ITSM 5.0.8), KIX unter Ubuntu 14.04, mysql 5.5

shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 13 Oct 2015, 10:36

Genau den Cron kann ich nicht starten. Warum auch immer.
You do not have the required permissions to view the files attached to this post.
Linux Debian Jessie
DB: postgres

Hazet
OTRS superhero
Posts: 386
Joined: 19 Feb 2009, 12:05
OTRS Version?: 5.0.9
Real Name: Harald Zahn
Company: Klinikum Augsburg
Location: Augsburg

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by Hazet » 13 Oct 2015, 10:39

Schau mal in die log-Dateien ob du da was findest...
Produktiv: OTRS 5.0.9 , (ITSM 5.0.10) unter Ubuntu 14.04, mysql 5.5
Test: OTRS 5.0.8 , (ITSM 5.0.8), KIX unter Ubuntu 14.04, mysql 5.5

shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 13 Oct 2015, 10:57

Ok zumindes läuft der Cron nun. Die Kiste läuft auf Hyper-V. Ich hatte zuvor die Cpus auf 4 erhöht. Schneinbar hat ihm das nicht gefallen. Nachdem ich nun die CPUS wieder 1 gestellt habe. läuft der Cron wieder. Allerdings werden die OTRS Jobs nach wie vor nicht ausgeführt.
Linux Debian Jessie
DB: postgres

shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 13 Oct 2015, 10:58

Sowohl die SchedulerERR.log als auch die SchedulerOUT.log sind leer.
In der /var/log/messages steht auch nichts was darauf hinweisen würde.
Linux Debian Jessie
DB: postgres

Hazet
OTRS superhero
Posts: 386
Joined: 19 Feb 2009, 12:05
OTRS Version?: 5.0.9
Real Name: Harald Zahn
Company: Klinikum Augsburg
Location: Augsburg

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by Hazet » 13 Oct 2015, 12:32

Sorry, aber jetzt bräuchtest Du jemanden mit einigermassen soliden Linux-Grundkenntnissen, das kann ich Dir remote nicht bieten...

Aber es gibt einen ganzen Schwung Treffer wenn man nach Deinem Fehlerbild bei google sucht.
Produktiv: OTRS 5.0.9 , (ITSM 5.0.10) unter Ubuntu 14.04, mysql 5.5
Test: OTRS 5.0.8 , (ITSM 5.0.8), KIX unter Ubuntu 14.04, mysql 5.5

shining01
OTRS superhero
Posts: 250
Joined: 07 Apr 2011, 08:02
OTRS Version?: 5.0.1

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by shining01 » 13 Oct 2015, 14:40

Vielleicht kann mir doch jemand noch helfen.
In der /var/log/syslog erhalte ich nach erfolgreichen start von service cron start und ./opt/otrs/bin/Cron.sh reload etc.

folgende Meldungen:
You do not have the required permissions to view the files attached to this post.
Linux Debian Jessie
DB: postgres

nd0
OTRS superhero
Posts: 232
Joined: 24 Mar 2015, 16:53
OTRS Version?: 5.0.14
Location: Colonia

Re: Cron funktioniert nach neustart der Appliance nicht mehr

Post by nd0 » 13 Oct 2015, 14:50

Ähnliches Phänomen wie bei mir, als ich angefangen hab mit der Appliance zu testen ...

Bei mir hat es damals geholfen wenn ich die virtuelle Maschine im vSphere Client neugestartet hab ... also ganz wichtig: Nicht "Runterfahren" und danach wieder "Einschalten", sondern einfach im "laufenden Betrieb" die Option "Neustart" wählen ... dann kamen alle Dienste mit hoch :lol:

Habe mich dann garnicht lange mit der Fehlersuche auseinandergesetzt, sondern wir haben uns dann relativ schnell GEGEN die Appliance entschieden :-)
LIVE: OTRS 5.0.14 || Debian || MySQL/LDAP
TEST: OTRS 5.0.14 || Debian || MySQL/LDAP

Post Reply