Fehler bei der Installation von OTRS 4.0.3

Hilfe zu OTRS Problemen aller Art
Post Reply
Hoschy
OTRS newbie
Posts: 3
Joined: 10 Jan 2015, 12:36
OTRS Version?: 3.3.11

Fehler bei der Installation von OTRS 4.0.3

Post by Hoschy » 10 Jan 2015, 15:01

Hallo Jungs und Mädels

Ich suchte ein Ticketsystem und bin bei OTRS gelandet. Ich habe mir einen vServer gemietet für Testzwecke um das OTRS mal zu testen. Der vServer besitzt Debian 7 und die Installation von dem Ticketsystem möchte nicht ganz funktionieren.
Ich wäre Euch Dankbar, wenn Ihr mir helfen könntet den Fehler zu finden.

Ich habe mich an diese Anleitung gehalten :
http://www.rootathome.de/installation-v ... er-debian/

Bei Schritt 3: Download und entpacken in der Anleitung habe ich dieses Paket gedownloadet:
wget http://ftp.otrs.org/pub/otrs/otrs-4.0.3.tar.gz

Bei dem Schritt 6: Rechte setzen bekomme ich allerdings ein Problem:
Ich gebe das ein:

Code: Select all

/opt/otrs/bin/otrs.SetPermissions.pl --otrs-user=otrs --otrs-group=otrs --web-user=www-data --web-group=www-data /opt/otrs
Ich erhalte dann von der Konsole diese Meldung:
Unknown option: otrs-group
Unknown option: web-user
Setting permissions on /opt/otrs
Wenn ich jetzt weiter mache mit Schritt 7: Konfiguration des Apache Webservers und ich gebe das in die Konsole ein:

Code: Select all

/etc/init.d/apache2 restart
Dann erhalte ich diese Meldung:
[....] Restarting web server: apache2 ... waiting Action 'start' failed.
The Apache error log may have more information.
failed!
In der /var/log/apache2/error.log steht jetzt das drin:

Code: Select all

[Sat Jan 10 13:36:07 2015] [notice] Apache/2.2.22 (Debian) configured -- resuming normal operations
[Sat Jan 10 13:53:05 2015] [notice] caught SIGTERM, shutting down
[Sat Jan 10 13:53:07 2015] [error] Can't locate Archive/Zip.pm in @INC (@INC contains: /usr/Custom /usr/Kernel/cpan-lib /usr /opt/otrs/Custom /opt/otrs/Kernel/cpan-lib /opt/otrs/ /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl . /etc/apache2) at /opt/otrs/Kernel/cpan-lib/Excel/Writer/XLSX/Workbook.pm line 25.\nBEGIN failed--compilation aborted at /opt/otrs/Kernel/cpan-lib/Excel/Writer/XLSX/Workbook.pm line 25.\nCompilation failed in require at /opt/otrs/Kernel/cpan-lib/Excel/Writer/XLSX.pm line 18.\nBEGIN failed--compilation aborted at /opt/otrs/Kernel/cpan-lib/Excel/Writer/XLSX.pm line 18.\nCompilation failed in require at /opt/otrs//Kernel/System/CSV.pm line 16.\nBEGIN failed--compilation aborted at /opt/otrs//Kernel/System/CSV.pm line 16.\nCompilation failed in require at /opt/otrs//Kernel/Modules/AgentTicketSearch.pm line 15.\nBEGIN failed--compilation aborted at /opt/otrs//Kernel/Modules/AgentTicketSearch.pm line 15.\nCompilation failed in require at /opt/otrs/scripts/apache2-perl-startup.pl line 140.\nBEGIN failed--compilation aborted at /opt/otrs/scripts/apache2-perl-startup.pl line 140.\nCompilation failed in require at (eval 2) line 1.\n
[Sat Jan 10 13:53:07 2015] [error] Can't load Perl file: /opt/otrs/scripts/apache2-perl-startup.pl for server 111.ip-37-187-178.eu:0, exiting...
Ich habe absolut keinen Plan was das jetzt bedeutet

Da ich jede Menge Zeit hatte habe ich noch die Version OTRS 4.0.2 und OTRS 4.0.1 getestet und bleibe immer an der selben Stelle stehen. Bei der Installation von der Version OTRS 3.3.11 gab es keine Probleme die komplette Anleitung hat genau Funktioniert. Ich wollte dann Versuchen zu upgraden auf die Version 4.0.3, aber leider auch da ohne Erfolg.

Wäre echt nett, wenn man da ne Lösung für das Problem finden könnte.

Danke Euch

Mit freundlichen Grüßen

Hoschy

jojo
Moderator
Posts: 14390
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Fehler bei der Installation von OTRS 4.0.3

Post by jojo » 10 Jan 2015, 15:39

Bitte halte Dich an diese Anleitung: http://otrs.github.io/doc/manual/admin/ ... -on-debian
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

Hoschy
OTRS newbie
Posts: 3
Joined: 10 Jan 2015, 12:36
OTRS Version?: 3.3.11

Re: Fehler bei der Installation von OTRS 4.0.3

Post by Hoschy » 10 Jan 2015, 15:43

Ok versuche diese dann.

Danke Dir

Hoschy
OTRS newbie
Posts: 3
Joined: 10 Jan 2015, 12:36
OTRS Version?: 3.3.11

Re: Fehler bei der Installation von OTRS 4.0.3

Post by Hoschy » 11 Jan 2015, 03:21

Hat funktioniert

Vielen Dank

dasDing
OTRS expert
Posts: 54
Joined: 12 Nov 2013, 19:27
OTRS Version?: 4.0.x Linux

Re: Fehler bei der Installation von OTRS 4.0.3

Post by dasDing » 12 Feb 2015, 15:10

Hi, ich habe gemerkt, dass sich bei SetPermissions die Synatex geändert hat. Ist das richtig, wenn ich das jetzt so schreibe?
#alt./otrs/bin/otrs.SetPermissions.pl --otrs-user=otrs --otrs-group=www-data --web-user=www-data --web-group=www-data /opt/otrs
./otrs/bin/otrs.SetPermissions.pl --otrs-user=otrs --web-group=www-data /opt/otrs

Oder muss ich --admin-group=www-data hinschreiben?

Rooobaaat
OTRS ninja
Posts: 432
Joined: 11 Sep 2014, 16:28
OTRS Version?: OTRS 5.0.x

Re: Fehler bei der Installation von OTRS 4.0.3

Post by Rooobaaat » 12 Feb 2015, 22:03

Code: Select all

./otrs/bin/otrs.SetPermissions.pl --otrs-user=<OTRS_USER> --web-group=<APACHE-GRUPPE> /opt/otrs
ist die richtige Syntax
My english is better than your german :P

"Produktiv": OTRS: 5.0.x, OTRS::ITSM 5.0.x
"Testing": OTRS 6 git
OS: Debian 8.0 (Jessie)
Apache2.4.10/MySQL 5.5.41

dasDing
OTRS expert
Posts: 54
Joined: 12 Nov 2013, 19:27
OTRS Version?: 4.0.x Linux

Re: Fehler bei der Installation von OTRS 4.0.3

Post by dasDing » 16 Feb 2015, 10:56

Wann bräuchte ich die --admin-group?

wurzel
OTRS guru
Posts: 2536
Joined: 08 Jul 2010, 22:25
OTRS Version?: 6.0.x

Re: Fehler bei der Installation von OTRS 4.0.3

Post by wurzel » 16 Feb 2015, 14:31

Hi,

ich kenne das mit der admin group bei BSD Systemen. Sonst wüsste ich nicht, warum man das braucht.

Flo
    ((OTRS)) Community Edition 6.0.x, LAMP LIVE auf Debian 9
    OTRS 6 Managed Silver

    -- Ich beantworte keine Forums-Fragen PN - No PN please

    I won't answer to unfriendly users any more. A greeting and regards are just polite.

    dasDing
    OTRS expert
    Posts: 54
    Joined: 12 Nov 2013, 19:27
    OTRS Version?: 4.0.x Linux

    Re: Fehler bei der Installation von OTRS 4.0.3

    Post by dasDing » 16 Feb 2015, 18:01

    Wann wird das BSD-Systemen eingesetzt?
    Muss das möglicherweise eine Gruppe sein über die man Rootrechte erhält? :)

    wurzel
    OTRS guru
    Posts: 2536
    Joined: 08 Jul 2010, 22:25
    OTRS Version?: 6.0.x

    Re: Fehler bei der Installation von OTRS 4.0.3

    Post by wurzel » 16 Feb 2015, 23:43

    Hi,

    der Administrator setzt das Betriebssystem seiner Wahl ein. Wenn er ein (Free-)BSD nimmt ist das halt so.

    Flo
      ((OTRS)) Community Edition 6.0.x, LAMP LIVE auf Debian 9
      OTRS 6 Managed Silver

      -- Ich beantworte keine Forums-Fragen PN - No PN please

      I won't answer to unfriendly users any more. A greeting and regards are just polite.

      dasDing
      OTRS expert
      Posts: 54
      Joined: 12 Nov 2013, 19:27
      OTRS Version?: 4.0.x Linux

      Re: Fehler bei der Installation von OTRS 4.0.3

      Post by dasDing » 17 Feb 2015, 12:43

      Hi Wurzel, sorry, ich habe einen Schreibfehler drin gehabt: Wann wird admin-group bei BSD eingesetzt? Weißt du, in welcher Situation dieser Parameter unter BSD notwendig ist und welchen Nutzen er dann hat?

      Post Reply