Fehler: Access denied for user...

Hilfe zu OTRS Problemen aller Art
Post Reply
Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Fehler: Access denied for user...

Post by Christoph » 06 Apr 2006, 08:30

Hallo zusammen,

ich habe die Aufgabe bekommen OTRS einzurichten und komme leider an einer Stelle nicht weiter, die für mich als Linux-"Anfänger" noch ein recht passables Problem darstellt.
Die Einrichtung des Apache etc lief problemlos und die Verknüpfungen zum starten von der OTRS installation habe ich auch noch ohne Hilfe einrichten können, nur bin ich nun an einem Punkt angekommen wo ich als Linux-newby leider nicht weiter weiss...

Hier noch ein Paar Daten die vllt weiterhelfen könnten:
OS: Fedora(CORE) - Linux
OTRS: v 2.0.4

Die "Installtion" von OTRS lief bislang fehlerfrei. Nur der letzte Schritt unterscheidet sich von der auf der offiziellen OTRS-Homepage. Nachdem ich die Datenbank angelegt habe, soll ich noch den Webserver neustarten.

Der Hinweis lautet:
Starte Deinen Webserver neu.:
service httpd restart
Danach läuft Dein OTRS.


Kein großes Problem. Den Neustart habe ich auch hin bekommen.
Doch dann kam ich nicht weiter:
Als ich auf die index.pl wollte um die ersten Schritte in OTRS auszuführen, kam folgende Warnmeldung:

Fehler: Access denied for user 'otrs'@'localhost' (using password: YES)
Kommentar: Please contact your admin
Fehler berichten: [Klicken Sie hier um den Fehler zu berichten.]
Traceback: ERROR: OTRS-CGI-10 Perl: 5.8.6 OS: linux Time: Thu Apr 6 08:04:33 2006

Message: Access denied for user 'otrs'@'localhost' (using password: YES)

Traceback (2784):
Module: Kernel::System::DB::new (v1.47) Line: 168
Module: Kernel::System::Web::InterfaceAgent::Run (v1.8) Line: 150
Module: /opt/lampp/htdocs/otrs/index.pl (v1.80) Line: 47


Was muss ich nun tun damit ich den Fehler ausbessern kann?
Ich danke schonmal all denen die mir helfen wollten :]
Gruß!

lindesbs
OTRS superhero
Posts: 225
Joined: 09 Dec 2005, 14:18
Contact:

Post by lindesbs » 06 Apr 2006, 09:09

Das ist eindeutig ein Problem beim Zugriff aufdeine SQL-Datenbank. hast du den Benutzer auch in der DB ? Ist die DB neu gestartet ? Evt. Hilft es auch, statt localhost die IP einzutragen, je nachdem, wie dein System eingerichtet ist, wo der SQL-Server steht, wie die Zugriffsrechte im SQL-Server gesetzt sind.
OTRS meets Contao

darkside

Post by darkside » 06 Apr 2006, 09:10

Hallo und Willkommen :)

Das sieht mir nach einem Rechteproblem mit der Datenbank aus.

Vermute mal Du nutzt mySQL?? Gibt es denn da einn user "otrs" der auch Zugriff auf die DB hat??

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 09:46

Ja hm...
Ich hab den User otrs der Datenbank schon hinzugefügt und habe das ganze auch gerade nocheinmal überprüft, der Fehler kommt bei mir immernoch auf.
Muss das Passwort für den User otrs in OTRS auch mit dem der Datenbank überweinstimmen oder könnte der Konflikt darin bestehen?

darkside

Post by darkside » 06 Apr 2006, 09:52

Nein, die PWD's müssen nicht identisch sein.

Nur
1. MySQL muss eben den Nutzer kennen (hast Du ja geprüft)
2. Der User muss Zugriffsrechte haben auf diese DB
3. OTRS muss in der Config nebst dem Server eben genau diesen Nutzer plus PWD zu stehen haben.

Die Daten für den Zugriff sollten in der config.pm unterhalb "Kernel" stehen. Überprüfe die doch noch mal

probier doch mal an der Konsole sowas wie

Code: Select all

mysqlshow --user=<username> --password=<password>
Die <> Werte müssen natürlich angepasst sein. Kommt da die Fehlermeldung auch schon, ist definitiv der Zugriff auf die DB nicht richtig.

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 10:16

Ja dann wird es an der DB liegen...
Die Warnmeldung ist die gleiche und sieht in der C folgendermaße aus:

Code: Select all

mysqlshow: Access denied for user 'otrs'@'localhost' (using password: YES)
Nur wo sollte der Fehler liegen?
Ich habe dem User "otrs" in der DB rechte zugewiesen und ihn auch angelegt.
Sollte ich Kennwort und Passwort ändern/eingeben oder auslassen?

darkside

Post by darkside » 06 Apr 2006, 10:24

Also, so der DB Freak bin ich nicht.

Womit arbeitest Du auf der DB?? Direkt von der Shell aus oder ein Tool??

Ich mache das ganz gerne mit Webmin. Darüber habe ich die Rechte gesetzt.

Mmhh, ich würde noch mal den Nutzer und dessen Rechte entfernen. Dann erst mal nur den Nutzer anlegen und PWD setzen und mit mysqlshow probieren.

Wenn das klappt, ihm Datenbankzugriffe gewähren und mit mysqlshow probieren.

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 10:32

BIn noch ganz neu in dem Gebiet, deswegen weiss ich warscheinlich auch nicht direkt alleine weiter. Ich benutze gerade die Adminoberfläche von XAMP, also myphpadmin und mysqladmin... Wenn das nicht die beste oder richtige Wahl ist sollte ich mich wohl schnell umentscheiden. Ich kanns ja auch mit einer anderen Oberfläche probieren, vllt bringt das ja etwas.
Hm...
Dann leg ich den user nocheinmal neu an und geb ihm keine/nur eingeschränkte Rechte und kein PWD.
Mal probieren...

darkside

Post by darkside » 06 Apr 2006, 10:38

Nuja, richtiges oder falsches Tool ... das gibt es so ja nicht. Es gibt nur ein Lieblingstool :)

Meines heist Webmin und MySQL-Front. Aber es gibt auch andere. Mit MySQL-PHPAdmin arbeite ich so direkt nicht ... aber es ist ein weit verbreitetes ... und sicher auch kein schlechtes.

Jetzt mal auf Dein System raufschauen währe schön :wink:

JB
OTRS wizard
Posts: 102
Joined: 20 Feb 2006, 13:51

Post by JB » 06 Apr 2006, 10:52

Das sql Passwort vom user otrs ist falsch!
Stable System: OTRS 2.1.1 Source; Ubuntu Dapper Drake; Apache2.0.x; MySQL 5.0.x

Test System: OTRS 2.0.4 .deb Packages; Debian testing; Apache2.0.x; MySQL 4.1.x

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 11:09

irgentwie steig ich da grade nicht durch...
Also ich habe den user nun neu angelegt und ihm keine rechte gegeben, ihm aber ein PW zugeteilt. Habe es dann mit mysqlshow versucht, was aber auch wieder nicht funktioniert hat. Das gleiche habe ich auch mit Userrechten versucht.
Dann habe ich das ganze auch noch ohne Userpwd versucht was auch nicht klappte.
Die Ausgabe der Console lautet wie folgt:

Code: Select all

 
+--------------------+
|     Databases      |
+--------------------+
| information_schema |
| test               |
+--------------------+

oder

mysqlshow: Access denied for user 'otrs'@'localhost' (using password: YES)
Dass das Pwd nicht stimmt hab ich mir auch schon gedacht ;]
Wie kann ich das ganze denn nun ändern und zwar so, dass das auch funktioniert? :[

darkside

Post by darkside » 06 Apr 2006, 11:15

Code: Select all

 
+--------------------+
|     Databases      |
+--------------------+
| information_schema |
| test               |
+--------------------+
Also, diese Auflistung kommt, wenn der Nutzer akzeptiert wird, den man über die Parameter --user und --password angegeben hat.

Hier muss halt noch nac Zuweisung der Rechte auf die OTRS-DB auch diese aufgelistet werden.

Code: Select all

mysqlshow: Access denied for user 'otrs'@'localhost' (using password: YES)
Diese Meldung sollte nur kommen, wenn der Nutzer nicht existiert oder aber das PWD nicht richtog übergeben wird.

Meine Fragen:
PWD enthält kein Umlaute oder Leezeichen oder abartige Sonderzeichen???

Ist ansonsten schwer von der Ferne Dir zu helfen :|

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 11:21

Nein nur normale Buchstaben, weder Umlaute noch Sonderzeichen etc.
Ist vllt möglich, dass die Verbindung zwischen der Datenbank und dem User nicht Korrekt ist, also der User nicht den richtigen Bezug auf die DB hat?

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 11:35

Also ich hab nun die mysqlshow-Ausgabe:

Code: Select all

 
+--------------------+
|     Databases      |
+--------------------+
| information_schema |
| TestDatabase       |
| test               |
+--------------------+
was doch soviel bedeuten müsste, dass der User mit der DB in Verbindung steht oder nicht?

darkside

Post by darkside » 06 Apr 2006, 11:40

Ja, das müsste so passen.

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 11:45

Ist ja schonmal ein Anfang... die Warnmeldung bekomme ich beid er index.pl trotzdem immernoch...

darkside

Post by darkside » 06 Apr 2006, 12:02

Wie heißt Deine OTRS-DB??

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 12:04

TestDatabase

so wie sie auch oben in der Databaseübersicht gelistet wurde.

darkside

Post by darkside » 06 Apr 2006, 12:06

Hab ich schon vermutet :)

config.pm Stimmt?? (inkl. Groß/Kleinschreibung)??
Datenbank läuft auf dem selben Server wie OTRS??

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 12:10

Denke schon:

Code: Select all

    # DatabaseHost
    # (The database host.)
    $Self->{'DatabaseHost'} = 'localhost';
    # Database
    # (The database name.)
    $Self->{'Database'} = 'TestDatabase';
    # DatabaseUser
    # (The database user.)
    $Self->{'DatabaseUser'} = 'otrs';
    # DatabasePw
    # (The password of database user.)
# (The password of database user.)
    $Self->{'DatabasePw'} = '<pwd>;
    $Self->{'DatabasePw'} = '<pwd>';
    # DatabaseDSN
    # (The database DSN for MySQL ==> more: "man DBD::mysql")
    $Self->{DatabaseDSN} = "DBI:mysql:database=$Self->{Database};host=$Self->{DatabaseHost};";
denke das die config.pm so stimmen wird oder?

Andre Bauer
OTRS guru
Posts: 2191
Joined: 08 Dec 2005, 17:01
OTRS Version?: 5.0.x
Real Name: André Bauer
Company: Magix Software GmbH
Location: Dresden
Contact:

Post by Andre Bauer » 06 Apr 2006, 12:18

Nein, stimmt so nicht.
Bei dir ist der Passworteintrag doppelt und bei einem der Einträge fehlt ein Hochkomma.
Dadurch wird wahrscheinlich die zweite Passwortzeile noch mit zum Passswort dazu gezählt....
Last edited by Andre Bauer on 06 Apr 2006, 12:22, edited 3 times in total.
Prod: Ubuntu Server 16.04 / Zammad 1.2

DO NOT PM ME WITH OTRS RELATED QUESTIONS! ASK IN THE FORUMS!

OtterHub.org

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 06 Apr 2006, 12:20

hab eben nur das pwd rausgenommen, deswegen fehlt das hochkomma.
ich lösche mal die eine zeile im code.
geändert hat sich trotzdem nichts...
Last edited by Christoph on 06 Apr 2006, 12:21, edited 1 time in total.

darkside

Post by darkside » 06 Apr 2006, 12:20

Boa, ich hab da grad 10min rauf geschaut und das nicht gesehen :)

Wie blind man doch ist!!

darkside

Post by darkside » 06 Apr 2006, 14:49

Also, ich muss erst mal passen. Hab keine Idee mehr, sorry.

Andre Bauer
OTRS guru
Posts: 2191
Joined: 08 Dec 2005, 17:01
OTRS Version?: 5.0.x
Real Name: André Bauer
Company: Magix Software GmbH
Location: Dresden
Contact:

Post by Andre Bauer » 06 Apr 2006, 15:02

Ist die Datenbank denn richtig befüllt?
Wieviele Tabellen hast du?
Prod: Ubuntu Server 16.04 / Zammad 1.2

DO NOT PM ME WITH OTRS RELATED QUESTIONS! ASK IN THE FORUMS!

OtterHub.org

zero cool
OTRS expert
Posts: 72
Joined: 22 Feb 2006, 21:01

Post by zero cool » 06 Apr 2006, 15:26

Hallo zusammen,

versuchs mal von vorne. erstelle einen neuen DB-User wie hier beschrieben.

Code: Select all

Create an database user:
-----------------------
shell> mysql -u root -p -e 'GRANT ALL PRIVILEGES ON otrs.* TO otrs@localhost IDENTIFIED BY "some-pass" WITH GRANT OPTION;'

Reload the grant tables of your mysql-daemon:
---------------------------------------------
shell> mysqladmin -u root -p reload

**************************************************************
*                                                            *
* Change the DB-Settings (host, database, user and password) *
*                                                            *
*   $OTRS_HOME/Kernel/Config.pm                              *
*   [...]                                                    *
*   # Database                                               *
*   # (The database name.)                                   *
*   $Self->{Database} = 'otrs';                              *
*                                                            *
*   # DatabaseUser                                           *
*   # (The database user.)                                   *
*   $Self->{DatabaseUser} = 'otrs';                          *
*                                                            *
*   # DatabasePw                                             *
*   # (The password of database user.)                       *
*   $Self->{DatabasePw} = 'some-pass';                       *
*   [...]                                                    *
*                                                            *
**************************************************************
-fb-

System : Debian Edge (unstable/ testing) -- in einer VM
WebServer : Apache 2 - inkl. mod_perl
Datenbank : mySQL 5
OTRS-Version : 2.4.2

Andre Bauer
OTRS guru
Posts: 2191
Joined: 08 Dec 2005, 17:01
OTRS Version?: 5.0.x
Real Name: André Bauer
Company: Magix Software GmbH
Location: Dresden
Contact:

Post by Andre Bauer » 06 Apr 2006, 16:37

Ja, ich würde auch empfehlen nochmal komplett von vorn zu beginnen.
Am besten die gesamte DB samt Usern löschen und dann neu erstellen.
Bei der Conig.pm solltest du am besten auch noch mal mit ner neuen anfangen.
Prod: Ubuntu Server 16.04 / Zammad 1.2

DO NOT PM ME WITH OTRS RELATED QUESTIONS! ASK IN THE FORUMS!

OtterHub.org

Christoph
OTRS newbie
Posts: 24
Joined: 06 Apr 2006, 08:11
Location: Ense
Contact:

Post by Christoph » 07 Apr 2006, 08:14

Ja dann werde ich nochmal ganz von vorne anfangen... Ob das dann klappt/geklappt hat werdet ihr natürlich erfahren. ;]

@ zero: Danke für deine Hilfe. Das ganze hat mir leider nicht weiterhelfen können...
Ich habe mich an dein Beispiel gehalten und kam schon nach dem ersten Befehl nicht weiter.
Die Antwort in der Shell-Konsole war diese:

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Also im Prinzip das gleiche wie mit dem User otrs. Da ich noch kein Datenbank Profi bin wird der Fehler an der DB liegen, keine Frage.

Andre Bauer
OTRS guru
Posts: 2191
Joined: 08 Dec 2005, 17:01
OTRS Version?: 5.0.x
Real Name: André Bauer
Company: Magix Software GmbH
Location: Dresden
Contact:

Post by Andre Bauer » 07 Apr 2006, 09:27

Alos wenn auf der Shell die gleiche Fehlermeldung kommt, dann ist definitv das Passwort falsch.
Prod: Ubuntu Server 16.04 / Zammad 1.2

DO NOT PM ME WITH OTRS RELATED QUESTIONS! ASK IN THE FORUMS!

OtterHub.org

zero cool
OTRS expert
Posts: 72
Joined: 22 Feb 2006, 21:01

Post by zero cool » 10 Apr 2006, 20:12

Hallo,

richte mysql neu ein und vergib ein neues DB-Admin PW
Hier solltest du eines vergeben -> leere Admin-PW machen immer stress...

nur nicht aufgeben. das resultat lohnt sich :mrgreen:
-fb-

System : Debian Edge (unstable/ testing) -- in einer VM
WebServer : Apache 2 - inkl. mod_perl
Datenbank : mySQL 5
OTRS-Version : 2.4.2

Post Reply