Probleme nach Update auf 3.3.5

Hilfe zu OTRS Problemen aller Art
Post Reply
insideAC
OTRS newbie
Posts: 30
Joined: 06 Sep 2013, 11:13
OTRS Version?: 3.2.9

Probleme nach Update auf 3.3.5

Post by insideAC »

Hallo,

ich habe heute einmal von 3.2.9 auf 3.3.5 aktualisiert.
Hier sind drei Fragen, die sich mir nun stellen:

1. Scheduler läuft nicht
Diese Meldung erscheint nach der Aktualisierung. Ich habe den Scheduler nicht beendet vor dem Update, nur den apache2 und cron beendet.
Anschließend habe ich den cron neu gestartet und die Mailabholung, etc. funktionierte wieder. Scheint, als ob dies unabhängig vom Scheduler funktioniert. Was genau macht der Scheduler und wodurch unterscheidet er sich von den Cronjobs? Muss der Scheduler gestartet sein?

2. Auto-Reply automatisch Cc an Kunden-E-Mail:
Nach dem Update wurde automatisch beim Auto-Reply auf ein eingehendes Ticket auf die E-Mail-Adresse, die im Kundenkontakt steht als Cc hinzugefügt. Wie kann das sein? Die Konfiguration wurde doch nicht geändert.
Behoben habe ich dies indem ich in der Datei /opt/otrs/Kernel/System/Ticket/Article.pm folgenden Block auskommentiert habe:

Code: Select all

if ( $Ticket{CustomerUserID} ) {
        my %CustomerUser = $Self->{CustomerUserObject}->CustomerUserDataGet(
            User => $Ticket{CustomerUserID},
        );
        if ( $CustomerUser{UserEmail} && $OrigHeader{From} !~ /\Q$CustomerUser{UserEmail}\E/i ) {
            $Cc = $CustomerUser{UserEmail};
            $ToAll .= ', ' . $Cc;
        }
    }
Außerdem wurde beim Antworten auf Tickets immer der Empfänger auf den im Kundenkontakt stehenden geändert.
Das konnte ich in der Config über

Code: Select all

ComposeReplaceSenderAddress
in den Griff bekommen.

So wirklich logisch finde ich das nicht, Warum ist nach dem Update ein Eingriff notwendig?

3. Regelmäßige Meldung im Log.
Nach dem Update erscheinen ca. alle 3 Minuten folgende Meldungen im Log:

Code: Select all

[Kernel::System::State::StateLookup[577] No State for new found!
[Kernel::System::State::StateLookup[577] No State for open found!
Was bedeutet dies und ist dies funktionsmäßig problematisch?
Wie kann man die sin den Griff bekommen?

Da das Produktivupdate Morgen ansteht wäre eine schnelle Antwort sehr prima!

Grüße
Roland

Post Reply