Welche Datenbankversion?

Hilfe zu OTRS Problemen aller Art
Post Reply
dasDing
OTRS newbie
Posts: 54
Joined: 12 Nov 2013, 19:27
OTRS Version?: 4.0.x Linux

Welche Datenbankversion?

Post by dasDing »

Hallo alle zusammen,

ich habe kürzlich OTRS auf Version 3.2.12 geupdatet.
Beim Update der Datenbank (3.2-Skript) hat er mir angezeigt, dass zwei Tabellen nicht entfernen kann, weil sie nicht vorhanden sind.
Außerdem werden mir seit Kurzem in /var/log/syslog Fehler angezeigt, z.B.

Nov 27 12:10:10 xxx OTRS-CGI-10[27701]: [Error][Kernel::System::GenericInterface::Webservice::WebserviceList][Line:557]: Table 'otrs2.gi_webservice_config' doesn't exist, SQL: 'SELECT id, name FROM gi_webservice_config WHERE valid_id IN (1)'
Nov 27 12:10:10 xxx OTRS-CGI-10[27701]: [Error][Kernel::System::DynamicField::DynamicFieldListGet][Line:937]: Table 'otrs2.dynamic_field' doesn't exist, SQL: 'SELECT id, name, field_order FROM dynamic_field WHERE valid_id IN (1) AND object_type IN ('Ticket') ORDER BY field_order, id'

Die Datenbank heißt bei uns otrs2 statt otrs.
Möglicherweise habe ich ein Update der Datenbank übersprungen.
Wie finde ich heraus, welche Version die Datenbank hat und was ich ändern muss?

Vielen Dank!

LG

dasDing
OTRS newbie
Posts: 54
Joined: 12 Nov 2013, 19:27
OTRS Version?: 4.0.x Linux

Re: Welche Datenbankversion?

Post by dasDing »

Habe es nun gelöst:
DB-Update 3.0, 3.1, 3.2 ausgeführt:
cat /opt/otrs/scripts/DBUpdate-to-3.2.mysql.sql | mysql -p -f -u root otrs etc.

Post Reply