Ubuntu 10.11 Perl Probleme

Hilfe zu OTRS Problemen aller Art
Post Reply
staybb
OTRS expert
Posts: 51
Joined: 01 Jul 2011, 09:39
OTRS Version?: 3.0.4

Ubuntu 10.11 Perl Probleme

Post by staybb »

Hallo,
ich habe OTRS 3.0.11 auf einen Ubuntu Server aufgesetzt. Ich komme auch in die OTRS Übersicht im Browser.
Oberhalb der Navigation kommen allerdings noch folgende Fehlermeldungen:

Code: Select all

Software error:

Can't locate LWP/UserAgent.pm in @INC (@INC contains: /opt/otrs/bin/Custom /opt/otrs/bin/Kernel/cpan-lib /opt/otrs/bin /opt/otrs/bin/cgi-bin/../../Custom /opt/otrs/bin/cgi-bin/../../Kernel/cpan-lib /opt/otrs/bin/cgi-bin/../.. /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at /opt/otrs/bin/cgi-bin/../../Kernel/System/WebUserAgent.pm line 17.
BEGIN failed--compilation aborted at /opt/otrs/bin/cgi-bin/../../Kernel/System/WebUserAgent.pm line 17.
Compilation failed in require at /opt/otrs/bin/cgi-bin/../../Kernel/Output/HTML/DashboardProductNotify.pm line 17.
BEGIN failed--compilation aborted at /opt/otrs/bin/cgi-bin/../../Kernel/Output/HTML/DashboardProductNotify.pm line 17.

For help, please send mail to the webmaster (webmaster@localhost), giving this error message and the time and date of the error.
Content-Type: text/html; charset=utf-8; Content-Disposition: filename="AgentDashboard.html" X-Powered-By: OTRS 3.0.11 - Open Ticket Request System (http://otrs.org/) Expires: Tue, 1 Jan 1980 12:00:00 GMT Cache-Control: no-cache Pragma: no-cache 
Welche perl Pakete fehlen mir? Oder wie kann ich die Fehler beheben?

jojo
Moderator
Posts: 14678
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Ubuntu 10.11 Perl Probleme

Post by jojo »

LWP::UserAgent

hast Du geprüft ob alle Module installiert sind (bin/otrs.checkModules.pl)?
"Production": OTRS™ 7, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) and git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

staybb
OTRS expert
Posts: 51
Joined: 01 Jul 2011, 09:39
OTRS Version?: 3.0.4

Re: Ubuntu 10.11 Perl Probleme

Post by staybb »

Es fehlen noch einige Pakete:
quote]
o CGI............................ok (v3.50)
o Crypt::PasswdMD5...............ok (v1.3)
o CSS::Minifier..................ok (v0.01)
o Date::Format...................ok (v2.24)
o Date::Pcalc....................ok (v1.2)
o DBI............................ok (v1.616)
o DBD::mysql.....................ok (v4.019)
o Digest::MD5....................ok (v2.39)
o Digest::SHA::PurePerl..........ok (v5.48)
o Encode::HanExtra...............Not installed! (Optional - Required to handle mails with several Chinese character sets.)
o GD.............................Not installed! (Optional - Required for stats)
o GD::Text....................Not installed! (Optional - Required for stats.)
o GD::Graph...................Not installed! (Optional - Required for stats.)
o GD::Graph::lines............Not installed! (Optional - Required for stats.)
o GD::Text::Align.............Not installed! (Optional - Required for stats.)
o IO::Scalar.....................ok (v2.110)
o IO::Wrap.......................ok (v2.110)
o JavaScript::Minifier...........ok (v1.05)
o JSON...........................ok (v2.50)
o JSON::PP....................ok (v2.27103)
o JSON::XS....................Not installed! (Optional - Install it for faster AJAX/JavaScript handling.)
o LWP::UserAgent.................Not installed! (Required - use "perl -MCPAN -e shell;" - )
o Mail::Internet.................ok (v2.07)
o Mail::POP3Client...............ok (v2.18 )
o IO::Socket::SSL.............Not installed! (Optional - Required for POP3 SSL connections.)
o MIME::Base64...................ok (v3.08)
o MIME::Tools....................ok (v5.428)
o ModPerl::Util..................Not installed! (Optional - Improves Performance on Apache webservers dramatically.)
o Apache::DBI.................ok (v1.09)
o Apache2::Reload.............Not installed! (Optional - Should be installed on mod_perl based installations to automatically reload changed Perl files and configuration data.)
o Net::DNS.......................Not installed! (Required - use "perl -MCPAN -e shell;" - )
o Net::POP3......................ok (v2.29)
o Net::IMAP::Simple..............ok (v1.2017)
o Net::IMAP::Simple::SSL......Not installed! (Optional - Required for SSL connections.)
o Net::SMTP......................ok (v2.31)
o Authen::SASL................ok (v2.15)
o Net::SMTP::SSL..............Not installed! (Optional - Required for SSL/SMTPS connections.)
o Net::SMTP::TLS::ButMaintainedNot installed! (Optional - Required for TLS/SMTP connections.)
o Net::LDAP......................Not installed! (Optional - Required for directory authentication.)
o PDF::API2......................Not installed! (Optional - Required for PDF output.)
o Compress::Zlib..............ok (v2.024)
o SOAP::Lite.....................Not installed! (Optional - Required for the SOAP interface.)
o Text::CSV......................ok (v1.21)
o Text::CSV_PP................ok (v1.29)
o Text::CSV_XS................Not installed! (Optional - Optional, install it for faster CSV handling.)
o XML::Parser....[/quote]

Ich habe

Code: Select all

perl -MCPAN -e shell
ausgeführt und folgendes erhalten:

Code: Select all

Searching for the best CPAN mirrors (please be patient) ....................................... done!

New urllist
  ftp://mirror.checkdomain.de/CPAN/
  ftp://cpan.noris.de/pub/CPAN/
  ftp://ftp.hosteurope.de/pub/CPAN/
  ftp://cpan.makeperl.org/pub/CPAN/
  ftp://ftp.mirror.8086.net/sites/CPAN/

Autoconfiguration complete.

commit: wrote '/etc/perl/CPAN/Config.pm'
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.9456)
Enter 'h' for help.
Das Paket fehlt weiterhin. Wie bekomme ich diese zum laufen?

jojo
Moderator
Posts: 14678
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Ubuntu 10.11 Perl Probleme

Post by jojo »

man cpan
man apt-get
man apt-cache
"Production": OTRS™ 7, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) and git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

Post Reply