Unable to install OTRS 6 on OEL 7

Links to OTRS Community related sites...
Post Reply
avinashillindra
OTRS expert
Posts: 59
Joined: 31 Mar 2016, 06:13
OTRS Version?: OTRS 5 Free
Real Name: Avinash Illindra

Unable to install OTRS 6 on OEL 7

Post by avinashillindra » 13 Nov 2018, 18:28

Dear Support,

While installing OTRS 6 on OEL 7, facing an issue with perl below those are:

Error: Package: otrs-6.0.12-01.noarch (/otrs-6.0.12-01.noarch)
Requires: perl(Template)
Error: Package: otrs-6.0.12-01.noarch (/otrs-6.0.12-01.noarch)
Requires: perl(XML::LibXSLT)

Please help me to fix the issue.

Regards,
Avinash Illindra

fcasal
OTRS superhero
Posts: 210
Joined: 21 Apr 2014, 16:14
OTRS Version?: 6.0.10

Re: Unable to install OTRS 6 on OEL 7

Post by fcasal » 13 Nov 2018, 19:22

Have you installed all the software packages that are required by otrs?

It seems that something is not installed.

Greetings.

avinashillindra
OTRS expert
Posts: 59
Joined: 31 Mar 2016, 06:13
OTRS Version?: OTRS 5 Free
Real Name: Avinash Illindra

Re: Unable to install OTRS 6 on OEL 7

Post by avinashillindra » 14 Nov 2018, 06:11

I'm following installation document and executed following command:

yum install --nogpgcheck otrs-6.0.12-01.noarch.rpm

and encountering error which I mentioned in previous post.

jojo
Moderator
Posts: 14401
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Unable to install OTRS 6 on OEL 7

Post by jojo » 14 Nov 2018, 06:20

Install perl(XML::LibXSLT)


if this package can not be found on epel you have to install it via cpan. Please also have a look on the admin manual http://doc.otrs.org
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

avinashillindra
OTRS expert
Posts: 59
Joined: 31 Mar 2016, 06:13
OTRS Version?: OTRS 5 Free
Real Name: Avinash Illindra

Re: Unable to install OTRS 6 on OEL 7

Post by avinashillindra » 14 Nov 2018, 06:35

I tried installing using you, it is not perl package, following is the output:

[root@helpdesk ~]# yum install "perl(XML::LibXSLT)"
Loaded plugins: langpacks, ulninfo
epel/x86_64/metalink | 9.0 kB 00:00:00
ol7_UEKR3 | 1.2 kB 00:00:00
ol7_addons | 1.2 kB 00:00:00
ol7_latest | 1.4 kB 00:00:00
No package perl(XML::LibXSLT) available.
Error: Nothing to do
[root@helpdesk ~]#

jojo
Moderator
Posts: 14401
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Unable to install OTRS 6 on OEL 7

Post by jojo » 14 Nov 2018, 10:08

use cpan
"Production": OTRS™ 6, STORM powered by OTRS
"Testing": ((OTRS Community Edition)) git Master

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com :: Share your ideas

Post Reply