Oracle

Moderator: DenisBY

Post Reply
l2qwe
OTRS newbie
Posts: 2
Joined: 23 Oct 2014, 16:01
OTRS Version?: 3.3.9
Real Name: Илья

Oracle

Post by l2qwe » 23 Oct 2014, 16:13

Доброе время суток.

Пытаюсь настроить работы OTRS с СУБД ORACLE (11.0.4)
Делал по инструкции(CentOS 6) http://otrs.github.io/doc/manual/admin/ ... ation.html

/opt/otrs/bin/otrs.CheckModules.pl

Code: Select all

  o Archive::Tar.....................ok (v1.58)
  o Crypt::Eksblowfish::Bcrypt.......Not installed! (optional - For strong password hashing.)
  o Crypt::SSLeay....................ok (v0.57)
  o Date::Format.....................ok (v2.22)
  o DBI..............................ok (v1.609)
  o DBD::mysql.......................ok (v4.013)
  o DBD::ODBC........................Not installed! (optional - Required to connect to a MS-SQL database.)
  o DBD::Oracle......................ok (v1.74)
  o DBD::Pg..........................ok (v2.15.1)
  o Encode::HanExtra.................Not installed! (optional - Required to handle mails with several Chinese character sets.)
  o GD...............................ok (v2.44)
    o GD::Text.......................ok (v0.86)
    o GD::Graph......................ok (v1.44)
  o IO::Socket::SSL..................ok (v1.31)
  o JSON::XS.........................Not installed! (optional - Recommended for faster AJAX/JavaScript handling.)
  o List::Util::XS...................ok (v1.21)
  o LWP::UserAgent...................ok (v6.05)
  o Mail::IMAPClient.................Not installed! (optional - Required for IMAP TLS connections.)
    o IO::Socket::SSL................ok (v1.31)
  o ModPerl::Util....................ok (v2.000004)
  o Net::DNS.........................ok (v0.65)
  o Net::LDAP........................ok (v0.40)
  o PDF::API2........................Not installed! (optional - Required for PDF output.)
    o Compress::Zlib.................ok (v2.021)
  o Text::CSV_XS.....................Not installed! (optional - Recommended for faster CSV handling.)
  o Time::HiRes......................ok (v1.9721)
  o XML::Parser......................ok (v2.36)
  o YAML::XS.........................Not installed! (required - Please install this module - )
вроде бы всё хорошо, перехожу в http://.../otrs/installer.pl

Image


В /etc/httpd/conf.d/zzz_otrs.conf

Code: Select all

SetEnv ORACLE_HOME /usr/lib/oracle/11.2/client64
SetEnv NLS_LANG AMERICAN_AMERICA.UTF8
SetEnv NLS_DATE_FORMAT 'YYYY-MM-DD HH24:MI:SS'

Что я делаю не так ?(

otrs 3.3.9
Linux 3.8.13-44.1.3.el6uek.x86_64 x86_64

Oracle развернут на другом сервере
Oracle Database 11g Release 11.2.0.4.0 - 64bit Production
Linux 3.8.13-44.1.3.el6uek.x86_64 x86_64

alexus
OTRS superhero
Posts: 271
Joined: 20 Sep 2010, 16:54
OTRS Version?: ITSM 5.0.14
Real Name: Alexey Yusov
Company: Radiant System
Location: Prague
Contact:

Re: Oracle

Post by alexus » 25 Oct 2014, 23:27

Надо смотреть логи, скорее всего модуль перловый стоит как-то криво.
Alexey Yusov

Production: OTRS ITSM 5.0.14 on CentOS 7 x64 Linux with MySQL 5.7
Tested: OTRS ITSM 5.0.14
Radiant System OTRS Intergrator
Stay tuned on our Facebook
Get OTRS Professional Services - Consulting, Implementation, Training, Development, Support!

l2qwe
OTRS newbie
Posts: 2
Joined: 23 Oct 2014, 16:01
OTRS Version?: 3.3.9
Real Name: Илья

Re: Oracle

Post by l2qwe » 29 Oct 2014, 12:54

Посмотрел логи апача

Code: Select all

Can't load '/usr/local/lib64/perl5/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: libocci.so.11.1: cannot open shared object file: No such file or directory at /usr/lib64/perl5/DynaLoader.pm line 200.
чутка поковырялся
в итоге

Добавил в /etc/httpd/conf.d/zzz_otrs.conf

Code: Select all

<Directory "/opt/otrs/bin/cgi-bin/">
    AllowOverride None
    Options +ExecCGI -Includes
# Добавил вот эти 2 строки
    PerlSetEnv LD_LIBRARY_PATH  /usr/lib/oracle/11.2/client64/lib 
    PerlSetEnv ORACLE_HOME /usr/lib/oracle/11.2/client64
И еще добавил в /etc/ld.so.conf

Code: Select all

#echo $ORACLE_HOME/lib >> /etc/ld.so.conf
И всё заработало

Post Reply