Search found 93 matches

by SuperDOS
13 Feb 2018, 10:00
Forum: Help
Topic: Get Customer Username/Login for article
Replies: 5
Views: 543

Re: Get Customer Username/Login for article

@crythias Do you think it's possible?
by SuperDOS
09 Feb 2018, 14:40
Forum: Help
Topic: Get Customer Username/Login for article
Replies: 5
Views: 543

Re: Get Customer Username/Login for article

Thanks for your reply. What I'm trying to achieve is adding customer photos in the new "dialog view" of OTRS 6 by modifying the MIMEBase.tt template. <div class="ArticleSenderImage"> <img src="http://URL TO WHERE IMAGES IS STORED/[% Data.ArticleFields.Sender.Login %].jpg" onerror='this.style.display...
by SuperDOS
02 Feb 2018, 14:00
Forum: Help
Topic: Error in log using ACL in OTRS 6
Replies: 2
Views: 261

Re: Error in log using ACL in OTRS 6

There's no error on the page only in the log. Fri Feb 2 08:43:25 2018 error OTRS-CGI-42 Need Data! Fri Feb 2 08:43:25 2018 error OTRS-CGI-42 Need Data! Fri Feb 2 08:43:25 2018 error OTRS-CGI-42 Need Data! Fri Feb 2 08:43:25 2018 error OTRS-CGI-42 Need Data! Fri Feb 2 08:43:25 2018 error OTRS-CGI-42 ...
by SuperDOS
02 Feb 2018, 09:50
Forum: Help
Topic: Error in log using ACL in OTRS 6
Replies: 2
Views: 261

Error in log using ACL in OTRS 6

Hi, After upgrading to OTRS 6 my ACLs is causing a lot of errors when used. error OTRS-CGI-42 Need Data! The ACL hides certain services for if you have different roles. The ACL works but cause the log to be flooded with errors. --- - ChangeBy: '1234' ChangeTime: 2017-03-10 12:26:29 Comment: Hide Cer...
by SuperDOS
01 Feb 2018, 15:09
Forum: Help
Topic: Get Customer Username/Login for article
Replies: 5
Views: 543

Re: Get Customer Username/Login for article

any ideas? is it possible?
by SuperDOS
07 Jan 2018, 19:24
Forum: Help
Topic: Get Customer Username/Login for article
Replies: 5
Views: 543

Get Customer Username/Login for article

Does anyone know if there is a way to get the customer username/login name like [% Data.UserLogin%]?
Tried [% Data.ArticleFields.Sender.Login %] but didn't get anything.

Customer ID would work as well.

Trying to make some customizations to my theme.

Thanks
by SuperDOS
07 Jan 2018, 17:48
Forum: Help
Topic: Custom skin for Customer not registered
Replies: 4
Views: 347

Re: Custom skin for Customer not registered

Thanks, I ended up cleaning out all old XML files and started over with files XML files from a clean 6.0.3 installation. Now it works. Ran these commands after. su -c "/opt/otrs/bin/otrs.Console.pl Maint::Cache::Delete" -s /bin/bash otrs su -c "/opt/otrs/bin/otrs.Console.pl Maint::Config::Rebuild" -...
by SuperDOS
04 Jan 2018, 08:14
Forum: Help
Topic: Custom skin for Customer not registered
Replies: 4
Views: 347

Re: Custom skin for Customer not registered

Yep the files are there and have rebuilt the config.
Nothing in the logs.

Doesn't appear in the sysconfig, my Agent skin/theme does though.
by SuperDOS
03 Jan 2018, 20:12
Forum: Help
Topic: Custom skin for Customer not registered
Replies: 4
Views: 347

Custom skin for Customer not registered

Is there something extra needed to add custom skin for Customer in OTRS 6? ../Config <?xml version="1.0" encoding="utf-8" ?> <otrs_config version="1.0" init="Framework"> <ConfigItem Name="Loader::Customer::Skin###101-test-Cust" Required="0" Valid="1"> <Description Translatable="1">Test Customer Skin...
by SuperDOS
07 Dec 2017, 13:08
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

Anyone know what's needed to be done with Customer skins in OTRS 6?
by SuperDOS
06 Dec 2017, 17:45
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

found this thread
viewtopic.php?t=27319

The ACL that gave the errors works but gives the errors.
Very strange.
by SuperDOS
06 Dec 2017, 17:13
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

Yes after disabling one of the ACL rule it doesn't repport the error anymore.
by SuperDOS
06 Dec 2017, 13:58
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

Maybe some "bad" ACL rule that doesn't work anymore?

Code: Select all

[Wed Dec  6 12:55:16 2017][Error][Kernel::System::Ticket::TicketACL::_CompareMatchWithData][2074] Need Data!
by SuperDOS
06 Dec 2017, 11:58
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

Thanks! now it works

Though I still get a lot of these errors in the system log

Code: Select all

Wed Dec 6 10:55:15 2017	error	OTRS-CGI-42	Need Data!
by SuperDOS
05 Dec 2017, 17:07
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

Yes get the same output as ItemsGmbH when running the PSQL queries
by SuperDOS
05 Dec 2017, 01:52
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

Still no solution to this. This is what's in the log after trying to add a note. TIME PRIORITY FACILITY MESSAGE Tue Dec 5 00:47:29 2017 error OTRS-CGI-42 Can't create meta article (TicketID=27)! Tue Dec 5 00:47:29 2017 error OTRS-CGI-42 ERROR: duplicate key value violates unique constraint "article_...
by SuperDOS
29 Nov 2017, 00:26
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

Re: can't work with tickets, OTRS 6.0.1

anyone?
by SuperDOS
28 Nov 2017, 00:47
Forum: Help
Topic: can't work with tickets, OTRS 6.0.1
Replies: 15
Views: 960

can't work with tickets, OTRS 6.0.1

After upgrading to OTRS 6.0.1 I get this error below when trying to send an email or create notifications, phone call. Any kind of communication. Same error if trying to create a new ticket. Any suggestions? Backend ERROR: OTRS-CGI-42 Perl: 5.16.3 OS: linux Time: Mon Nov 27 23:40:37 2017 Message: Ca...
by SuperDOS
24 Nov 2017, 17:43
Forum: Help
Topic: Dynamic Field - Multi Valued String
Replies: 4
Views: 270

Re: Dynamic Field - Multi Valued String

Ok so I don't really need to add dynamic field to add a new field for custoemr?

I can Simply add for instance [ 'Department', 'Department', 'Department', 1, 0, 'var', '', 0 ], ?

Still need to figure out how to map a multi-valued ad attribute to a field, if it's possible.
by SuperDOS
24 Nov 2017, 17:35
Forum: Help
Topic: Dynamic Field - Multi Valued String
Replies: 4
Views: 270

Re: Dynamic Field - Multi Valued String

But I sync other values from the AD like department, Name, Telehponenumber and so on. # note: Login, Email and CustomerID needed! # var, frontend, storage, shown (1=always,2=lite), required, storage-type, http-link, readonly, http-link-target, link class(es) [ 'UserTitle', 'Title', 'title', 1, 0, 'v...
by SuperDOS
24 Nov 2017, 17:33
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

Is there something extra needed to add custom skin for Customer? Tried doing the same as for Agent skin but feels like something is missing. ../Config <?xml version="1.0" encoding="utf-8" ?> <otrs_config version="1.0" init="Framework"> <ConfigItem Name="Loader::Customer::Skin###101-test-Cust" Requir...
by SuperDOS
24 Nov 2017, 17:27
Forum: Help
Topic: Dynamic Field - Multi Valued String
Replies: 4
Views: 270

Dynamic Field - Multi Valued String

Added a new dynamic text field for customers called computer. Now I want to fetch the serial number from the AD that is stored on the user in the attribute serialnumber In my Config.pm I added a mapping: [ 'DynamicField_Computer', 'Computer', 'serialNumber', 1, 0, 'var', '', 0 ], But all I get is a ...
by SuperDOS
24 Nov 2017, 14:24
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

Thanks, I forgot I added <meta name="format-detection" content="telephone=yes" /> to my HTMLHead.tt

works now
by SuperDOS
24 Nov 2017, 13:55
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

Hmm there's only font-awesome.min.css in the folder.
But on another test system where the icons works there is no font files in that directory either.

Tried clear caching and another browser.

nothing showed when adding a div with fa fa-paperclip

also did a yum reinstall of the otrs rpm
by SuperDOS
24 Nov 2017, 13:22
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

has it something to do with /opt/otrs/Kernel/Output/JavaScript/Templates ?
Not sure the function of this yet.
by SuperDOS
24 Nov 2017, 13:17
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

Image
no console errors.
by SuperDOS
24 Nov 2017, 13:01
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

Hmm any idea why no icons is showing? doesn't help to change back to default theme/skin.
have cleared the cache.
by SuperDOS
24 Nov 2017, 11:51
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Re: Custom Skin not registered OTRS 6

thanks just what i needed
by SuperDOS
24 Nov 2017, 11:03
Forum: Help
Topic: Custom Skin not registered OTRS 6
Replies: 12
Views: 552

Custom Skin not registered OTRS 6

Upgraded to OTRS 6 and now my custom skin isn't registered so you can choose it.
The theme works.
Made a new XML file and added it to the Config dir and rebuild the config, but still it does't show under sysconfig.
Anything different from OTRS 5 that needs to be done?
by SuperDOS
19 Sep 2017, 09:09
Forum: Help
Topic: Clean installation OTRS 6 Beta 1
Replies: 8
Views: 942

Re: Clean installation OTRS 6 Beta 1

Works now in Otrs 6 Beta 2 got error these errors: Module: Kernel::System::Console::InterfaceConsole::Run Line: 80 Module: /opt/otrs/bin/otrs.Console.pl Line: 38 ERROR: OTRS-otrs.Console.pl-Maint::Config::Rebuild-09 Perl: 5.16.3 OS: linux Time: Tue Sep 19 09:05:50 2017 Message: Data was only readabl...
by SuperDOS
11 Sep 2017, 12:39
Forum: Help
Topic: Clean installation OTRS 6 Beta 1
Replies: 8
Views: 942

Re: Clean installation OTRS 6 Beta 1

CentOS 7 minimal installation, SELINUX disabled, EPEL activated and OTRS RPM installation. yes that's exactly how I did the installation. If I go to User administration I get ton of the same error [Mon Sep 11 12:37:36 2017] -e: Use of uninitialized value $UserMailStringParts[1] in join or string at...
by SuperDOS
11 Sep 2017, 11:59
Forum: Help
Topic: Clean installation OTRS 6 Beta 1
Replies: 8
Views: 942

Re: Clean installation OTRS 6 Beta 1

# /opt/otrs/bin/otrs.CheckModules.pl o Apache::DBI......................ok (v1.12) o Apache2::Reload..................ok (v0.13) o Archive::Tar.....................ok (v2.26) o Archive::Zip.....................ok (v1.30) o Crypt::Eksblowfish::Bcrypt.......ok (v0.009) o Crypt::SSLeay...................
by SuperDOS
10 Sep 2017, 11:18
Forum: Help
Topic: Clean installation OTRS 6 Beta 1
Replies: 8
Views: 942

Re: Clean installation OTRS 6 Beta 1

the ldap works fine I can do a lookup of users (until I get the error) and also login with AD credentials.
by SuperDOS
09 Sep 2017, 17:43
Forum: Help
Topic: Clean installation OTRS 6 Beta 1
Replies: 8
Views: 942

Re: Clean installation OTRS 6 Beta 1

Yes all modules up to date, are you running with AD integration?
by SuperDOS
08 Sep 2017, 10:23
Forum: Help
Topic: Clean installation OTRS 6 Beta 1
Replies: 8
Views: 942

Clean installation OTRS 6 Beta 1

Hi, Just installed Otrs 6 Beta 1 one on a new system to test it out. It's on CentOS 7 with local mysql with LDAP/AD integration for users/agents. The issues I get is when trying to create a new ticket and it do a lookup of users (typeahead) I get an error. Also when you try to logon the customer por...
by SuperDOS
31 Jan 2017, 18:36
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal [SOLVED]

Solved it.

had to change scriptalias in sysconfig since changes of URI.
by SuperDOS
30 Jan 2017, 15:35
Forum: Howtos
Topic: How to get rid of /otrs/ in your URI
Replies: 23
Views: 35436

Re: How to get rid of /otrs/ in your URI

Any updates on this?
by SuperDOS
19 Jan 2017, 00:23
Forum: Help
Topic: New errors in log, daemon not working correctly
Replies: 3
Views: 731

Re: New errors in log, daemon not working correctly

seems to work now.

did yum --enablerepo=cr update
and then yum update

rebooted and no error so far.

very weird.
by SuperDOS
18 Jan 2017, 23:31
Forum: Help
Topic: New errors in log, daemon not working correctly
Replies: 3
Views: 731

Re: New errors in log, daemon not working correctly

hmm that's very odd. only done yum updates since I installed Centos 7...

if I run: uname -r
3.10.0-327.22.2.el7.x86_64
by SuperDOS
18 Jan 2017, 18:48
Forum: Help
Topic: New errors in log, daemon not working correctly
Replies: 3
Views: 731

New errors in log, daemon not working correctly

Hi, Starting getting errors I've never seen and the daemon doesn't seem to work properly. Any ideas? Running OTRS Helpdesk 5.15 and CentOS 7.3 (1611) Example: [Wed Jan 18 17:45:11 2017][Error][Kernel::System::ObjectManager::_DieWithError][533] Kernel::System::Email could not be loaded: Attempt to re...
by SuperDOS
27 Jul 2016, 10:44
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal

The error message details from the ckeditor documentation is: filetools-response-error Location: plugins/filetools/plugin.js Description: An error occurred when parsing the upload response. Text could not be parsed to JSON. Additional data: responseText: Upload response text. not sure what to make o...
by SuperDOS
26 Jul 2016, 17:46
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal

Yes I do and it's set to https in sysconfig.

I can't understand why it's working in the agent interface but not in the customer portal.

Have another test otrs setup where it works. "only" difference is on that system I run the database on the same server as the otrs installation.
by SuperDOS
26 Jul 2016, 16:48
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal

ran the debugger in chrome [CKEDITOR] Error code: filetools-response-error. [object Object] "[CKEDITOR] Error code: filetools-response-error." { [functions]: , __proto__: { }, responseText: "<!DOCTYPE html> <html> <!-- --> <!-- OTRS: Copyright 2001-2015, OTRS AG. This Software is under the AGPL. -->...
by SuperDOS
04 Jul 2016, 14:44
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal

Bump this one last time...
by SuperDOS
07 Jun 2016, 15:31
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal

anyone with ideas where to look to resolve this?
by SuperDOS
03 Jun 2016, 12:49
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Re: Can't upload images in customer portal

here's the ssl_request_log [03/Jun/2016:12:36:26 +0200] 192.168.100.70 TLSv1.2 ECDHE-RSA-AES128-GCM-SHA256 "POST /customer.pl?Action=PictureUpload&FormID=1464950179.9942062.72663585&OTRSAgentInterface=VGIgxexEXYLG3gE7idG8tgmb0LwIhxro&CKEditor=RichText&CKEditorFuncNum=0&langCode=en HTTP/1.1" 3736 [03...
by SuperDOS
02 Jun 2016, 16:26
Forum: Help
Topic: Can't upload images in customer portal
Replies: 9
Views: 1452

Can't upload images in customer portal

For some reason the image upload function doesn't work in the customer portal. If I use the copy paste function I get this: http://i.imgur.com/fmbe28s.png And if using the image upload function I get a login page?! http://i.imgur.com/YOhObW2.png I'm on OTRS 5.10 with ITSM. CentOS and Apache with the...
by SuperDOS
22 Jan 2016, 16:16
Forum: Help
Topic: Dashboard report Backlog/New Tickets
Replies: 3
Views: 512

Re: Dashboard report Backlog/New Tickets

Hmm seems to be stuck, not that good at perl. :)
Anyome have any tips?
by SuperDOS
19 Jan 2016, 15:27
Forum: Help
Topic: Dashboard report Backlog/New Tickets
Replies: 3
Views: 512

Re: Dashboard report Backlog/New Tickets

Thanks, think I'm on the right track.
I made a copy of Ticket Queue OverView and changed it to Ticket backlog.
So now I have a dashlet but it's the same info as the Ticket Queue Overview.
Need to figure out what to change in the TicketBacklog.pm
by SuperDOS
18 Jan 2016, 17:31
Forum: Help
Topic: Dashboard report Backlog/New Tickets
Replies: 3
Views: 512

Dashboard report Backlog/New Tickets

Hi, I'm trying to find out if you can create a report of how many open/new Tickets created during the current day and how many open/new tickets that are older than 24 hours. If you could present it on the dashboard that would be great, much like the ticket queue overview. Any ideas? Would look somet...