Trouble setting up HTTPBasicAuth

Moderator: crythias

mmanis
OTRS newbie
Posts: 1
Joined: 02 Jan 2018, 23:39
OTRS Version?: 6.0.2

Trouble setting up HTTPBasicAuth

Postby mmanis » 03 Jan 2018, 00:39

I am trying to set up HTTPBasicAuth so that when visiting the login page, if the REMOTE_USER environment variable is set, that username is logged in to the dashboard as if they had signed in normally. I am able to get the REMOTE_USER variable set (if the correct authorization is provided to Apache) but I am seemingly unable to get OTRS to do anything meaningful with the variable. When it is set, I am sent to a "redirect" page that goes nowhere, regardless of if the user exists in the DB or not.

My config is set:

Code: Select all

    $Self->{'Customer::AuthModule'} = 'Kernel::System::CustomerAuth::HTTPBasicAuth';
    $Self->{'CustomerPanelLoginURL'} = 'https://mysite/unauthorized.html';
    $Self->{'CustomerPanelLogoutURL'} = 'https://mysite/logout.html';

    $Self->{'AuthModule'} = 'Kernel::System::Auth::HTTPBasicAuth';
    $Self->{'LoginURL'} = 'https://mysite/otrs/index.pl';
    $Self->{'LogoutURL'} = 'https://mysite/logout.html';


I gather that there must be more to it than that, but I cannot find anything in the documentation. On the forums I see plenty of posts about Active Directory, but all I need is for OTRS to trust the REMOTE_USER variable and log that user in as if they had typed their password.

fcollerette
OTRS newbie
Posts: 24
Joined: 27 Dec 2017, 20:40
OTRS Version?: 6.0.2-03

Re: Trouble setting up HTTPBasicAuth

Postby fcollerette » 26 Jan 2018, 15:24

Hi,

did you got it to work ?

I'm trying to finalize this setup for my agents.

Any tips ?


Return to “Help”

Who is online

Users browsing this forum: No registered users and 9 guests

cron