[SOLVED] Service stays loading and never Shows

Moderator: crythias

iclaude
OTRS newbie
Posts: 33
Joined: 31 Mar 2016, 10:30
OTRS Version?: OTRS 5.0.23 Free
Real Name: Claude Chelene

[SOLVED] Service stays loading and never Shows

Postby iclaude » 05 Oct 2017, 09:53

Please Help I am having problems with the Services in my OTRS Tickets on the Agent page.
When I open the services they just stay loading and never show.
Last edited by iclaude on 16 Oct 2017, 15:53, edited 2 times in total.
OTRS 5.0.23/OpenSuse
MySql

reneeb
OTRS guru
Posts: 4363
Joined: 13 Mar 2011, 09:54
OTRS Version?: 3.3.x
Company: Perl-Services.de
Contact:

Re: Service stays loading and never Shows

Postby reneeb » 05 Oct 2017, 11:08

Check the webserver log and open the developer tools of your browser. Check the JavaScript console and/or the network tab if any errors are reported.
Perl / OTRS development: http://perl-services.de
Free OTRS add ons from the community: http://opar.perl-services.de
Commercial add ons: http://feature-addons.de

iclaude
OTRS newbie
Posts: 33
Joined: 31 Mar 2016, 10:30
OTRS Version?: OTRS 5.0.23 Free
Real Name: Claude Chelene

[SOLVED] Service stays loading and never Shows

Postby iclaude » 06 Oct 2017, 09:02

reneeb wrote:Check the webserver log and open the developer tools of your browser. Check the JavaScript console and/or the network tab if any errors are reported.


With the browser Developer Tools I get this:

var tid=false,i,j,c,e,tmp;do{tid='j'+t_id+'_'+(++t_cnt);}while(m[tid]);tmp={id:false,text:typeof d==='string'?d:'',icon:typeof d==='object'&&d.icon!==undefined?d.icon:true,parent:p,parents:ps,children:[],children_d:[],data:null,state:{},li_attr:{id:false},a_attr:{href:'#'},original:false};for(i in [ERROR MESSAGE: Unable to get property 'icon' of undefined or null reference] df){if(df.hasOwnProperty(i)){tmp.state[i]=df[i];}}

Can you Help?

Regards
Last edited by iclaude on 16 Oct 2017, 15:53, edited 2 times in total.
OTRS 5.0.23/OpenSuse
MySql

reneeb
OTRS guru
Posts: 4363
Joined: 13 Mar 2011, 09:54
OTRS Version?: 3.3.x
Company: Perl-Services.de
Contact:

Re: Service stays loading and never Shows

Postby reneeb » 06 Oct 2017, 09:17

I doubt that this is the error message (this may be the code that causes an error). Can you post the error message?
Perl / OTRS development: http://perl-services.de
Free OTRS add ons from the community: http://opar.perl-services.de
Commercial add ons: http://feature-addons.de

iclaude
OTRS newbie
Posts: 33
Joined: 31 Mar 2016, 10:30
OTRS Version?: OTRS 5.0.23 Free
Real Name: Claude Chelene

[SOLVED] Service stays loading and never Shows

Postby iclaude » 06 Oct 2017, 09:20

reneeb wrote:I doubt that this is the error message (this may be the code that causes an error). Can you post the error message?



Here it is

ERROR MESSAGE: Unable to get property 'icon' of undefined or null reference
Last edited by iclaude on 16 Oct 2017, 15:53, edited 1 time in total.
OTRS 5.0.23/OpenSuse
MySql

iclaude
OTRS newbie
Posts: 33
Joined: 31 Mar 2016, 10:30
OTRS Version?: OTRS 5.0.23 Free
Real Name: Claude Chelene

[SOLVED] Service stays loading and never Shows

Postby iclaude » 16 Oct 2017, 15:44

Solved!

Since we were having problems in our test environment installation we just had to copy all files from the following directories from our production environment :

/opt/otrs/var/httpd/htdocs/skins/Customer/default/css


/opt/otrs/var/httpd


/opt/otrs/Kernel/Output

Regards
OTRS 5.0.23/OpenSuse
MySql


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests