Another Impossible to send message to:

Moderator: crythias

Capcap
OTRS newbie
Posts: 3
Joined: 25 Sep 2017, 15:22
OTRS Version?: 5.0.23
Real Name: Martin
Company: Capana

Another Impossible to send message to:

Postby Capcap » 25 Sep 2017, 16:25

Hi,

Since we migrated our OTRS server to a new machine we are having this Impossible to send message error.
It seems to be very random, at first, we thought that it only effected tickets that was created before the migration but the issue now also happens when answering through OTRS for new tickets as well, all our agent has been effected by this issue when answering on some tickets. But we are unable to see any connection why we could answer some and some not. We have even been denied on a specific ticket one day, but the day after we are able to use OTRS to answer. But usually the ticket we are unable to answer on through OTRS error persists every time we try.

The error never occurred before the migration and we have kept the same setup for everything, only changed the account on sendmail but use the same kind of setup.

Sendmail setup:
SMTPTLS
Host: smtp.office365.com
Port: 587

Error message:

Code: Select all

[Mon Sep 25 08:50:05 2017] -e: Net::SMTP::_SSL: Net::Cmd::datasend(): unexpected EOF on command channel:  at /opt/otrs/Kernel/System/Email/SMTP.pm line 170.
ERROR: OTRS-CGI-10 Perl: 5.22.1 OS: linux Time: Mon Sep 25 08:50:05 2017

 Message: Can't send message: 421[Net::SMTP::_SSL] Connection closed! Enable Net::SMTP debug for more info!

 RemoteAddress: 1.11.11.11
 RequestURI: /admin

 Traceback (71929):
   Module: Kernel::System::Email::SMTP::Send Line: 172
   Module: Kernel::System::Email::Send Line: 769
   Module: Kernel::System::Ticket::Article::ArticleSend Line: 2263
   Module: Kernel::Modules::AgentTicketCompose::Run Line: 859
   Module: Kernel::System::Web::InterfaceAgent::Run Line: 1054
   Module: ModPerl::ROOT::ModPerl::Registry::opt_otrs_bin_cgi_2dbin_index_2epl::handler Line: 40
   Module: (eval) (v1.99) Line: 207
   Module: ModPerl::RegistryCooker::run (v1.99) Line: 207
   Module: ModPerl::RegistryCooker::default_handler (v1.99) Line: 173
   Module: ModPerl::Registry::handler (v1.99) Line: 32

[Mon Sep 25 08:50:05 2017] -e: Net::SMTP::_SSL: Net::Cmd::_is_closed(): unexpected EOF on command channel:  at /opt/otrs/Kernel/System/Email/SMTP.pm line 176.
ERROR: OTRS-CGI-10 Perl: 5.22.1 OS: linux Time: Mon Sep 25 08:50:05 2017

 Message: Impossible to send message to: name"company.com .

 RemoteAddress: 1.11.11.11
 RequestURI: /admin

 Traceback (71929):
   Module: Kernel::System::Ticket::Article::ArticleSend Line: 2270
   Module: Kernel::Modules::AgentTicketCompose::Run Line: 859
   Module: Kernel::System::Web::InterfaceAgent::Run Line: 1054
   Module: ModPerl::ROOT::ModPerl::Registry::opt_otrs_bin_cgi_2dbin_index_2epl::handler Line: 40
   Module: (eval) (v1.99) Line: 207
   Module: ModPerl::RegistryCooker::run (v1.99) Line: 207
   Module: ModPerl::RegistryCooker::default_handler (v1.99) Line: 173
   Module: ModPerl::Registry::handler (v1.99) Line: 32


Any help would be helpful, been struggling with this error for over 1 month and tried everything that we could find on this forum.

jojo
Moderator
Posts: 13941
Joined: 26 Jan 2007, 14:50
OTRS Version?: Git Master
Contact:

Re: Another Impossible to send message to:

Postby jojo » 25 Sep 2017, 16:34

Use sendmail for sending mails. This is more flexible and also would allow authentication e.g. via postfix
"Production": OTRS5, OTRS::ITSM5, SIRIOS 2.3
"Testing": OTRS git Master
OS: Ubuntu / Apache2/MySQL 5+

Never change Defaults.pm! :: Blog
Professional Services:: http://www.otrs.com :: enjoy@otrs.com

lexan76
OTRS newbie
Posts: 1
Joined: 25 Sep 2017, 14:52
OTRS Version?: 5.0.15
Real Name: Fredrik Edenlind
Company: Capana Sweden AB

Re: Another Impossible to send message to:

Postby lexan76 » 26 Sep 2017, 07:16

Hej jojo

Does this mean that this is a known problem with this other way of sending emails?

I saw many others getting this error so myabe its a known limitation?

thx

Capcap
OTRS newbie
Posts: 3
Joined: 25 Sep 2017, 15:22
OTRS Version?: 5.0.23
Real Name: Martin
Company: Capana

Re: Another Impossible to send message to:

Postby Capcap » 28 Nov 2017, 15:42

Hi,

We are still facing this problem, have tried different email providers/ports and a lot of other tweaks, but problem remains.

However, we did find the following in the logs when comparing successful replies and unsuccessful replies.
Successful email end with the following in the log:

Code: Select all

Net::SMTP::_SSL=GLOB(0x562f665a9368)>>> ze:10pt">Admin OTRS.</span></body></html>=
Net::SMTP::_SSL=GLOB(0x562f665a9368)>>>
Net::SMTP::_SSL=GLOB(0x562f665a9368)>>> ------------=_1555855655-58337-0--
Net::SMTP::_SSL=GLOB(0x562f665a9368)>>> .
Net::SMTP::_SSL=GLOB(0x562f665a9368)<<< 250 2.7.1 <1999999999.999999.999999999@ emailadress.com>


Unsuccessful email end with the following:

Code: Select all

Net::SMTP::_SSL=GLOB(0x5568bc5014a0)>>> ze:10pt">Admin OTRS.</span></div></body></html>=
Net::SMTP::_SSL=GLOB(0x5568bc5014a0)>>>
Net::SMTP::_SSL=GLOB(0x5568bc5014a0)>>> ------------=_1555855699-58898-0--
[Tue Nov 28 08:54:55 2017] -e: Net::SMTP::_SSL: Net::Cmd::datasend(): unexpected EOF on command channel:  at /opt/otrs/Kernel/System/Email/SMTP.pm line 170.


The only different what we can find is this seperate row with a "."

Code: Select all

Net::SMTP::_SSL=GLOB(0x562f665a9368)>>> .


And my guess is that this dot needs to be present for the email to end due to:

Code: Select all

<<< 354 Start mail input; end with <CRLF>.<CRLF>


We are unable to figure out what is causing this EOF dot to be present and not present for a reply.

Anyone have any input?

Capcap
OTRS newbie
Posts: 3
Joined: 25 Sep 2017, 15:22
OTRS Version?: 5.0.23
Real Name: Martin
Company: Capana

Re: Another Impossible to send message to:

Postby Capcap » 06 Dec 2017, 12:16

*Update*

Seems like our error is connected to Ticket::Frontend::ResponseFormat
The format we use is the standard:

Code: Select all

[% Data.Salutation | html %]
[% Data.StdResponse | html %]
[% Data.Signature | html %]

[% Data.Created | Localize("TimeShort") %] - [% Data.OrigFromName | html %] [% Translate("wrote") | html %]:
[% Data.Body | html %]


And if we remove the last row from the format:

Code: Select all

[% Data.Body | html %]

Everything seems to work, the testing we have done have resulted in no error so far.
But why?, and how can we work around this, it is important for us to have the old message in each reply so we don’t want to remove this.

Br
Martin


Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 7 guests