Error when search output to Excel

Moderator: crythias

lukbec
OTRS newbie
Posts: 22
Joined: 20 Apr 2012, 15:03
OTRS Version?: 2.4.6

Error when search output to Excel

Postby lukbec » 14 Jul 2017, 15:09

Hello,

when I search ticket and change output to excel I have the following error:

Can't locate object method "newdir" via package "File::Temp" at /opt/otrs/Kernel/cpan-lib/Excel/Writer/XLSX/Workbook.pm line 916. ,

This is a new clean installation otrs 5.0.20 on SUSE Linux Enterprise Server 11 SP4.

Any idea ?

zypper install perl-File-Temp
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
'perl-File-Temp' is already installed.
No update candidate for 'perl-File-Temp-0.2304-12.5.noarch'. The highest available version is already installed.


I checked the permissions and modules of the perl.

perl /opt/otrs/bin/otrs.CheckModules.pl
o Apache::DBI......................ok (v1.12)
o Apache2::Reload..................ok (v0.13)
o Archive::Tar.....................ok (v1.38)
o Archive::Zip.....................ok (v1.24)
o Crypt::Eksblowfish::Bcrypt.......Not installed! Use: 'zypper install perl-Crypt-Eksblowfish' (optional - For strong password hashing.)
o Crypt::SSLeay....................Not installed! Use: 'zypper install perl-Crypt-SSLeay' (optional - Required for Generic Interface REST transport and SOAP SSL connections.)
o Date::Format.....................ok (v2.22)
o DBI..............................ok (v1.607)
o DBD::mysql.......................ok (v4.008)
o DBD::ODBC........................Not installed! (optional - Required to connect to a MS-SQL database.)
o DBD::Oracle......................Not installed! (optional - Required to connect to a Oracle database.)
o DBD::Pg..........................Not installed! Use: 'zypper install perl-DBD-Pg' (optional - Required to connect to a PostgreSQL database.)
o Digest::SHA......................ok (v5.45)
o Encode::HanExtra.................Not installed! Use: 'zypper install perl-Encode-HanExtra' (optional - Required to handle mails with several Chinese character sets.)
o IO::Socket::SSL..................ok (v1.38)
o JSON::XS.........................ok (v3.03)
o List::Util::XS...................ok (v1.42)
o LWP::UserAgent...................ok (v6.13)
o Mail::IMAPClient.................Not installed! Use: 'zypper install perl-Mail-IMAPClient' (optional - Required for IMAP TLS connections.)
o IO::Socket::SSL................ok (v1.38)
o Authen::SASL...................Not installed! Use: 'zypper install perl-Authen-SASL' (optional - Required for MD5 authentication mechanisms in IMAP connections.)
o Authen::NTLM...................Not installed! Use: 'zypper install perl-Authen-NTLM' (optional - Required for NTLM authentication mechanism in IMAP connections.)
o ModPerl::Util....................ok (v2.000004)
o Net::DNS.........................ok (v0.63)
o Net::LDAP........................Not installed! Use: 'zypper install perl-ldap' (optional - Required for directory authentication.)
o Template.........................ok (v2.26)
o Template::Stash::XS..............ok (undef)
o Text::CSV_XS.....................Not installed! Use: 'zypper install perl-Text-CSV_XS' (optional - Recommended for faster CSV handling.)
o Time::HiRes......................ok (v1.9711)
o Time::Piece......................ok (v1.12)
o XML::LibXML......................ok (v1.66)
o XML::LibXSLT.....................Not installed! Use: 'zypper install perl-XML-LibXSLT' (optional - Required for Generic Interface XSLT mapping module.)
o XML::Parser......................ok (v2.36)
o YAML::XS.........................ok (v0.59)

Return to “General”

Who is online

Users browsing this forum: No registered users and 8 guests