DB Upgrade from 2.4.9 to 5.0.18

Moderator: crythias

swick
OTRS newbie
Posts: 2
Joined: 21 Apr 2017, 15:17
OTRS Version?: 2.4.9

DB Upgrade from 2.4.9 to 5.0.18

Postby swick » 21 Apr 2017, 15:34

Hi,

we have a very old installation ( 2.4.9) with a large database ( ~ 20 GB ) and want to upgrade to 5.0.18.

I have a now a fresh installation with 5.0.18 running.

Can I just upgrade the old database with the DBUpdate-to*.sql files from each major version?

Code: Select all

./otrs-3.0.22/scripts/DBUpdate-to-3.0.mysql.sql
./otrs-3.0.22/scripts/DBUpdate-to-3.0-post.mysql.sql
./otrs-3.1.21/scripts/DBUpdate-to-3.1.mysql.sql
./otrs-3.1.21/scripts/DBUpdate-to-3.1-post.mysql.sql
./otrs-3.2.18/scripts/DBUpdate-to-3.2.mysql.sql
./otrs-3.3.16/scripts/DBUpdate-to-3.3.mysql.sql
./otrs-4.0.23/scripts/DBUpdate-to-4.mysql.sql
./otrs-5.0.18/scripts/DBUpdate-to-5.mysql.sql


What about these 'DBUpdate-to*.pl' perl scripts?

Do I need them as well?

But they not only change something with the database they also do other things
which could break my new installation.

root
Moderator
Posts: 699
Joined: 18 Dec 2007, 12:23
OTRS Version?: 5.0.x
Real Name: Roy Kaldung
Company: Znuny Inc.
Contact:

Re: DB Upgrade from 2.4.9 to 5.0.18

Postby root » 21 Apr 2017, 15:49

Yes, you'll need also the DBUpdate-to*.pl files
It's a step-by-step procedure, please check the documentation carefully, afaik there is one step with an pre and post sql file.
OTRS 4 /5 CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

You need professional services? Check out http://znuny.com/

swick
OTRS newbie
Posts: 2
Joined: 21 Apr 2017, 15:17
OTRS Version?: 2.4.9

Re: DB Upgrade from 2.4.9 to 5.0.18

Postby swick » 21 Apr 2017, 17:28

ok. thank you for the quick reply.


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests