SSO / Single Sign On / LDAP Customer

Howto's zu OTRS Themen. Keine neuen Topics mit Fragen in diesem Forum!
AyKay
OTRS newbie
Posts: 14
Joined: 07 Jun 2013, 08:00
OTRS Version?: 3.2.7

SSO / Single Sign On / LDAP Customer

Postby AyKay » 24 Jul 2013, 09:52

Hallo Zusammen!

Da ich sehr lange mir die Infos selbst zusammen suchen musste und keiner bereit ist einfach eine "Lösung" zu posten sondern immer nur Kommentare kommen wie "benutz doch die SuFu"(auch wenn die SuFu 20.000 verschiedene Ansätze bringt aber nicht die Lösung) mache ich das jetzt.

Zur Bearbeitung von den Files empfiehlt sich das Programm "Notepad++". Es funktioniert aber auch mit dem "normalen" Editor. Zudem empfehle ich euch die Datei "OTRS\otrs4win\Scripts\OTRSServicesRestart.bat" zu bearbeiten und am Ende der Datei ein "PAUSE" einzufügen(ohne ""). Dadurch hat man die Möglichkeit Fehler zu erkennen.

Mein System mit dem es funktioniert:

OTRS Server OS: Windows Server 2008 R2 Standard x64 in Domäne eingebunden
OTRS Version: 3.2.3 Installer 2.4.6 (Ich habe diese Version gewählt, da hier der Apache nicht nach 5 Minuten sich verabschiedet)
Verwendung von Apache 2.2

DC OS: Windows Server 2003 R2 Full Updates

Als erstes sollte die config.pm angepasst werden. Im Anhang findet ihr ein Textfile welches ihr an 6 Stellen anpassen müsst. Als erstes alle 4 Variablen richtig konfigurieren. Danach bei der "Agenten Authentifizierung" den Punkt "mydomain\\" anpassen. Zu guter Letzt noch bei "Kunden Authentifizierung" den Punkt "mydomain\\".
Jetzt könnt ihr den Text komplett in eure config.pm übernehmen. Wer Login+Logout URL verwenden möchte, kann das gerne tun, bei mir ist es unrelevant.

EDIT: Ihr müsst eure vorhandene config.pm bearbeiten (meine config reinkopieren) und NICHT einfach mein File nehmen(bei mir fehlen die Einstellungen eures Server).

Als zweites solltet ihr die Module einfügen unter *euer OTRS Verzeichnis*\Apache\modules\.

Als drittes steht die Bearbeitung der httpd.conf auf dem Programm.
Direkt in Zeile 60 habe ich eingefügt:

Code: Select all

LoadModule sspi_auth_module modules/mod_auth_sspi.so


Ab Zeile 343 habe ich folgendes eingefügt:

Code: Select all

###############SSO#################
<Directory "D:/Apps/OTRS/OTRS/bin/cgi-bin">
   SSPIAuth On
   SSPIAuthoritative On
   SSPIDomain mydomain.local
   SSPIUsernameCase lower
   SSPIOfferBasic On
   Require valid-user
   Options +ExecCGI -Includes
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>
<Location /OTRS/>
    AuthName "My OTRS"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIDomain mydomain.local
    SSPIOmitDomain on
#   SSPIOfferBasic on
    Require valid-user
</Location>
<Directory /OTRS>
    Options FollowSymLinks
    AllowOverride None
    AuthName "---!"   
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIDomain mydomain.local
    SSPIOmitDomain on
#   SSPIOfferBasic on
    Require valid-user
</Directory>
<Location /otrs/>
    AuthName "My OTRS"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIDomain mydomain.local
    SSPIOmitDomain on
#   SSPIOfferBasic on
    Require valid-user
</Location>
<Directory /otrs>
    Options FollowSymLinks
    AllowOverride None
    AuthName "---!"   
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIDomain mydomain.local
    SSPIOmitDomain on
#   SSPIOfferBasic on
    Require valid-user
</Directory>
###############End SSO#################

Ich habe nichts herausgelöscht oder überschrieben. Wichtig ist nur die Anpassung von "mydomain.local" überall. Im Anhang findet ihr auch nochmal die komplette httpd.conf (Ich empfehle aber "nur" die Änderung zu nehmen, da ansonsten alle Pfade aus meiner httpd.conf angepasst werden müssen). Wichtig ist zudem noch die Anpassung des korrekten Pfades. Bei mir ist der Pfad D:/Apps/***** und verwendet "/" statt "\"

Jetzt sollten die Services neugestartet werden und SSO sollte funktionieren.

Für die LDAP-Anbindung habe ich die Infos von boris hier aus dem Forum verwendet. Bei Fragen(Verbesserungen) fragt, aber nicht per PM. Jeder soll davon profitieren.
You do not have the required permissions to view the files attached to this post.
Last edited by AyKay on 02 Aug 2013, 11:58, edited 1 time in total.

prichter
OTRS newbie
Posts: 34
Joined: 22 Jan 2013, 12:22
OTRS Version?: 3.0.1

Re: SSO / Single Sign On / LDAP Customer

Postby prichter » 25 Jul 2013, 08:45

Das Thema kommt gerade zum richtigen Zeitpunkt.
Du hast ja im Anhang noch das eine Apache Module eingefügt, kannst du dazu noch etwas sagen? wo es bspw. hingezipt werden soll?
OTRS 3.1.12 , Win Server 2008 R2, Apache 2.2

prichter
OTRS newbie
Posts: 34
Joined: 22 Jan 2013, 12:22
OTRS Version?: 3.0.1

Re: SSO / Single Sign On / LDAP Customer

Postby prichter » 25 Jul 2013, 09:25

Hallo, danke erstmal, das ist genau das was ich brauche.
Ich habe bisher nur folgendes Problem, mein Apache (Vers 2.2.) startet nicht:
Folgender Fehler aus dem Ereignisprotokoll:
The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 60 of C:/Program Files (x86)/OTRS/Apache/conf/httpd.conf: LoadModule takes two arguments, a module name and the name of a shared object file to load it from


Grüße
OTRS 3.1.12 , Win Server 2008 R2, Apache 2.2

Leavar
OTRS newbie
Posts: 8
Joined: 23 Oct 2013, 13:06
OTRS Version?: 3.2.5
Real Name: Rafael

Re: SSO / Single Sign On / LDAP Customer

Postby Leavar » 24 Oct 2013, 12:52

Hey AyKey,

danke für deine Mühe und die so detaillierte Anleitung.
Gern würde ich deiner Anleitung folgen, doch verwenden wir den IIS 7 der leider nicht zu 100% kompatibel mit deiner Anleitung ist.
Was genau muss ich beachten bzw. verändern damit es auch bei mir klappt?

VG

addseo2015
OTRS newbie
Posts: 1
Joined: 02 Jun 2015, 06:27
OTRS Version?: 12345

Re: SSO / Single Sign On / LDAP Customer

Postby addseo2015 » 03 Jun 2015, 08:52

Dadurch hat man die Möglichkeit Fehler zu erkennen.


Return to “Howto's”

Who is online

Users browsing this forum: No registered users and 1 guest